Backup failed at XX:XX:XX / Error backing up database

Core Machine (Operating system/System info/Roon build number)

MacMini (Late 2012-High Sierra) w/ latest roonserver sw

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

1Gbps wired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I am getting an error while backing up database. (see pic below)

My scheduled backup was working fine until I ran a manual backup (I was in the process of migrating to a new machine). I somehow suspect that file names with special characters (European letters, accent marks, etc.) in my NAS library (Synology w/ SMB service) are causing the trouble. Then again, the scheduled backups were running find for many months. Last successful backup was made 4 days ago with 30 backups 4 days apart spanning as far back as November last year. I have about 640K tracks with 16GB memory in the core machine.

I just googled about an error message that my mac finder is giving out when trying to copy some of my library (NAS) files to a directory, namely:

The operation can’t be completed because one or more required items can’t be found (Error code -43).

Google says something like:

Wow, good you have backups. Looks like your drive might be failing.
Hope your music files are backed up.

Does Roon play music?
Have you added any new music since the last successful backup?

tagging @support.

Music plays fine. I added a few albums since the last backup but not that many so I can pick it up again from the last backup.

I strongly suspect that some accented characters in the file names are causing the trouble. It seems there are two types of accented characters. One is plain Alt+code type and the other Combining Diacritical Marks. My Synology file system seems to differentiate the 2 types while mac OS does not and end up giving me an error when one (roon or human via finder) tries to access a file with Combining Diacritical Marks in its name (no issue for the normal Alt+code accented characters). Windows files system seems to differentiate the 2 types so no issue there. Any mac / file system / character set expert care to shed some light upon this matter? Or I might have to convert mac os to windows to avoid this issue in the future. One question still remains. It was working fine and why the trouble all of a sudden. I do not think anything is broken in my playback chain. I would appreciate your help.

Sorry, out of my depth with macOS.

Support might have some answers or a MAC expert will come along.

You could, as an experiment, remove the files you think are the trouble and then see if backups start to work again.

Thank you for your kind input. I tried to find files with those special characters in the Windows explorer but it does not seems to differentiate the 2 types so I gave up (too many matched files to inspect manually). I only wish that there is a debug mode in the roon backup process so one would know when and by what file the process was stopped. Or roon team can monitor the process remotely. This backup process goes on for like 3 hours then fail. Backup time was more manageable when running in an incremental fashion but doing a full backup seems to be a 3 hour+ job.

As indicated in the article you linked to, “This operation can’t be completed …” error are typically symptoms of either filesystem corruption (run Disk Utility to fix that) or incorrect file permissions. Since the latter seems less likely, I’d go straight to Disk Utility.

Indeed, Macos and Linux differ in how they do unicode normalization. Macos uses NFD; Linux (and Windows) use NFC. This could definitely be an issue if you are backing up files with non-ASCII filenames.

I’ve definitely run into similar issues when using rsync to copy files between Macos and a Linux fileserver. Here’s a discussion of doing the requisite filename conversions on-the-fly.

But Roon backuos don’t touch your music files. They ares solely concerned with backing up the Roon database. So I am puzzled that an issue with filenames would crop up in backing up the Roon database.

Hello @shinyc, I can help! Could you please try backing up to another drive and seeing if that’s successful? That would help narrow down where the issue is.

Hi @nuwriy,

First, let me show you how my various disks are setup.

  1. Music files are on Synology NAS (NFC, only SMB turned on).
  2. “Roonserver” directory resides on an external SSD with MacOS (NFD) connected to Mac mini (Roon core machine).

I used to backup roonserver files to the Synology NAS. But this time I will backup the files to the SSD (NFD) connected to Mac mini and let you know if it succeeds.

Thanks for the info! And yes, please let me know if backing up to another location is successful.

Hi @nuwriy,

Just to be on the base ground again, I switched back to the original config. That is, Roonserver directory resides on the internal HDD. Then, I tried to backup the roon database to the directly attached SSD (instead to the NAS, in which way I was getting the issue). The same error message is returned.

I did another experiment, I did a fresh install of Mac OS and roonserver on an external SSD and restored the last successful backup (date stamped 4/4) to the roon. The restore process finished with no error message. Then, I performed a fullback up, one to the same SSD drive and another to the Synology NAS. Both backups finished without an error message.

So I kinda suspect that there may have been some corruption occurred since 4/4. I still wish that I can create a backup set from the roonserver directory on the original drive and be able to restore it to the newly installed roon (on the external SSD). I would appreciate if you can help me troubleshoot this.

Thank you.

Hey @shinyc, thanks for the info! For the next step, please make one more backup using your original configuration and provide me with logs once you’re done? I’d like to take a look at those logs and see what pops out.

In a moment, I’ll send you a personal message with a link where you can upload your log file. You can find directions for creating that log here.

Hi @shinyc ------ Thank you again for your patience while our technical team has been looking into this issue for you.

I spoke with our team today regarding their evaluation of the logs from your install. Sometimes, errors like the one you saw can be spurious, but unfortunately in this case they are seeing signs of low-level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced to what looks like backups failing while trying to access a missing image file, but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to install Roon fresh on your Core machine, and roll back to one of your backups. If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any backups, unfortunately you will need to start with a fresh database.

Again, this class of issue is extremely rare for us, and you have our apologies for the trouble here.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.