Backup failing running ROON ROCK on NUC

Im Running ROON ROCK on a NUC and get the message: Backup failed at xx:xx backup directory not available?

What are you backing up to? Is it connected via a network?
You will get the issue solved faster if you enter in all the necessary info about your setup as described here: I'm having a problem with Roon -- where do I report it?
When I’ve had this problem its because my network drive somehow disconnected from the system.

I’m backing up to a drive in the NUC

Can you share a screenshot of the backup path?
Settings>Backup>Scheduled Backups

Can you see the backup location in your File Explorer/Finder?


Please see attached

Is this a thumb drive or a larger USB drive?
It looks like it was originally formatted on a Windows computer. Do you know if it was exFAT? Have you backed up to this drive already (yesterday?).
I suppose you have already tried to eject the drive and remount it on the Nuc?
You might want to take a look at this post and try some of the steps suggested there.

If no luck there, @support will need to take a look at what’s going on.

I’m running a 1tb SSD inside the NUC. This holds the library and the backups. The music access is fine

Hi @Adrian_Windo,

Can you please try rebooting your ROCK? It would be interesting to note if manual triggered backups experience this behavior, can you try to start a manual backup by going to Backups -> Backup Now and let me know if that works? Also, what is the exact model/manufacturer of the 1tb SSD you have installed inside the NUC?

– Noris

Yes i did a reboot and manually triggered a backup, same issue and message. The drive is a Crucial MX500 1TB SATA 2.5"

Hi @Adrian_Windo,

Thanks for trying the manual backup. The next step here would be to enable diagnostics mode for your account, which I have just done so. What this action will do is next time your Core is active a set of logs will automatically be generated and uploaded to our servers for analysis. Once these are recieved, I will consult with QA regarding the specific failure state. I will be sure to let you know once I have more info to share regarding you case and thanks in advance for your patience here!

– Noris

Hi Norris

Many thanks. I shall be away from home until Friday so their will be no traffic until then


1 Like

Hi @Adrian_Windo,

Thank you for your patience here while I consulted with the QA team regarding this behavior.

It appears that the backup you are performing is on an external drive called ROON_BACKUPS according to the screenshots and in fact backing up to ROCK’s internal storage drive should not be possible. There are a few follow-up questions which may help:

  1. Have you ever performed a successful backup to this drive before?
  2. How is the external drive formatted? (NTFS/FAT32/exFAT/HTFS+)?
  3. What are the permissions of the drive? Does the drive have read/write access?
  4. Does this drive work as expected on a regular PC for reading/writing files?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.