Backup Restore Error on MOCK

Happy Holidays!

I’ve faced a problem during a restore (migration).

We moved from a MOCK (ROCK running on a HP laptop) to a virtualised Roon Server (running on an Ubuntu Server).

Both of them
-connected to the same network share (shared on a virtualised Xpenology).
-imported 16k+ tracks and watching changes real time
-can and do read and write the backup folder on the network share mentioned above

When I try to restore any of MOCK’s backup on the Roon Server, I received this error message “Restore failed. Please check your backup folder and try again”.

Other issues:
-on the MOCK I can not add the network share with the account created for this purpose, I had to use the administrator account
-on the Roon Server I’m seeing messages like this “CIFS VFS: Send error in read = -4”.


It seems I had a couple of totally useless backups from the MOCK database on my NAS.

I’ve just created two backups on the MOCK.
One to the network share, another to a thumb drive.

Then tried to restore a backup on the MOCK from the network share and got the same “Restore failed.” message again.
Then started a restore on the MOCK from the thumb drive and it was successful.

Switched to the Roon Server created a backup to the network share, then successfully restored from that backup.
At this point it seems the Roon Server connected well to my Xpenology share.
Then started a restore on the Roon Server from the thumb drive what contains a backup of the MOCK’s database and it was successful (!!!) and now everything works on our Roon Server as it worked on the MOCK before (playlists, tags, DSP settings etc.

I do not understand what was the problem with the MOCK and its backup, but I decommissioning it.

Roon Backup/Restore logic is riddled with errors. That’s what’s wrong.