Bad sound quality with Roon [Resolved, Ethernet Switch]

That’s okay
We did try using a pc, and it made no difference, actually I got worse.

My guess is that roon Software I making som kin of distorting compared to the lumin.

In the Lumin app, please disable digital audio output, disable Spotify Connect (if you don’t use it), and disable Lumin Streaming (if you don’t use AirPlay). Analog Output Level should be Normal. Please also make sure volume is 100.

There are other tweaks that requires additional hardware, but perhaps let’s just see if the LPS for your Synology helps.

Hi peter

All of things you suggested was already don besides the Spotify and streaming thing… now it’s done and with a slightly improvedment.
Unfortunately LUMIN still sounds a lot more detailed and With much more live/realistic feeling without going through Roon.
It’s really so sad, cause I love the platform of roon.

I’ll guess I’ll wait out the LPS on my synology…

Hi Sean

Im wondering if you have heard a “plop” in your speakers when using DSP/Eq ?
It occurs when the volume is a bit high (not high high)… but on listening level. It sounds as if the speaker/bass is broken, if you know what I mean.

It’s really really weird

Are you connecting the Lumin and the Synology by ethernet directly or with a router/switch in the middle? I may have some ideas.

IMO, The issue seems to be RoonReady on the Lumin vs Lumin’s internal playback.

The NAS and network components don’t seem to be an issue with Lumin’s playback of music stored on the NAS, not sure why people are suggesting fixing those components to solve the possible sound issue with Roon on the Lumin.


1 Like

Well I have a router in My technique room were the fiber goes in, and from the router through a gigabit switch who feed six rooms in the house.
In my listening/Hifi room I got a switch with one cable to my lumin and two cables to my synology.

This is my thinking too. Sound direct from Lumin and via RAAT should be quite similar if not completely identical. The OP describes this as almost night-and-day so something is definitely strange here. @wklie is there maybe a reclocker on the Lumin output that the RAAT stream is not passing through?

Ah, I see. If the same gear is used (NAS) with the same network gear and pathway, and the only thing that changes is RAAT vs. Lumin’s internal processing, then the difference must be related to software. I think this is the reasoning that most people make from this scenario, correct?

I’ve seen similar comments made by other Bryston BDP users when using their ethernet connection to feed music by NAS (MPD) and computer (RAAT). In that case, one can make a claim of difference between NAS and computer and their PS/noise, but in OP’s case, even this distinction cannot be made as he is using the same device for both purposes, if I’m reading correctly?

There is one aspect I’m curious about that I’d like OP to find out about: network activity. You can look at the switch’s LED to see if it’s active. Flickering LED shows traffic. I wonder if there is a difference in traffic patterns between RAAT and Lumin’s native.

For example, on my BDP-1 with RAAT, the LED on the switches are constantly flickering. Constant traffic. I wonder if that’s the case with RAAT on Lumin as well? Next, follow the network activity when playing a track using Lumin’s native app. Is the network just as active throughout?

Hi Thomas, nope I don’t get that. Really weird indeed.

I have gotten a “plop” sound when using bass boost type EQ in the past… well before Roon. but then I learned that it’s best to use EQ to tame peaks and try to avoid boosting any regions if possible.

But you say even with all DSP switched off, there is still a night and day difference, so this is a head scratcher for sure.

So what PSU are you using right night, the stock 918+ PSU? That’s what I use.

Silly question from me but when you’re using the Lumin A1 you’re NAS is still in use right, for all your stored music?

Please turn on the Clipping Indicator and check for clipping:

1 Like

Both RAAT and native OpenHome music playback use the same clock.

To my knowledge RAAT should work similarly across different brands of devices in terms of network traffic.

For Lumin native OpenHome playback, even after playback has started, the rest of the current track will be cached as much as possible.

Please try the latest Lumin firmware with the latest RAAT integrated.

I had problems last year with awful roon audio quality on Win10 machine, therefore creating audio samples that demonstrated the huge difference between any player (MediaPlayer HomeClassic Cinema was used, but could have been any player) and Roon. I never got any definitive response from roon staff, so I bring it here. @Thomas_Larsen, can this terrible “ringing” be related to your audio problems? Here are the audio samples for comparision:!AgwTOVHwFIUih81uVGO_nmYfonLvYQ4

I got rid of this ringing by converting the whole setup to 192-24, thus I suspect sample rate conversion problems.

But beyond that, I also get the impression that something is not proper with the roon audio quality; it sound “flat”, but I haven’t tested seriously for a couple of months and must do that before I speak any more of it.

Roon does not sound.

I have given up on the NAS setup as I encountered similar issues.

I book them on the NAS PSU plus all services running (it got slightly better with every service stopped) plus the switch and the other devices attached to it.

Even when running a direct cable connection between the switch upstair and the Network streamer downstairs I still had plenty of distortion.


What do you mean by “ringing”???

Hi, Peter @wklie

I’ve updated the firmware but with no improvement in the sound quality. The music is still “Flat and without live feeling” through RAAT.
I’m still waiting for my LPS to be modified to my new synology… so maybe it’s not 100% fair to compare the two software yet (lumin/Roon).


I am not sure how to extrapolate my experience to your system, but this may be helpful. I had a similar problem with Roon sound quality compared to the software I was using at the time. When I checked the system profiler on my mac mini I found that Roon was using 70% of the CPU. On the recommendation of a forum member I switched the mini to Roon Server and am running Roon itself off of a laptop, with the mini still acting as the Core. CPU usage is down to 5% on the mini and Roon sounds fantastic – better than any other software that I have used.

Besst word I could find. Listen to samples

Thanks, but I did check up on my synology…
cpu is stable on 10-11% with some rarely peaks up to 20-25%, so I don’t think this is a problem here.

But while I’m waiting for my new LPS i did some tweaking with cables and decoupling, and I got an INSANE improvement by placing these decouples under my synology.

Everyone with a good system using a nas should try this!!

There is still a huge difference between my lumin and roon, but now the Roon almost plays music… but surely the lumin also sounds better now since the musici transported from the nas.