Be wary of the latest Synology package - it may have a serious bug

Hello everyone.

I have a Synology DS918+. A few months ago I decided to try out Roon on it and it worked fine, didn’t load it too much and streamed just fine). Then for various reasons I took it off. Then a few weeks ago I decided to try it again and downloaded the latest Synology SPK package at that time (RoonServer_Synology_DSM7_x86-64_20220216.spk). However things very quickly went off the rails. This time my Roon clients (OSX, iPhone) would not play any more than one track then would just sit there until I rebooted the server.

So after mucking around for a while wondering why it wasn’t working I removed it again. Then the strangeness really kicked in. Logging into the NAS I tried to set 2FA on a user and got an error saying the 2FA code was wrong. Tried several times with various users. All failed.I browser a directory’s properties and was told the NAS could not compute the directory size. Same thing, tried numerous directories and could not get their sizes. I tried adding a new user to the admin group and it would not let me, plus there was a bunch of other errors which made no sense.

I had Synology (very helpful people) log into the NAS and they told me that the Roon install had choked my /tmp directory with files and that was causing the weird failures. I checked and sure enough there were 10s of thousands of socket files in the directory all owned by the Roon user. Removing them fixed all the problems.

I have no idea whether this is a one off on my NAS or an actual bug in that release. So I’d suggest if you have this release on Synology that you check your /tmp directory.

1 Like

I also have Roon Server running on DSM7 (actually 7.1 update 4) on a DS916+ with 8GB of ram. Christopher Reike’s Roon Server package 20220216 is currently installed and handling updates (my actual Roon Server is Roon 2.0 build 1128). It’s run well for me so far. I checked the /tmp directory and there are roon socket files there but only 21 of them. There’s also an empty roon images directory.

So it’s not happening everywhere – not to say it’s not messing up on your setup but it doesn’t appear to be universal (thankfully!) So there’s hope for a solution I think.

Could you please point out which /tmp directory you are referring to. Is it located in the root directory on your NAS, or in the RoonServer directory, or somewhere else?

The tmp directory is the root one. ie /tmp. To check it I ssh’d into the NAS, then changed directory to /tmp. If you’ve got the right one you should see a lot of socket files for various apps and other temp files. But the Roon ones were obvious as the Roon user was the owner.

No doubt @crieke will come in and want some more info perhaps

Yeah now that I know what went wrong I might install it again to see what happens.

Just in case you get stuck at some point: you can also run Roon server in a docker container. In that case you are not dependent on the synology package. Works fine on my 918+. There are installation instructions on this forum when you search for it.

Hi @Derek_Clarkson,
thanks for the info. I could reproduce that Roon Server is indeed writing to the global /tmp directory.
This is actually not a big deal, as this directory is emptied on reboot automatically. The only implication I could think of at the moment is when you have manually started Roon Server over ssh as root (or as a different non-RoonServer user) and then start it again via package center. Due to permissions Roon Server might not write its tmp files then.

I’ll fix this in the next Synology update, so only the app’s /tmp will be used then.


For anyone reading this. It’s looking more and more like - It’s just me and something weird that occurred on my system :slight_smile: :wink:

Thank you for your reply Derek. I am of senior age and don’t have the skills to do anything with SSH without running the risk of irreparable damage. The safe option for me is to wait for a fix by Christopher Rieke.


I also run ROON on a Synology DS 420+. ROON and Synology are both up to date and run without any problems.

Best regards

I can also say everything is fine on 720+ with external SSD. Everything good and all up to date.

As an update - I’ve reinstalled Roon on the NAS and so far it’s operating without an issue. Whatever it was that swamped my /tmp dir with files seems to have gone away.

Did have an issue with the server exibiting strange intermittent failures until I update ffmpeg as per the instructions. So big thanks to @crieke for his support as I would never have thought that would be the issue.