Beginning of track is cut off

When I start a track, half a second is cut off, approximately. This happens with files streamed from my NAS and with Tidal tracks, equally. I use Linux server with Bluesound Node 2 and iPad controller. No external DAC. I don’t get the problem if I play using the BluOS app instead of Roon. Any ideas?

Hi @Dafydd_Waters ---- Thank you for the report and sharing your observation(s) with us. The insight is appreciated!

Have you tried using the the resync delay feature under “device setup”?


1 Like

Thanks for this. Yes. I tried a very short, short and longer delay: 500ms, 1000ms and 5000ms, respectively. Did not solve the problem.

It only happens when starting playback. So the first track of a recording will be cut off but not the beginning of subsequent tracks that follow on without stopping playback. Equally, if the first track of a recording is queued, it is not cut off.

I’ve noticed this happening too, mostly when I interrupt a track while it’s playing. It doesn’t matter if the new track is the same sample rate or not; the first few samples of the new track always seem to get cut off. If I pause the current track before switching to the new one, I usually don’t get this issue.

1 Like

Hi @Dafydd_Waters — Thank you for touching base with me and confirming that information. Both are appreciated!

Moving forward, to help me better evaluate what could be causing this to occur may I very kindly ask you to please provide me with the following:

  1. An expanded description of your current setup as seen here.

  2. Please, very briefly, outline your network configuration/topology as well as providing insight into any networking hardware you are using. I want to have a clear understanding of what the chain of communication looks like across your network, and the “links” that make up that chain.


1 Like

Hi Eric. Thanks for this. Apologies for the delay. I can send you the information at the weekend. Cheers, Dafydd.

Hi Eric

Attached screenshot should tell you about versions.

Core runs on Ubuntu 16.04 LTS. The hardware for the core is Dell XPS 13 ‘Developer Edition’ laptop Intel i5-5200U CPU @ 2.20GHz x 4. 8 GB RAM. 64-bit. Solid state disk.

Music is stored on Synology DS115j NAS with WD Red 1TB NAS optimised drive. NAS is wired to latest version of Virgin Media cable router. All other connections are wireless.

Streamer is Bluesound Node 2:

The problem: When starting playback, beginning of first track is cut off. Not a problem with subsequent tracks. Not a problem with first tracks when following on in a queue. Problem is the same for tracks streamed from Tidal and tracks from the NAS.

Observation: only a problem using Roon. If I play using TIDAL app for streaming or BluOS app for tracks on NAS, there is no cut off.

Library size: 27,471 tracks.

Thanks for your help!

Hi @Dafydd_Waters ----- Thank you for the follow up and providing the requested information, both are VERY appreciated :thumbsup:

Moving forward, during your troubleshooting of this behavior have you tried (temporarily of course), bypassing the NAS and playing some media from local storage on the device hosting your core? If so, what was the experience like?


1 Like

Hi @Eric

Apologies for the long long wait for a reply. Since you last tried to be helpful, I’ve migrated to ROCK on NUC and changed the connection to my Bluesound Node 2 from WIFI to Ethernet (so now, only the remote from my iPad is wireless). Magically, I now no longer have any problems (touch wood). Thanks again for your support.

PS: setting up ROCK on my own kit was dead easy. Love it.

All the best


1 Like