Benchmark DAC3 HGC Issue

This is my prime DAC. I had been running it directly from the ROCK USB port, just fine, up to the limits of its abilities, until last night. I am just now trialing the new Benchmark HPA4 (and new Focal Utopia headphones), but my DAC is pre-September 2018, and for it to integrate, fully, there is a hardware firmware upgrade to install in the DAC3. I did this last night, however, after pulling everything apart, and putting it all back together again, I ‘lost’ the NUC USB port!

After a bunch of fiddling, I concluded that the NUC was fine, and that I just needed to RE-Enable the NUC USB port in Roon. It had disabled itself in the process. Why? Perhaps because it detected a change in the device on that port? Anyway, after RE-enabling the port and doing device setup again, it no longer appears to support DoP, and has a max data rate of ‘only’ 92KHz. There were two possible causes: 1) the HT mode; and 2) the new firmware. I have now confirmed that undoing the HT mode makes no difference, BUT reverting back to the original firmware (which is just a jumper move, now) restores the previous relationship with ROCK - it again sees DoP and 192KHz capabilities.

Note that the DAC3 did still support higher rates via alternate signal paths, just not directly from Roon on the NUC USB port. That is to say, Roon will not send DoP or >92KHz to the DAC3, directly, with the new firmware.

I am hereby reporting this to @support and to Benchmark for resolution. Between the two ends, there is some mismatch to be resolved with the current firmware of the DAC3.

When I learn of any resolution, I’ll post it back here.

Hello @James_Blessing,

It appears that your Benchmark DAC3 has gone into USB 1.1 mode, which is not compatible with Linux as far as I know. The instructions to return the device to USB 2.0 mode may differ depending on which version of the DAC3 you have, so make sure to check the owners manual that came with your device. On the DAC3 HGC, you can toggle USB modes by pressing both input buttons on the front panel for 3 seconds.


1 Like

Well, this was it. Since the background and resolution were a little circuitous, I’ll detail it all here in case anyone else encounters it.

In the past, I had my DAC3 in 'USB 2 mode". This setting sticks - I do not have to reset it each time I turn on the unit (nice!). I installed the new firmware chip, and moved the configuration jumper to use the new chip, rather than the on-board code. I did NOT set it to USB 2 mode again - it didn’t occur to me. My NUC (Rock) USB device disappeared in Roon. After a lot of other checks, I concluded that the NUC was okay, and the DAC3 was okay (played highest res material via HDMI through an OPPO 205 via digital coax. It turns out Roon had disabled the USB port.

Upon re-enabling the NUC Rock USB port in Roon, when configuring the Device, it showed a DAC3 with limited capability. I put the DAC3 jumper back to the internal code and all was working well, as before. That is when I posted. Both Roon Support and Benchmark alerted me to likelihood that the DAC3 was just in USB 1 mode.

Right. So I put the jumper back to new firmware again, and NOW it shows the unit is in USB 2 mode, even though I still had not re-set it - I only moved the configuration jumper from new chip to internal and back again. The DAC3 seems to have picked it up from the previous settings, even it had not done so the first time.

Now the Roon device setup page looks like before, with DoP and up to 192 KHz rates. But that is not the end of the story. Even though Roon showed 192KHz capability, it would not send 192KHz music to the DAC3 - it still only sent 96KHz. I powered down the NUC (again) and rebooted. I tried sending DoP to the DAC3 and that worked! I tried playing a different music file at 192KHz and THAT worked. I tried playing the first 192KHz file and now it works also?

Bottom line, all is working properly now, as before, even though I made no USB setting changes along the way. It all just needed a number of resets and restarts to get all back in sync (apparently). The key seems to be to carefully set, or re-set, ALL configuration options after changing the firmware.

On to my critical music evaluations then…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.