Best way to migrate to Nucleus after stumble

Definitely follow @danny’s instructions. He’s the expert.

You can reset the database from the ROCK web interface. Use at your own risk!

Cheers, Greg

What’s the ROCK web interface? Is this just entering the IP address in a browser? I do see a series of items there but am uncertain what each can do or not.

After backing up the Roon database on my MacMini and using it to restore to the Nucleus I still find that many, many album covers either are missing or wrong, as well as many misidentified albums or numerous multiple entries of albums which should have been grouped under a single album. These had been fixed by me in the past. Seems that the restore process took me many steps backward. I guess your warning suggests that restoring is still fraught with less than perfect results.

I will state for the record that the Nucleus, after a few hours listening, is substantially better than my MacMini. That system, which is substantially faster with more memory, is likely burdened by less than optimized software. What you guys have done, especially in tuning R.O.C.K. for this hardware, has made a huge difference in lowering the noise floor, bringing out more details and creating more focus than what my MacMini has offered to date. Seems like the overall timing of how the Roon player delivers the bits downstream contributes to a far more focused soundstage. Greater depth and breadth. This results in a smoother and easier listening experience. Instruments and vocals are simply more realistic. Listening to high resolution sources, such as Dave Brubeck’s “Time Out”, really show off these attributes of the Nucleus. I’m sure I’ll discover more striking improvements with standard Redbook CD’s in addition to well recorded older mono albums. I’ll be curious when MQA first unfold happens (either in Roon or when dCS delivers it in their Network Bridge; already have MQA rendering in my DAC). That might suggest whether this format has much to offer beyond uncompressed PCM.

One other thing: seems that the Roon iPad app no longer seems to lose connection to the Roon Core. Another plus for R.O.C.K.

Well it seems that a day after I did the restore Roon had been busily reorganizing and integrating all the myriad changes from the backup. Whereas, after thinking it had done its work, and pointing to Overview and looking at “Recently Added” nothing looked right. All the album were labeled as newly added. But a day later everything now appeared as they had been last seen on my MacMini. Too bad there’s no real indicator from Roon when it really is all done with its restoration processing.

Hi Steve,

Sorry for the late reply. Glad everything eventually got sorted for you and you’re enjoying the Nucleus.

Yes, the web interface is the IP address in your browser. Also, there is a swirl icon at the top right of the screen that indicates when Roon is doing some analysis. You can tap it to see what’s going on.

btw, I’m not a Roon employee. I’m a moderator and I help edit the knowledge base. Otherwise, I’m a Roon fan, just like you.

Enjoy the music.

Cheers, Greg

Didn’t realize that the Community section was simply “sponsored” by Roon Labs. In any case, I’m surprised that there doesn’t seem to be a Nucleus area devoted to feedback, setup, usage, etc. maybe that’s because ROCK has been out there so long and/or that the Nucleus, being a hardware product, is a bit of an odd duck.

The community is not only sponsored by Roon Labs, but our entire support staff is here too.

I’m currently writing a proper manual covering all aspects of Nucleus. Right now all we have is the Nucleus User’s Guide, and while it is useful, it is not exhaustive.

OK. And just to alert folks who are using the Nucleus feeding a dCS Network Bridge: there is an issue when Roon switched bitrates - the initial half second or so is cut off in playback. I believe dCS knows about this and will be fixing the problem when it finally releases a firmware update.

A temporary fix is to set a Resync Delay of 500ms or so in the Device Setup for dCS.

In my previous use of the MacMini, the symptoms were sometimes worse, with Roon erroring out with a message suggesting that it lost access to its Roon counterpart on the dCS. Worse case it demanded rebooting the dCS.

@AMP – is this a dCS firmware issue, a Roon issue, or a Nucleus issue?

It’s a resync delay issue (at least in this config) as there’s no way for the bridge to know when the DAC is ready so it’s just going to start rolling data. Depending on the DAC, 500 - 1000ms is an appropriate setting.

I wonder if the delay was previously set on his Mac Mini, but that setting didn’t get migrated over to Nucleus.

OK cool… just making sure this isn’t a dCS + Nucleus issue.

So, is there a “fix” coming from dCS, or this is just a setting to set?

Send me a Nucleus and I’ll tell you conclusively :slight_smile:

This is going to be like any other bridge-type device connected to a DAC. Some DACs will need more time than others to sync up and come online. This is just a standard setting of the resync delay.

I believe a few are headed your way soon.

The 1000ms delay I’d set up for my MacMini didn’t migrate to the Nucleus. Was that supposed to occur, if I only migrated the database?

And if I’m using the dCS with not one but potentially numerous DACs (Berkeley, Audio Alchemy DDP-1, LH Labs Geek Out, and Schiit Yggdrasil) the Resync Delay would need to be modified for each in turn. Luckily the dCS Network Bridge is only connected to a single DAC in a users environment at any given time.

It’s been quite a long time since the folks at dCS have been working on this issue, but given all the potential testing with many DACs, it’s no wonder it’s taken so long.

What you’re describing isn’t a dCS issue. The bridge has no way of knowing when the DAC is locked and ready so without a delay set it starts sending the bitstream via its outputs immediately. Depending on the DAC this can result in the first part of a track being cutoff as the DAC hasn’t had time to lock to the incoming signal, sync its clocks, and unmute.

Some DACS take longer than others so I always recommend setting the delay to something so as to ensure enough time for most DACs to sync up.

The setting is per zone.

So, this is a different problem than the one described months ago. That one had, I think, a more serious effect of preventing Roon from “finding” the dCS NB. It could require a restart of the dCS. Had that one with my use of the MacMini. Interestingly I never experienced any cut off of the beginning track of a song when switching bitstream rates.

Right… because…

You had a 1s resync delay set on your Mac.

Actually I should have qualified my statement: prior to experiencing the problems with Roon-dCS “disconnect” and changing the Resync Delay fro 0 to 1000ms I never experienced the cutoff of first tracks when switching album/song bitstream rates. And the “disconnect” problem was both rare and therefore not consistent.

Been using the Nucleus for some more time. I’ve found that I had to bump up the Resync Delay to 3000ms to give the Berkeley DAC enough time to get locked for playing when bitrates change. Unlike my MacMini, the Nucleus is much quicker sending music downstream. It overtakes the DAC if I don’t tell Roon to wait long enough. I’m guessing this has already been experienced by others using ROCK on Intel NUCs.

6 posts were split to a new topic: Nucleus Specification and LPS Options