Beta release 08/09/2017 (050)


I’ve just pushed an update to the beta channel. This release focuses on the screen stuff.

Biggest change is the introduction of a second ‘play screen’, which you can access by tapping the cover art. You can go back to the original one by tapping the cover art again, so no worries for those that like the current screen as it is.

That said… the new screen has a blurred cover art background and controls for radio, shuffle and loop.

RoPieee remembers which screen you prefer, so after a reboot it starts with the last selected screen.

Oh. And as a last-minute-change I’ve added the IP address to the settings screen and connection failure screen.



I’ve tried to set the installation to the Beta channel (and saved the change), but when I then reboot, it comes back to the Stable channel. Any suggestions? Thanks.

Try again, or reboot again. I tried last night, with numerous reboots, without success. Noticed an issue with the zone name again (single quoted in the GUI). Then on a whim changed it to beta when I was up at 4:30am, and now a clock greets us. :slightly_smiling_face:

It seems to take some time, or reboots, or downloads.

Can you send me feedback?
Then I can look into this, because this should obviously not happen.

Set Ropieee to the beta channel, rebooted, and it’s back to Stable. Here’s the feedback from the current Stable channel state:

Just now changed the channel to Beta, confirmed it and sent another feedback report: 6560084c74216c67

I’m sorry to say, but your filesystem is damaged. System acts in read-only mode, hence changing the setting doesn’t work.

OK - so I assume the best thing is to download a fresh copy from the Ropieee web site and burn the SD card again?


It also results in having a different filesystem on the SD card (geek speak), which hopefully makes something like this less likely to occur.

Regards Harry

1 Like

ok. I’ve managed to fix the issue with the quotes; need to wrap it up, but update will be out tomorrow.


Hey Harry @spockfish

Dad woke up this morning and the Touchscreen has disappeared from his network.

I’m guessing something went wrong with this nightly reboot. It’s been flawless for a couple of weeks now.

I’m going to wipe the card and re-install for him via TeamViewer but just thought I’d let you know.

Just for info: for some reason, Microsoft Edge thinks that the image file download on is an HTM file? I had to use Chrome to get the file properly downloaded…

Yeah more people ran into this. I don’t have a Windows machine here so I can’t test it. I’ll put a warning on the website for now.


Ok. The good thing is that your dad will then be on a system with the changed filesystem.

Ok cool, thanks Harry. Do we only need to download and install the stable image?

No need to use the beta image anymore even if we want to run beta?

Nope. Just install stable, and when you want you can switch.

1 Like

Cool bananas :banana:

1 Like

And feedback sent: 5580cb4ca94502f1

That’s very unfortunate. What I see is that the extension crashes while trying to connect to your Core. It’s automatically being restarted, but fails again.

This is weird. Nothing changed to the extension, and I’ve never seen this error in connecting to Core before.

Question: did you also tried it with a restart of your Core?

Yep, for sanity, I just shutdown my Core and powered up to triple check.

And still, no extension showing.

I don’t know what else I can do apart from doing a clean install for a 3rd time.

Ok… bizar.

I’m pretty convinced that 3rd install won’t fix it. Unfortunately. For some reason it can’t connect.
But let’s do a test anyhow. Just pick ‘stable’, and send me the feedback afterwards.