BETA Release 2024.06

Hi,

I just released a first BETA release for the upcoming 2024.06.

This is a fairly ‘boring’ release, which focuses on resolving the whole ‘WIFI WPA3 drama’.
That means that starting with this release, WPA3 is not supporte on the onboard WiFi chip.

For the rest some ‘under da hood’ improvents all over the place, but these are changes worth mentioning:

  • ENHANCEMENT: upgrade Linux kernel
  • ENHANCEMENT: update Shairport-Sync component
  • ENHANCEMENT: update UPnP bridge component

Let me know how things look. Idea is to push this one out somewhere the coming 2 weeks.

Thanks

2 Likes

I will try. You mention about support for wpa2 and wpa3 mixed mode. When my device offer two mode RoPieee takes wpa2?

Update:

I see this screen. My conenction is mixed mode wpa3/wpa2.

Yes,

That means that the current connection is using WPA3 and thus the update is prevented because it would potentially result in a disconnected device.

As soon as you fix this (either by connecting to WPA2 or disabling WIFI for time being) this message will disappear and the update is available.

Regards

My router has mixed mode so after update RoPieee will works?

Yes it will.

I’m testing now…

Update:

It’s ok. RP was connect to the router in mixed mode WPA2.

1 Like

@spockfish , would you send me an screenshot of the “MORE INFO” text after the “Update available but blocked” message? I think a FAQ entry in the guide would be helpful, if you agree.

1 Like

Hey @spockfish, I’ve upgraded one of my units fine, however now the screen is not working correctly.

Volume and clock/power work as expected.
Play/pause/prev/skip/radio/shuffle/loop all do nothing.

I’ll upgrade my other unit and see if behaviour is the same.

Nope, second screen is same behaviour. Both screens can’t perform any of the “playback interaction” aspects.

Hello – After installing the beta, my USB DAC is no longer displaying on the Audio tab.

AirPlay and Spotify Connect streaming are both working fine, but not UPnP.

Feedback: 1ca0d1e802dab4c7

Thanks!

Ah, my USB DAC is also not showing on the Audio tab. (it’s working fine in Roon which is all I’ve tried)

Thanks.

Found it. This will be fixed with the next beta.

Can you send me feedback?

after you interacted with the screen?

Thanks

Upgraded 4 * RPIs: (2 * RPI3A, 1* RPI3B and 1* RPI4B).
:+1:
Only the interaction with the screen is not working for Play/Pause, Next and Previous.
The volume control via screen is still OK.
Thanks Harry.

1 Like

Done. I rebooted it, left it a little bit, then woke up the screen (with touches) and then tried several play/next/previous taps.

b5d46b4de7fc869b

Not sure if you can tell in the feedback, but this unit is not the official screen. Yes I know it’s unsupported, but I’m getting exactly the same behaviour on my official supported screen. If there’s nothing apparent in the logs then let me know and I’ll send more feedback from the other unit.

1 Like

Same issue with the screen play pause not working on my RPi3b after updating. My OSMC remote does not work either.
Feedback sent: 41bdfde84be77639

I have tried renewing the extension and rebooting server and RPi3b.

Can play from Roon remote on my phone to this unit.

Unit info:
Software Version: RoPieee 2024.06 (1655)[BETA]
Kernel Version: 6.6.34-SPCKFSH-v7+

  • Hardware: Raspberry Pi 3 Model B Rev 1.2
  • Network: ethernet
  • Audio: digi+ pro hat optical and coax to KEF LS50W and Schiit Yggdrasil
  • Display: Yes
  • Remote: OSMC

Hi,

I’ve pushed out another beta build that fixes the screen interaction issue and the USB DAC ‘no show’.
Let me know how it goes.

Thanks

Hi Harry,
Seems to work again, the screen interaction.
Thank you very much.
Kind regards, Frank.

1 Like

Thanks Harry, confirm both issues sorted on both test units. All good so far.

1 Like

Just updated all units to the 1662/1663 beta and screen play/pause and OSMC remote are functioning correctly.
Thanks Harry.

1 Like