Beta release channel

Now we’re back to normal (both ‘regular’ and XL on the same base), I’d like to regularly push things to the beta channel.

Normally I’d like to release once per month and release at least one beta.

So here it is, the first beta towards ‘2022.05’ with the following stuff:

  • NEW: support for the Mediatek MT7612U Wireless adapter
  • IMPROV: update base packages
  • IMPROV: add fallback for naming of external WiFi adapters (USB)
  • IMPROV: bump Linux kernel
  • FIX: ‘fancy name’ of XL services don’t follow hostname change

PS: if you want to use beta, change the release channel on the ‘advanced’ tab to ‘beta’ and follow instructions. After the reboot it will notify you within a few minutes that an update is available.


6559df8035328ad5 had one that seems to be a version off the other RPi3b I have. Any clues as to why?

another RPi4b seems to be restarting every 15 secs or so in a boot loop the last 2 I tried to force a feedback but there was no code number…Please ignore this one 1d76542625427c55 as I was getting the web address for a feedback

I tried this while the unit was responding to pings but I dont think it worked

are you referring to the number between brackets? That’s the build number, every build (combo hardware + software) has a different build number.

What matters is the ‘xxxx.xx’ version. For all products on beta that should say ‘2022.05’.


Yes but I would have expected them to all get the same build as they were all on the stable prior.

The rpi4 is on 219 but I think I’ll have to reflash it as it’s just stuck in a 15 sec boot crash loop

I was able to pick up the beta channel without issue.
Thank you.

One of the 3 RPi3B’s is now restarting loop too…going to reload stable and sick there for a bit I think.

New beta release is out. This is the last towards the 2022.05 release.

Changes since last beta release:

  • NEW: make XL service names configurable
  • FIX: XL services do not follow hardware mixer setting


1 Like

This is the first beta towards 2022.06.

This time it’s XL only.

There’s only one feature here: an “UPnP-2-Roon” bridge.

What it does is that it uses the Roon Squeezebox compatibility to bridge an existing UPnP device and make it available for Roon. This means you need to enable Squeezebox functionality in Roon for this to work.

It works pretty straightforward (you can find it in the XL menu under ‘UPnP Bridge’). For now I’ve exposed the minimum amount of settings, let’s find out if we need more.

So… get your old UPnP device and fire it up!
And yeah, let me know how it goes :wink:

Regards Harry


Interesting! It works with LMS / Daphile too: I configured my SOtM sMS200 as UPNP / DLNA device, RopieeeXL with UPNP bridge found it on the network and made it “visible” to Daphile as if it were a Squeezelite device.
… it works !!!

1 Like

Hello Harry,

I made some tests with a HC preamplifier Marantz AV8802A

Test OK in stereo (192k)
I tried in multichannel and DSD without success

Is it possible to disable the “UPnP-2-Roon” bridge ?


You can set the renderer to ‘none’.

“none” does not appear in the renderer list

Click on Scan and “none” will be an available choice

1 Like

Ok, it works

For the DSD and multichannel test:
Multichannel : Roon converts to stereo and it doesn’t work if I force multichannel in Roon,
DSD: Roon converts to PCM and it doesn’t work if I set it to DOP

I seem to be missing something, I’ve enabled the beta software and carried out a reboot, but cannot see “UPnP-2-Roon” bridge under RopieeXL tab. Suspect I’ve missed a step, but not sure what I have done wrong ?

Are you running the new RoPieeeXL version or the old one? If you are on the old one there are no more update available, stable or beta.
To move to the new version you need to start from scratch: download the image, flash it and boot your rpi.
This is how the new version in numbered …

Keep in mind that, after selecting a different release channel, it will take some time before the update is being fetched.

I’m pretty sure that if you go back to the web interface it will say that ‘an update is available’.

Thank you for the reply, it was a school boy error, I enabled the beta software but forgot to install it. Can now see the correct software version and can see the following tab UPnP Bridge inter RoPieeeXL, which i’ve selected Apply. However Roon is still showing “Searching for Squeezebox devices etc “ even though Enable Squeezebox support is active ?

So you scanned for the UPnP devices, saved the config and ran configure?

Tried that, just shows “searching for UPnP renderers”