Big Sur remote not connecting to Core

I wish I could say the same, but unfortunately, my new Macbook Pro with M1 ARM-chip will not connect to the Roon Core. I’ve tried several troubleshooting tips: check wifi-adressen (OK), restart both core- and this computer (done, not a solution), re-install Roon om my new MB Pro. Nothing.
I did change the core yesterday, from a 12 year old IMac to my (now) old Macbook Pro with the newest 10.14-OSx. Al other IPhones, IPads, Bluesound Node in the house connect to the new core with no problem. But the new M1 MB-Pro just won’t. Same picture for several hours now ;-( Any guesses?

Hi @jean_coumans,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are you able to connect the new Mac via Ethernet as a test if you have an adapter? Is there any change if so?

I’ll give it a try.
Main wifi-router and the connection to the outside: ZTE Experiabox V10 (Supplied by provider KPN, Dutch firm).
Connects via WIFI to the Roon Core on a Macbook Pro 2013
Connects via WIFI to Mac MINI 2014 with Roon
Connects via WIFI to several IPhones and IPads
The router is connected via the supplied cable to a Netgear GS10SE router.
This is connected via cable to Bluesound Node 2i as Roon endpoint.
All of the above work without a glitch. All are updated to the newest OS.
The only problem is with my new M1 Macbook PRO, of which youy have seen the above screenshot. I use it as a Roon endpoint, to choose my music which is played on a dedicated USB-DAC. It has a wifi-connection with the wifi-router. It is my work-computer, I use it on an daily bases, up to 12 hours a day, without any networkproblems (the aforementioned Macbook PRO used to be my work-computer, it always ran Roon without a glitch, where an old IMac used to be the Core, the IMac is now obsolete).
I tried connecting to the network via an ethernetcable (on a special Calldigit USB-C-hub). Network runs fine, but my M1 MB PRO still can’t detect the Core, unfortunately. It shows the same message as above.
Hope you can help me.
Grz Jean

Goto System Preferences > Security & Privacy > Firewall, and try turning off the firewall just to check if thats blocking it. If so, under “firewall Options”, make sure Roon is set to “Allow Incoming Connections”.

Good suggestion, and I had high hopes. But unfortunately, the firewall has not been activiated at all:


So, the solution must lie elsewhere.

Hi @jean_coumans,

When you set up the new MacBook did you use Apple’s Migration Assistant or Time Machine?

If so can you try uninstalling Roon completely from this machine and reinstall fresh?

I tried this before and I did again just now. I’m sorry, still no solution.

Hello @jean_coumans, when you migrated, did you do so with Apple’s Migration Assistant or Time Machine?

Timemachine

Well, thats probably not helping - Roon does not work well with time machine.
Try renaming the Roon library, and relaunching. If that doesn’t work, try reinstalling Roon.

  1. Open Finder and click Go in the top bar
  2. Hold down the Option key (or Alt)(⌥) to unhide the Library folder
  3. Click the Library folder
  4. Rename “Roon” folder to “Roon_old”

Hey Mikeb,
Thx for your time and support. The Roon-library is on another computer that works fine, also with all the other stuff (Node2i, other IPad’s and IPhones, another IMac). That computer with the library did not need and did not get a time-machine update. It is just my new MB Pro M1 that cannot find the roon library. See my initial post. I did uninstall and install Roon several times, to no avail, unfortunately.
Fyi: Apple Muziek (the old ITunes-app, so called in my native lingo Dutch) can find Apple Muziek on the Roon-lib-computer: I’m listening to my Muziek coming form the Roon-core compuer on my MB Pro M1.
It’s a mystery
Jean

OK, you first need to be on the same network as the Roon Core, be able to ping it, then we have a chance of the Roon software connecting to it. If the network stuff is fine, and the Roon Core works with other clients, the problem must be local to the MacBook remote. The settings are in the library file(s), we know these don’t restore well from Time Machine - the steps above will junk them, forcing the program to start over. This may help :slight_smile: If I’m rambling forgive me, but I’m sharing ideas.

YES YES YES!!
Sorry for being such a pigheaded @$$ to question your advice. You were spot on.
You made my day, because, allthough the world is tested by much greater crises then my little problem, it drove me MAD.
So, big thank you. Also for the lesson that Roon keeps a library on my M1: didn’t now that. There is a brandspanking new one.
This probably also means that I can delete the roon-old directory?

Hello @jean_coumans, glads to see you got some help here! Please let me know if you have any further questions.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.