Black screen after setup on Windows 8.1

(Nikolaos Baxevanis) #1

Core Machine (Operating system/System info/Roon build number)
Windows 8.1 virtual machine … VMware Fusion 11 (macOS latest as host OS).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
VMware Fusion 11 network adapter.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
After running the software, I get 2 prompts from the Windows firewall which I set both to ‘allow’. Then the app starts but I see a black screen.

But since Roon is a .NET desktop app (I suppose, by looking at the DLLs in the AppData installation folder), it should work fine on Windows 8.1?

What is the .NET Framework/.NET Core version that must be installed?

#2

I dont know for sure as I have never tried running Roon in a VM, but I would suspect this is something to do with the virtual graphics hardware specifications that VMWare is emulating, or maybe a missing driver for it in Win 8.1?

#3

I’ve run Roon in a WIN10 VM under Ubuntu. No problem.

Dunno about using Windows 8. Damn old.

(Nikolaos Baxevanis) #4

Well, if it’s a .NET app, it’s supposed to run also under Windows 7. Happy to move to another OS, but would be nice to know if this is a known issue or not first.

#5

I’m not sure it’s completely a .NET app.

I do know that Roon uses its own in-house developed language for some of its code.

#6

Have you checked the GFX configuration/driver? Roon has a dependency on OpenGL 3 support for instance. Does your VM support that?

(John) #7

Hello @Nikolaos_Baxevanis,

We do not support running Roon in a Virtual Machine. Thus, I am moving your post to the #tinkering section.

The behavior you are describing sounds similar to what you would see when the driver has issues with its openGL implementation. I would be investigating the graphics stack if I were troubleshooting this issue.

-John