Bluesound and multizone sync (via Roon)


This one is pretty in-depth: Grouped Playback exhibiting Clock Drift
but the issue was eventually resolved by the (very knowledgable) user.

also related to other hardware and eventually resolved.

And this one (but was also raised by Yannis): Grouped zones lose synchronisation over time

So there are not that many other reports but, in the last thread Mike mentions the fact that Roon is aware that syncing could be improved.

Before I’ll raise my own ticket / issue I’ll wait for BlueSound to update their RAAT implementation. According to Roon the latest update contains some improvements regarding the clocking / syncing of the slave device. So my hopes are on that update…

1 Like
(Yiannis Kouropalatis) #22

@dibb and @dhusky

Hi guys,

Just tried the workaround (many thanks @dibb) and tried grouping in BluOs first before playback via Roon. It works for a few minutes but it does not take long for music to dropout completely. Once it does I cannot restart playback via Roon at all. If I ungroup (Node 2 + Flex) via BluOs then Roon works again.
Thanks for the idea anyway :slight_smile:


wow, that doesn’t sound good at all… :frowning:

(Yiannis Kouropalatis) #24

Yep :frowning:

I have accepted that in my case at least, Roon & Bluesound is not working unless I stream to a single device / endpoint. No problems at all when using Roon with Roon Bridge end points but Bluesound devices need to be controlled via the BluOs app for reliable multiroom playback.

Hopefully others will have better experience


Hmm, I’m not willing to accept that because BS should be working with Roon (as it’s advertised to be Roon Ready). For me it’s also core functionality since most of the time I’m streaming to my living room and kitchen and syncing issues are very noticeable.

I want to give it a serious try to debug this issue (if possible), but I only can do that if BS has updated their RAAT SDK.
Until that time, may I ask how do you run Roon server? On what device and OS version?

(Yiannis Kouropalatis) #26

Totally understand and empathise :slight_smile:

I have also been trying to find a solution for the past 2 months but I feel I have run out of options to try for the time being (at least until Bluesound rolls out the updated RAAT).

My Roon Core runs on a 2017 MacBook Pro 13 Retina (Core i7, 16GB Ram, 1TB SSD, Touch Bar version). OS is the latest version of High Sierra.



Thanks for those links - some of the info was beyond my networking understanding. My ROCK install and endpoints all end up connecting via the same switch but I was wondering whether UDP for timing would still need to go via the router? Would be good to eliminate the router as potentially relevant here - for the record mine is a Bipac 7800DXL.


Thanks for the info. I thought maybe if we all run Roon server on a Mac Mini that might give us a clue, but that’s not the case…

I missed another thread with the same problem (but you already found that one I see): Third speaker out of sync

1 Like

Although latest build 298 contains grouping and syncing improvements, it doesn’t solve the syncing issue with my BlueSound devices. Guess we still have to wait for BlueSound to update…

(Andreas Baumann) #30

Any news on this issue. I have the same problems with a Node 2 and a Pulse Mini.


It’s now up to BlueSound to update the RAAT SDK. According to BS this update “is on their roadmap”.

(Shawn Brennan) #33

I have been following this topic on many threads here and on Bluesound because of the frustration of this issue. I am happy to report that with the release of BluOS 3.4 the problem appears to be solved!

FWIW… I am using a Roon Ready cocktail audio x50D connected by Ethernet cable to an eero pro and a Bluesound 2i connected by wifi and they are now playing in sync. I was very close to abandoning the Bluesound device since this functionality is imperative to its usefulness to me. (I had experimented. before the BluOS 3.4 update, with connecting the Bluesound 2i by Ethernet with no improvement in sync).

1 Like