Bluesound Node "Roon Ready" attribute has disappeared

Roon Core Machine

OS: Windows 10 Pro 64bit 21H2
CPU: Intel(R) Core™ i7-6700K CPU @ 4.00GHz 4.00 GHz

Networking Gear & Setup Details

Router: Bell Home Hub 3000 modem acts as router
Mesh: Plume pods

Connected Audio Devices

Bluesound Node Music Streamer (latest version, hardwired to my Ethernet network)
Downstream: Z-sound RDP-1 digital preamp (coaxial input from the Node)
Mark Levinson 360S DAC (AES/EBU input from RDP-1)
Krell Monoblocks
Magneplanar MG 3.6R speakers

Number of Tracks in Library

15,000 tracks

Description of Issue

I’ve been running my system in the above configuration for about 18 months, and everything has worked perfectly. In particular, the Bluesound Node has been recognized by Roon as a Roon Ready device, with all the usual beneficial consequences.

In the last 24 hours, however, Roon has somehow lost the Node’s Roon Ready attribute (see the screen shot attached). For what it’s worth, so has the BluOS Controller app. I assume this is some kind of glitch in the network handshaking between the Node’s firmware and some other network component. But I have no idea why this has happened in the last 24 hours, and I have no clue how to troubleshoot the problem.

So far I have tried the following brute-force fixes: (1) power-cycled the Node, (2) rebooted the modem/router, (3) rebooted my computer. None of these made the attribute reappear. Any suggestions?

After dinner I took one more step: (4) Opened the iOS version of the BluOS Controller app, selected Diagnostics from the menu and pressed the Reboot button. Voila! Roon Ready reappeared.

Thinking about the whole sequence, I suspect the effective steps, in order, were (1) reboot the modem/router and (2) reboot the Node.

1 Like