Bluesound Powernode 2i Playback Issues

1.6 Is Randomly Stopping Play To My Wireless Bluesound Powernode 2i Whereas Roon 1.5 Did Not Have This Issue.

1.6 seems to have made a previously always stable end point somewhat unstable. I’ve waited to report this as I wanted to give 1.6 time to settle down, but as the problem persists, I felt I would make mention of it. The only known change to any component in the chain would be the upgrade to 1.6. No new devices have been added, upgraded or changed anywhere in my network (whether related to audio or not).

My configuration is listed below. My Bluesound Powernode 2i was rock-solid under 1.5, under 1.6 it randomly stops playing in the middle of a track. This track could be from my library or from Tidal or from my Qobuz trial subscription. My wired connections seem not to have this issue.

My Conjecture:

As it seems that 1.6 did not include any work specifically on RAAT or the transport, I’m guessing there is perhaps a heartbeat problem that is caused by the same underlying issue that has caused Roon to be somewhat slower in normal operation than it was on 1.5. If Roon core has an issue causing it to be less responsive, perhaps there is a heartbeat mechanism that ensures end-points are still there and responding. If this were the case, then perhaps Roon is unable to execute that routine in a timely fashion and playback is paused on the incorrect presumption there has been a connectivity loss? Knowing nothing about the internal design of Roon, this is of course just speculation. Regardless, the upgrade to 1.6 is the only changed element, ergo there is something going on.

My Configuration:

  • Synology 3615 XS+ running Roon Core on SSD, 16GB of Memory
  • 2 Bluesound Endpoints
  • #1 Bluesound Node2, wired connection, connected to DAC via Coax out\
  • #2 Bluesound PowerNode2i, wireless, driving a pair of Harbeth P3. (set to a max of sample rate of 96KHz)
  • #3 Aurlic Aries Mini, wired, RCA out into LTA MicroZotl Headphone Amp
  • Control of playback from iPhone and iPads
  • Netgear Nighthawk R9000 Router (X10)
  • Current SW/FW on all systems
  • Music Library = ~7500 Albums / ~130K Tracks, Redbook FLAC, HiRez FLAC, DxD and DSD
  • Active Tidal subscription with some Tidal albums added to library
  • Trial Qobuz subscription (U.S. Based Account)
  • Internet Connection: AT&T Fiber 1Gig


Hello John,

Thanks for contacting us regarding this issue. I have split your post over to the support section so that we can assist you better here.

You mentioned that the Powernode 2i is experiencing this issue with both Local and Streaming content, can you let me know if the behavior is the same for your other endpoints and this issue just affects the Powernode?

How is your Powernode connected here? Is it making use of WiFi or is it connected via Ethernet? Does the same behavior occur if you connect it via Ethernet temporarily as a test?

How often does this issue occur? Is it once every now and then or more frequently?

Please let me know this information when possible.



I originally posted in 1.6 feedback because upgrading to 1.6 was the only variable that changed, it seems like a 1.6-introduced bug. The issue occurs as frequently as a couple of times per hour. I have not tried the PowerNode 2i in wired mode, as it worked perfectly before 1.6.

As for your other questions, they are all answered in my original posting.


Hi @c2c2c2,

I understand that the only thing that’s changed is your Roon version but the feedback thread is not useful for addressing individual issues, it is more of a place to provide overall feedback on the product design choices while in #support we work with users on a more individualized basis to fix issues.

Let’s try two tests here:

  1. Please reproduce this issue once more and note the exact local time in your country (ex. 2:17PM) that playback has issues. Once that has been noted, please manually send us the logs from your machine using these instructions and I’ll cross reference the timestamp in the diagnostics to see if there are any issues.

  2. As a temporary test, please try connecting the Powernode 2i via Ethernet and see if you experience the same issue. If you don’t then this gives us a great data point and would allow us to focus more on the wireless interaction between the Powernode and Roon.