Bluesound Pulse Flex no longer appearing as Roon ready device

Core Machine (Operating system/System info/Roon build number)

SonicTransporter i5; SonicOrbiter OS

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Core connected via ethernet via Netgear GS105 unmanaged switch
BlueSound Pulse Flex connected via WiFi to Synology RT2600ac router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Pulse Flex over WiFi

Description Of Issue

Since 1.7 install, I am no longer seeing the Pulse in my list of Roon Ready devices. If I watch the settings screen it can sometimes appear for a split second, but that is it.

Nothing else has changed in my network.

A quick scan of the current roon log shows lots of stuff, including connection failed type messages. If I review a log from before the upgrade, the errors messages are not present.

I can send over the log files.
Please investigate and let me know if you need anything else
thanks
Nick

PS. I should add that it doesn’t matter what roon remote I use - Windows and IOS, the Pulse still doesnt appear

Hi @Stampie,

Just to verify, have you tried rebooting your Core and the Bluesound? Any change?

Are other devices showing up okay?

Hi @dylan, yeah I’m an expert rebooter, so have already tried this.

My other devices - i.e. laptop, OpticalRendu, iPad all work fine

Hi @Stampie,

Yes, this would be appreciated. Can you use these instructions to send them over via Dropbox / Google Drive?

Is there any change in behavior if you connect the Core to the router as well?

What if you try connecting the Pulse via Ethernet as a temporary test?

Hi @noris, changing the network setup as suggested made no difference.

Logs have been uploaded - link: https://1drv.ms/u/s!AnG-Y6RCWBmVhJQeC-HyiHbnUxHcPA?e=pnttNE

I’ve included logs from a 1.6 backup to aid diagnosis.
regards
Nick

Hi @Stampie,

Thanks for sending those logs over. It looks like Roon does detect it and tries to connect to it but is unable to do so because the connection is refused by the Flex. Hmm, is the Flex up-to-date on latest firmware?

Hi @noris,

Yes the Flex is on the latest firmware. However, on a whim I decided to rebuild the index on the device, and within 5 minutes of that starting, the Flex now magically appears again as a Zone in Roon. I guess the index was corrupted and somehow stopped it connecting to Roon (even though the index is of no use in Roon terms)

I will keep an eye on it to make sure it doesn’t revert once the indexing is finished.

No idea why this would solve the problem, but might be useful if anyone else has this issue at some point

I will mark thread as resolved once I’m satisfied this is no re-occurrence

thanks for your help
Nick

Hi @Stampie,

Thanks for the update here! I am a bit confused, can you clarify what exactly you mean by rebuilding the index? Has the behavior subsided since rebuilding it?

Apologies @noris, I was referring to the index on the Pulse Flex, nothing to do with Roon.

Well, the device disappeared again over the weekend, although a reboot this morning seems to have fixed it for now.

I will continue to monitor behaviour for now
Nick
PS I have left it connected via ethernet, just to remove WiFi from the equation

1 Like

No worries @Stampie.

Can you clarify what exactly you rebooted here, was it the Flex or the SonicTransporter?
Next time this issue occurs, can you try unplugging the Ethernet cable and plugging it in without rebooting and let me know if that allows the Flex to appear again?

The Pulse Flex was rebooted.

Hi @Stampie,

Thanks for clarifying that aspect. Can you please try unplugging and re-plugging the Flex Ethernet cable when you’re next in this state and let me know if that also corrects this behavior?

Will do as requested when it next occurs

1 Like

Hi @Stampie,

I pinged out hardware team regarding this behavior. In addition to performing the Ethernet test, can you also send me a copy of your Bluesound logs next time this issue occurs?

You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy + paste the text into a text editor and send it as a shared Dropbox/Google Drive/Firefox Send link.

Thanks!