Bluesound wireless seems to be the problem

IIRC this was mentioned as an issue at one point on the BS forums…not sure if it’s still relevant or, indeed, if my memory is wrong. There’s definitely some inconsistency between products too…my old Node 2 never worked with WiFi (long since sold) whereas my Flex (not i) works fine on the same WiFi.

I have a node 2 not 2i its wires but when I have used WiFi it was fine. The old models only use 2ghz band though , 5 GHz was only introduced on the i series so wondering if this could perhaps be a part of the issue.

This was the thread I was thinking of: Bluesound can’t handle mesh points? . Haven’t looked through it all recently though.

I’m with you on this, Jay.

I have a Node 2i purchased with the intent of using it wirelessly. As it’s advertised as being a wireless device I expect it to work. To require that someone (the buyer) must accept that they must use it in a wired configuration for reliable use is unacceptable.

For context I have an ATV4K and PS4 located in the same cabinet that work without issue - all devices have line of sight to an AC router about 4 metres away. The AT4K can stream high bitrate 4K content from Plex without issue, yet the Node 2i cant handle a single redbook CD audio stream without tripping over. I’ve tried both 2.4Ghz and 5Ghz wireless modes.

EDIT: Interestingly my issue only occurs with Roon. Streaming local content using BlueOS works fine. As does Spotify. So maybe it isn’t a WiFi issue but a Roon implementation issue.

Given the comments above and my own experience I’m wondering if the problem is with newer devices - ones with an ‘i’ suffix? I use Node 2, 2 x Flex and Pulse Mini. All are fine with Roon on Wifi. The Pulse Mini used to drop out occasionally but that was a WiFi issue - upgraded the router 2 years ago and it’s been fine since. I find that, if WiFi signal shows 2 dots or more on iPad the Bluesound connection is 100% reliable.

I remember seeing something - think it was on Bluesound forum - some time ago saying that Roon used more wifi bandwidth when playing than BlueOS app. If that is true then it might explain why problems are with Roon if wifi connection is marginal.

Well, my Node 2i is about 7 feet from my router. The signal strength is nearly perfect for an 802.11ac device. At the start of even 96/24 tracks from Roon, I get a brief stutter. If I simply connect the Node 2i’s ethernet port to an Apple Airport Express (10/100 connection) - no stuttering, with any files, even if I skip around a lot with 192/24 tracks.

The problem is Bluesound’s Wi-Fi implementation.

2 Likes

I am using Bluesound on NAD M10. Works flawlessly. I am beyond dismayed by these blanket condemnations of products, software and, especially, ROON. If the fault has any merit, there would likely be wide-scale fixes instead of issues unique to you.

1 Like

I have a Bluesound Vault 2i and 2 Sonos speakers grouped using Airplay and up until recently, I have had no issues and have had for the most part seamless playback. Suddenly, I am getting consistent half-second dropouts when playing music from my Roon setup. It does not happen when playing directly via the Vault or directly from the NUC via my SSD and Mojo DAC. Everything is connected via ethernet so wireless should not be the issue. This only happens when using an Airplay group so I suspect that is the issue. I am hoping it is a Roon issue, however, as like many of the folks here I have had little to no success getting support from Bluesound.

FWIW, I have a powernode 2i wirelessly connected to a Ubiquiti Amplifi HD mesh network, streaming from Roon core running on a 2010 Mac mini (which is hardwired) and I’ve had no problems with streaming. The powernode connects to the base station on the 5 ghz band, not one of the mesh points. Base station is in a closet about about 20-30 feet away through a few walls from the powernode. Sorry to hear that others are having such problems.

I have 4 Bluesound Pulse 2i’s and I get dropped signals constantly. When I call Bluesound they check the diagnostics and it shows that my WiFi signal strength is excellent, -37 db. Bluesound then blames Roon for the dropouts. I am not technically aware to know what the problem is. The Pulse 2i’s have excellent sound quality but I hate the dropped signals. What can I do?

Do you have a range extender or an old WiFi router that can act as a bridge? See if putting one of them next to the device and then hooking it up via ethernet cable works. I’m now a week into using my two Flex 2is in this fashion without a single dropout, having never made it further than 3 songs prior to this.

Not that we should have to do this, but I’d like to see if the method works for anyone else out if curiosity

I posted this earlier, but this is exactly what I did and as you also observed, completely solved my brief stuttering issue at start of playback (or skipping to a different track).

My latest problem… this morning I turned on the TV and there was no sound coming from my Pulse 2i’s. I checked the Bluesound app and the “optical input” icon has disappeared. After hours of trouble shooting the problem I switched my TV sound mode back to the TV speakers. No matter what I did I could not get TV sound through my speakers.

To make matters worse, I then listened to Corigliano’s 1st Symphony with Roon. Though my speakers are set up in “Stereo” mode, one of my speakers kept on dropping out. I then had to delete the fixed stereo mode in Bluesound and assign each speaker a left channel and right channel. It seems to solve the problem, for now. Bluesound has become such a headache. Since today is Sunday I will call Bluesound in the morning to diagnose both of these problems.

Looking back I would’ve stuck with wired speakers if I knew that these “wireless” problems were so prevalent. You would think that as of 2019 we would be able to get reliable wireless music systems by now.

Yes, I have an ethernet range extender. It did not work for me. My signal strength always shows “excellent” so I don’t know what the problem is.

Had a lot of problems with Bluesound and also Sonos/MusicCast when I had Asus routers. Both old and brand new ones. The problem was with multicast settings on the Router. I do not know if this is a problem with other router brands also or if the problem still exists.

But got this from Bluesound in 2017 and it fixed all the problems with connections :slight_smile:

Asus released a firmware in late 2015 that seemed to have adjusted the Multicast Settings on the Router.

Multicast is the protocol that all BluOS Players use to appear in the App.

Please ensure that you are on the most recent firmware for the Router and try setting up DHCP reservations for the Players on the Router.

Please try adjusting the settings in your router to the ones in the pictures we have included.

The most important settings to change are

LAN -> IPTV: Enable multicast routing (IGMP Proxy) : Enabled
LAN -> IPTV: Enable efficient multicast forwarding (IGMP Snooping): Enabled
Wireless -> Professional -> Band 2.4GHz -> Enable IGMP Snooping: Enabled
Wireless -> Professional -> Band 2.4GHz -> Multicast Rate(Mbps): OFDM 12

Please see the pictures

image


2 Likes

OK, I am not a Bluesound user, but some of the discussion prompted me to try an alternative means of linking my audio setup to my network. Up until now I used a Powerplug but I have now put an ASUS RP-N12 wireless extender. It has decent configurability and can be configured as an access point to the network, connecting via Wireless but not transmitting. In that mode I have connected the switch in my room to the Ethernet socket on the ASUS device. That in turn connects to my core, my streamer and a Ropieee device with screen for ‘now playing’ information. It is early days but at present I see no deterioration in functional performance even with the core hanging off it. I am yet to stress it with DSD and multiple endpoints but I think this might offer another solution for those unhappy using the wireless stack on their 2i devices.

1 Like

This was exactly my issue with a Pulse 2i. Once I removed the 2.4 GHz network from the Pulse’s configuration, leaving it only the 5 to play with, my problems went away. And I received fast, courteous, and useful help from the Bluesound support team in figuring this out.

Edit: Pulse 2i, not Node 2i. Sorry, I have Node on the mind because I’m considering adding one to expand my network using a stereo amp.

Do you run separate SSIDs for 2.4 vs. 5 GHz? Is that how you removed 2.4 GHz from your Node 2i configuration? I might have to try that out and see if it helps.

By the way, do you notice any truncation of audio at the start of an album (or new track if you manually advance/skip tracks)? it’s very brief for me, like 1/2 second. (This is with Roon only for me, using the Node 2i as an endpoint).

Yes, the 2.4 & 5 GHz networks have separate SSIDs.

I haven’t noticed any truncation, no. Most of my listening is via Roon Radio, after choosing a seed song from either my local library or Tidal, so I don’t do a lot of advance/skip action at home (I do that often at work, but have a different setup entirely there.)

In your other posts on the forum you’ve said they’re wired up using ethernet. I’m glad your stuff is working but that doesn’t mean ours are, or that we’re at fault. There’s a clear problem with wireless and it’s evident by many posts on this forum.

1 Like