BluOS 3.16.1 update broken Roon Ready?

Since I updated my Node 2i with BLUOS 3.16.1, while trying to use Roon on the Node, the ‘device’ does not appear in the ‘select an audio zone’. It finds the airplay version but not the ethernet version. It worked fine before the update. Oddly, if I ask the Node to reindex, while it is actually doing it, the Node 2i shows up correctly and plays…but as soon as the reindex is completed (a library on an NTFS formatted usb drive), the Node 2i loses connection and stops playing. Is there something that I can do to correct this? My Roon Core is on a drive attached to an iMac connected via ethernet not wifi.

Im pushing this to the support threads but can you please do the following

In order for Roon’s support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Hi. Bear in mind Roon Ready was working on the Node 2i prior to the upgrade. My music system / route is: Latest Roon software with Core running on an external usb drive attached to iMac running Sierra OS. Connected to router via ethernet (power plugs, working fine with tv, radio, etc). Ethernet to ethernet switch that has Firestick and TV, Node 2i connected. Node then has usb 2TB external attached and indexed (NTFS format). From Node to DAC via optical cable. DAC is a Beresford Caiman II. From DAC to amplifier (NAD C352). Roon Core contains 65,000 songs. Access to both BluOS and Roon via iMac, iPhone 7 and iPad Air.

Hi Bob I have a PowerNode 2i and I have updated last week with no RAAT issues.
I would suggest rebooting your environment as a start and see if comes back.
I would reboot your Roon Core as well, just in case

Thank you for your advice. Should I do a factory reset on the Node 2i? To teboot Roon, should I sign out and delete the Roon software, I have Core backups?


Bob no need to factory reset everything at this point.
Just reboot the Roon Core. What platform is it on?

And when you have done that just power cycle the Node 2i

The Core is located on a usb external, powered drive attached to iMac running Sierra OS. All worked fine up until the BluOS update at end of November. Oddly, while the Node 2i is indexing, the ethernet version of the Node is available in Roon…but once the indexing is complete, it disappears…sometimes just ‘flashing’ up its presence very briefly… the Airplay version is available but I have not engaged that. The indexing is for a local usb drive plugged into the Node usb port. That has its own power hub.

Bob where is it indexing, on Roon or more likely on BlueOS app.

It will be worth rebooting your Mac and your Node.
Personally I have no music on my BlueOs, I only use it from Roon and Tidal so as to keep it doing the least possible.
I don’t know the answer to this, but it might be worth removing the indexed music from BlueOS and rebooting and seeing what that does.

Hi. Michael
That is what I was thinking…perhaps the Node cannot cope with one library on its own usb port and another library streaming via Roon from the Mac.
I will give it a go. I presume that to reboot Roon, you would just restart the iMac?

Yes just reboot the Mac is what I meant.
BlueOS should cope fine with both running, but something might have gone wrong with the upgrade so remove the storage point and you can always add it back at a later date once everything is working again

Have rebooted Roon via Mac. have rebooted Node 2i with usb disconnected. on the mac have ditched a local share in Blu OS. there are no network shares either on the Node. it is now just Node and Roon…still not seeing the Node in Roon…only fleetingly. It appears as an endpoint but clears immediately!

In activity monitor on the Mac which shows running processes, there are two indications of Roon. One is 1GB in size and is running. The other is Roon (Not Responding) at 28.9MB in size. It has always appeared thus since installing Roon. I wonder what the non-running app is.?

Add images

![image|669x500](upload://t0U0bDzJug4LF5PNHwzZ35z6TP4.jpeg) ![image|669x500](upload://g5fSbXYEMcWPfR43nZQW9zHJrb6.jpeg)

One image shows the AirPlay Node that can be enabled. The ethernet version flashes up but then disappears just below it.

Well… after all the messing about and worrying: I noticed that when selectng the Node in BluOS … it had a little logo like an arrow pointing right satung the Node was playing out to somewhere… then it showed blutooth headphones which I don’t own! So could not rectify by shutting out bluetooth and forgetting any devices! Bit the bullet and did a factory reset on the Node2i which was painless and setup again… hey presto my ethernet Node device was back! Not connecting anything else up for a bit…. THANK YOU FOR YOUR HELP Michael! I will keep the Roonies updated should it go west again. It also was updated to 3.16.1.


Sorry Bob I had to run off and get a Covid test so I can fly to the US on Wednesday and only just got back.

Glad you go there in the end though

Just as an FYI, Roon requires exclusive access to any Roon node. Clearly, in your case, it couldn’t get exclusive access because of the connection to the headphones. I’ve had similar problems for certain Roon endpoints in my network that are also DLNA endpoints, so I can stream to them using JRiver. If I am using them in DLNA mode and don’t make sure I specifically shut down that stream, I can’t access them via Roon. Also, Roon won’t show an endpoint if it isn’t connected to a DAC. Basically, it won’t show you anything that it technically can’t stream to.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.