Bose speaker works fine with OSX but on Windows it skips through songs (local and tidal)

Was there ever a resolution to this I’m seeing this same issue with my Bose 3 speaker Desktop setup. works fine on my MacBook but when I moved to a windows machine to act as my music server is skipping through all the songs, local or streaming through tidal . does not matter

Hi @Ryan_Kelley ---- Thank you for the report and sharing your feedback with us. The insight is very appreciated!

Moving forward, I have went ahead and moved your post to it’s own thread so we can address this behavior with you directly. To help aide in our evaluation of this behavior with the mentioned Bose device may I very kindly ask you for the following:

  • A brief but accurate description of your current setup using this link as a guide.

  • While it is a touch unclear to me as to the exact Bose product you are using (my sense is either: Companion 3 series 1 or Companion 3 series 2) I did some research and in both manuals for these device under troubleshooting it mentioned the following:

    Symptom: “The speaker system does not play”

    “If using a PC, check your sound card settings to make
    sure the “Digital output only” setting is turned OFF.
    This setting is typically found in the Options menu of
    the volume control icon. This icon is usually located in
    the lower right-hand corner of the Windows desktop.”


what version of Roon you are running 1.4 build 294
What operating system you are running windows 10 64bit
Basic information about the device you’re using intel NUC 16gb’s memory, 16gb optane cache, intel I7
Describe where your music is stored - local SSD over USB from bose to intel NUC
If you are using a NAS or any other kind of network storage, be sure to include the information requested in the Network section below) No
Let us know your collection size (approximate number of tracks) 27,094. happening while streaming from tidal also.

bose system companion 5

Hi @Ryan_Kelley ----- Thank you for the follow up and providing the requested feedback! My apologies for the slow response here.

Moving forward, I took a look at the provided link in your reply and the Champion 5’s user manual also mentions the same troubleshooting technique as referenced above. Have you by chance given this suggestion a go yet? Just curious what the experience is like if you have.

Additionally, how does the companion 5 work outside of Roon, say via the TIDAL application? Any issues?


it does it with any music source. i was unable to find that " “Digital output only” setting is turned OFF" setting.

also the speakers work with the system . system sounds ,youtube, movies , iTunes all output. it’s just when using roon and picking it as an audio source does it skip every song local or streaming

Thank you for taking the time to answer my questions and for touching base with me @Ryan_Kelley. Both are appreciated!

Moving forward, I would like to enable diagnostics on your account so we can take a closer look into this behavior being experienced with the companion 5 when it is mounted to mentioned Windows machine, but before I do that I would kindly like to ask you to please perform the following:

With the companion 5 mounted to the Win10 NUC…

  • Please reproduce the issue and note the album that is skipped through and the time of day when the error occurred.

Once I have the time of when the error occurred and what was being played I will enable the mentioned diagnostics as this action will automatically generate/upload a diagnostics report to our servers containing a set of Roon logs.


album : Mozart in the jungle time 1:50 MT.

I did it a couple of times between 1:50 and 1:52mt.

Thanks for the follow up @Ryan_Kelley and providing the requested feedback!

I have enabled the mentioned diagnostics and will keep an eye out on our servers for the report. Once it has been received I will follow back up so you know we have it and then I will be passing it over to our techs for review.


in the meantime, I’m moving the core back to OSX so i can listen to music

Hi @Ryan_Kelley ----- Thank you for your patience here while our team has been looking into this behavior for you.

I noticed that your ticket is still in our tech team’s queue and I expect some feedback from the team soon but in the mean time I did some further research on the companion 5 and I can see that there was a driver update on 11/28/2017. Can you please verify for me that the latest drivers for the companion 5 are currently loaded on on the Windows machine.


those are links to some third party software that is who knows what. There is nothing on Boses site about updated drivers or drivers at all. I’ll only work with manufacturer drivers

Thanks for touching base with me @Ryan_Kelley, very appreciated!

Continuing forward, I had a chance to touch base with the tech about this behavior you are experiencing with the Companion 5 when using a Win10 based machine. As per the conversation our techs have asked if you kindly provide/try the following:

  1. Please provide a complete screenshot of the “playback” settings being used with the Companion 5 when it’s mounted to the Win10 device (“audio” tab - “devices setup” - > “playback” tab).

  2. Have you tried using the device with “exclusive mode” enabled? If not, would you kindly do so.

  3. Have you tried using the device with “work around drivers that misreport device capabilities” enabled? If not, would you kindly do so.