BOSS DAC and DSF (DSD64) files

Hi everyone

I have 2 Raspberry Pi: 1 with the IQAudio Pi-DAC+ (configured with the disc image provided by IQAudio: IQ_Roon_pcm5xxx_RC7_closed.img), and 1 with the Allo Boss HI-FI DAC (configured with DietPI).
I am very happy with this material. Sound quality is pretty good, and sound synchronisation between the two devices works very well.

Recently, I had the possibility to rip my SACD discs to ISO files, then converting the ISO file to DSF (DSD64) files.
While the result is very good with the Raspberry with IQAudio, sound quality is very poor with the BossDAC (actually, it is barely audible).
I have interverted the two Raspberry’s, and the problem is clearly related to the BossDAC (or to its configuration?).

Does anyone have an idea of what could cause this problem? Of course, I could convert the DSF files to FLAC files. But before that, I like to understand how things work…

I don’t know if this helps, but here is a screenshot of the signal path when I play DSF files with the BOSS DAC (on the left) and with the IQAudio (on the right):

Note that there are other things that I don’t understand regarding the signal path: why is it of “High Quality” when I play the DSF files, and “Lossless” when I play FLAC files? Why not “lossless” with DSF files as well?
And why is the output “ALSA” with the BOSS DAC, and “Analog Output” with the IQAudio? What does that mean?

My configuration is rather simple:

  • Roon server on QNAP NAS
  • Raspberry Pi’s wired connected to the network
  • 1 Raspberry Pi (with the BOSS DAC) connected through RCA output connectors to my Rotel amplifier
  • 1 Raspberry Pi (with the IQAudio hat) connected through RCA output connectors to a B&W A7 speaker

Thank you very much for your help!

Try RoPieee.
It has been reported to work with DSD.
I’m using an Allo Boss DAC as well, but I’'m not using DSD myself.

Yes, I could try RoPieee.
But as far as I know, DietPI should work with DSD files as well.
So I suppose it should be possible to correct the problem I have with DietPI.
Does anyone have any thought on what I should do to make my BOSS DAC work with DSD files?
If not… well, I’ll try RoPieee.

If you have a spare SD card you will find out in no time, and you can revert to DietPie in a few minutes. :slight_smile:

Yes, you’re right! :wink:
I could (and will) do that.
It’s just that I like to understand why things work… and sometimes why it is not working.

I’m sure that @spockfish will be able to tell you. :slight_smile:

I tried this myself. I was using Dietpi but could not get dsd64 to work. Installed Ropieee but same result

I can confirm that it is working. I’m very happy with my Boss dac & Pi. The Pi is running dietpi.

Are you using dsd over pcm?
Did you try it with dsd64 files? states the following:

Native DSD streaming: RoPieee supports, besides DoP (DSD over PCM), native DSD on the following USB DAC’s: Allo Boss DAC not mentioned.

So it seems that only DoP (DSD over PCM) is supported by RoPieee for the Allo Boss DAC.

DSD over DoP is still DSD, just another format of transporting the bits. Despite what you might have heard, there is no audio difference between DoP and native, unless the DAC does something different with the data stream depending on how it was transported.

At least that’s what I have heard, and as a computer guy I think sound logical.

No, I didn’t use dsd over pcm.
I changed this parameter (I did it quickly this morning, before going to work, and will try again when I’ll be back home), and the result was no sound at all.

When I go back to the defaults parameters (conversion to PCM), the sound is ok for 10 or 20 seconds, and then starts to deteriorate (like a quavering voice) and becomes inaudible.
So I thought it could be due to a buffer problem, and increased the buffer size (500ms). I didn’t have much time to test it, but it seems that the sound was ok after changing the bufffer size.

One last point: when playing DSD files (even after changing the buffer size), synchronization between the two endpoints (Pi’s with BOSS DAC and IQaudio) is lost (while synchronization is perfect when playing FLAC files).

Do you think I should change something in the DietPI parameters?

It plays dsd over PCM(DoP).

What you have there is not DOP, it is conversion to PCM. Is the Boss DAC documented anywhere as being DSD capable? If it is what OS where they using?

Back from work, I did a few tests, and the results are disappointing:

  • when I set DSD Playback Strategy to “DSD over PCM”, there’s no sound.
  • when I set DSD Playback Strategy to “Convert to PCM”, the audio is really bad (with only a slight improvement when I set the buffer size to 500ms)

So, up to now, my conclusion is that I cannot play DSD64 files with my BOSS DAC (& DietPI).
What I still have to try is to install Ropieee instead of DietPI. But I don’t have much hope. And it is quite frustrating to not understand why it doesn’t work with DiepPI (while it works for others).

It is what it is.
I’m no audio codec expert, just want to report that my Pi setup is playing dsd music.
The setup is DoP.
This should work for Thierry too.
Btw: my linux kernel is 4.9.52-v7.

OK cool. It is probably doing the conversion to enable the volume reduction/control. But it may be the reason yours gives sound while others don’t which is pertinent I think.

I have installed the latest version of DietPi (Linux 4.9.56-v7+), and now the Pi can play DSD64 files (with Convert to PCM as DSD Playback Strategy; with DoP, I still have no sound).
Thanks to all of you for your help and suggestions!

I had the same issue; I could convert DSD to PCM but couldn’t understand why Roon was showing DSD64 and 128 in green for the Allo BossDAC but wouldn’t play DoP.

Johan confirmed the DAC does not support DSD:

RBM explained why Roon reports that it can: