Brand New Roon Nucleus is unable to have the software updated - This is a duplicate thread. Sorry - I'm new to room

Roon Core Machine

Brand New Roon Nucleus, Version 1.0 (build 175)
Roon Server Software, Version 1.6 (build 416)
Internal Music Storage, 1000GB, ST1000LM048-2E71, 100% of 924 GB available
Roon Labs Software, Version 1.0 (build 11)

Networking Gear & Setup Details

1GB download through Rogers ISP
Connected the Nucleus to my CISCO GB switch that is running properly

Connected Audio Devices

Not applicable

Number of Tracks in Library

Not applicable

Description of Issue

I’ve tried everything to get my New Nucleus to Update the Software. When I launch Roon on my MacMini, or iPhone or iPad I receive a screen saying Software updated needed. It tells me one or more of my devices on my network need a software update. I tried updating the Nucleus but it keeps telling me to retry. I’ve tried stopping and starting the Nucleus by accessing the screen at the bottom saying Configure Roon OS devices on your network. I have DHCP enabled. It looks like the Nucleus can be found at IP address but after trying to reinstall the Operating System and Restarting or Resetting other items, it still doesn’t work. Kindly have a Roon Support Specialist reply to me. Another Roon user tried to help but I have not been able to get it to work. Do I need to take the Nucleus back to my authorized Dealer. This is very frustrating after paying full price for it. Previously, I had no problem creating a Roon Core on an old iMac but that system is not stable and I want to use my new Roon Nucleus and relocate my Apple music to the Nucleus that came factory installed with 1TB HDD. Hoping Support at Roon can help me. Thank you.

Have you contacted your dealer for assistance? They may be able to help locally with what you are experiencing, or may recommend you bring it to them to assist in performing the update to Bulld 970.

There is something wrong with the roon server…

Thank you. Do you know if they are doing anything to fix it? I guess it’s misfortune the day I get a nucleus, Noon Server is having problems. Thanks for letting me know. Has anyone from Roon notified their customers?

Is this a rev A or Rev B nucleus? 1 or 2 HDMI ports… if its a RevA this is a very old model

appears maybe you have posted 2 threads on this matter

Sorry about creating 2 threads and thank you for letting me know. I’m new to the Roon forum and didn’t realize I did it as I am trying to request support. The unit I purchased yesterday has 2 HDMI ports as seen in the attached picture. I’m hoping you can see the picture. Please let me know if this is the older or new model. Thank you.

I closed your other thread, let’s keep everything in one place, it will be easier to track.
Thanks for your patience and understanding

Thank you.

Somehow, magically, mysteriously I was able to decommission my old core on my old iMac and was able to update the Firmware/OS on my new Nucleus, and configure it. Thank you to whoever helped me.


It’s a rev B thus a newer model.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.