Breaks in audio

Hi there,

I am copying in @support as they may have come accross my issue.

I have a recent problem whereby I am getting small breaks in music, just a second or so, and then the music will continue playing. This could be lots of issues, but I thought I would start here first in terms of HQPlayer, but the issue could be anywhere really. First off, I have no new hardware or software. And, this set-up has worked without issue for many months.

My set-up, I have the latest desktop version of HQ Player running on an i7 9700 win10 machine, I upscale everything to DSD 256. My roon core is on a dedicated NUC i7. I have an Allo USBridge streamer (using Gentoo player) feeding into a Topping D90 balanced DAC. I use the pipeline functionality with some filters from Home Audio Fidelity. I use Poly-sync-ext2 ASDM7EC with multi-core DSP and adaptive output rate greyed. The whole network is wired.

I did think initially it was an issue to do with my VPN on my PC, but even when I disble that, and HQ Player can then see the USBridge, I still get the breaks.

The breaks in music generally happen between 2-10 a song. Sometimes less and its inconsistent.

I think the issue occurs with streamed content from Qobuz and also local content stored on my DS918+ NAS. I need to verify it happens with all content.

Anyway, any thoughts as to the problem? Anything I can try to narrow the issue down?

I can’t replicate the issue with 44.1kHz 16bit 2 channel material which is either stored on the NAS or streamed from Qobuz.

Edit - This was only with PCM and not DSD, so I need to repeat. I will update shortly.

What is your Network like. Is most stuff hardwired? If not, can you hardwire the endpoint to see if the condition replicates or corrects?

Well, begin removing and simplilfying your audio chain, one thing at at time, until it works. I would start by removing HQPlayer from the chain first.

Your CPU will be on the edge for doing DSD256 with ASDM7EC modulator. You could try just ASDM7 for comparison and see if it makes a difference. On i9-9900K, ASDM7EC loads two cores to about 84% when the cores are running at 5 GHz.

ASDM7EC is about 3x heavier than ASDM7.

Thanks for the replies.

Its all hardwired, with control undertaken by android tablet and phone

I was wondering the same thing, I will do this if needed. I could connect my core direct to the DAC.

Thanks for this info, it is helpful. The chip itself is watercooled and overclocked to 5ghz. Its been running at that speed for 18 months with minimal temps or issues. Up until now, I have not had any issues when using HQPlayer (and it may not be HQPlayer obviously). What doesnt make sense to me is why it has worked for a long time and for it to then be an issue all of a sudden. I need to investigate a bit more and post a few more specifics when I know them.

The attachment shows the CPU is being pushed occasionally but not all the time.

I havent managed to replicate tonight, typically! I will keep trying. Listening to loads of stuff, all working.

Looks good, so I’d now look into the network. Any updates to the network infrastructure firmware?

Small endpoint devices generally have trouble coping with full speed gigabit traffic for longer periods of time. So they need 802.3x Ethernet Flow Control to avoid network packet buffer overflows and resulting packet loss (and resends as result which just makes the burden worse). For example about half of the smart switches have this disabled in the configuration by default and thus needs to be manually enabled. Typically this infrastructure feature is detected and enabled by the network devices. There is always a possibility that some update has disabled this feature somewhere.

Even normal desktop computers cannot always cope with constant full speed transfers. Looking at my switch’ pause frame statistics, for example my new iMac with i9-9900K CPU uses this flow control feature quite a bit. Since this feature is implemented in network hardware, it reacts much faster than higher level software equivalents.

Thanks again for getting back to me.

I do use fairly cheap switches from Netgear (and the wifi is Netgear Orbi also, with a base unit and two satellites). I have a few NETGEAR GS116UK 16-Port Gigabit Unmanaged Switches (and GS108 and GS105UK). I will need to check on the Ethernet flow control as I am not sure.

In terms of things working now, I have (by chance), restarted the NAS, the PC and the Router all over the course of the day. Although all switches have remained powered up.

Unmanaged switches usually support 802.3x, mostly by just passing it through (you can see the specs). Things like Intel NIC drivers have it enabled by default usually. Pretty much only device in my network that doesn’t support it is a Seagate NAS. But luckily that device doesn’t need to communicate with the NAA.

It doesnt look like i can check my switches given their unmanaged nature. I wonder if its an issue with the streamer.

Make sure to swap out some Ethernet cables when troubleshooting. Cable faults occur more often than people expect and “audiophile” Ethernet cables are far from immune from them. Quite often with Roon and HQP we are using full duplex as streaming music is being received while HQP output is transmitted. A faulty cable that works ok without stress can throw up errors under full duplex load.

Wow, that makes my head hurt thinking about all the cables, but its a good point.

I would like to be able to re-create the issue reliably and then try removing cables. Then I will be changing one aspect at a time.

So three to four hours in, I am now hearing breaks for a second or so in the music. It is currently streaming from Qobuz, 96kHz 24bit content.

Update: I tried restarting the PC which hosts HQ Player, but breaks in audio about 10 minutes later. I then tried restarting the router, again, breaks in audio about 10-15 minutes later. I have not restarted the NAS, but will try that, just for completeness. I do have Khazul’s roon extension running in Docker which I use for Logitech Harmony controller.

Once you make a change, Keep it Out, while doing the rest of the detective work. That being said, start by removing anything that is not vanilla Roon out of the audio chain, that includes extensions, HQPlayer, etc etc. Again, one at a time.

Did you ever try not using HQPlayer?

That is next. I couldnt replicate the problem to start with, now its back I feel I can eliminate things one at a time.

Update: I disabled HQ Player, and connected the core direct to the DAC omitting the streamer (USBridge Sig). I let it play for a while and could not hear any breaks. I then renabled the HQ player endpoint and reconnected the streamer, and I got some breaks pretty soon after playing music. I then restarted the streamer for good measure but also got breaks just after when I started to play music.

I just had a look at a system schematic I created recently. HQ player is connected through three different switches on its way to the NAA on the USBridge Sig, I am not sure if that is relevent or not.

I suppose the next step is to start checking switches and cables then. I have a thread on the netgear forums enquiring about flow control on the unmanaged switches.

Its been playing for an hour or so via HQ player, no breaks. Quite an inconsistent problem.


I decided I to swap in a RPI4 (for the USBridge sig) with @jussi_laako NAA image on it and again playing a qobuz file (96kHz) and it loaded and it played no problem(sounded great by the way), but I get the same breaks in the track. So its not the streamer, I am a little paranoid around the USB sig as I have issues with it before, so its good its not that.

So, to test cables seems straight forward, I can just swap them out, but I am not sure how to test the switches. I guess I could borrow one from elsewhere on the network and just swap it in like the cables. This could take awhile…

I have changed most cables now and swapped out switches (shuffled really) but still having issues.

In terms of my Netgear switches, it seems they cannot be accessed remotely and it does not mention flow control here - so not sure about that, I think it is disabled by default. I have both a 5 and 8 port switch in use in my system.

However, I do have a few more things in my mind to try. Most recently, I have just unchecked my home audio fidelity filters which are usually active. I have not had a break in audio yet since switching off, fingers crossed its that. I usually use the pipeline set-up using 352kHz filters. Could these be the issue?

You didn’t specify, but, I assume you are talking about HQP settings.

Yes, I have measured the room, Home Audio Fidelity generate the filters, and I load into the ‘Matrix pipeline settings’ in HQ Player.

I have the system playing as I am working today, I can’t hear any breaks yet after a few hours of unchecking the filters. I need to give it more attention later to make sure. I am not sure what it means though. Is it an error with the filters? PC not powerful enough? Something else…