Bricasti M3 - Roon Uncertified [Resolved - Cleared cache]

Roon Core Machine

I am running Roon Core version 1.8 (build814) (64bit) on a Windows 10 system. It is installed on my server with i7-9700T CPU and 16GB RAM.

Networking Gear & Setup Details

Roon core is connected via wired ethernet, the router is Netgear R7800, Roon Remote via WiFi, all on the same network.

Connected Audio Devices

Bricasti M3 is connected via wired ethernet, the router is Netgear R7800.

Library Size

Description of Issue

Roon remote dispalys Bricasti M3 uncertified, and can not enable. The M3 was manufactured in August, 2021.
My Lyngdorf TDAI-3400 works well in the same network environment.
Wonder how is the problem solved?
The screenshots are as following:

Hmm, according to Roon’s web site, the M3 should be Roon Ready and Roon puts it in the Roon Ready section of Settings==>Audio.


1 Like

Hi @zhijun_zhong,
Whilst waiting for Roon support team to follow this up for you, could you check that the Bricasti M3 has the latest firmware installed.

1 Like

Hi, @Carl
My M3 has the latest firmware installed.

After the uncertified problem occurred, I reported to Bricasti and they sent me a new SD card manufactured on Aug. 11,2021. I got the new card and replaced the one on the device, and Roon Remote still displays uncertified.

The pictures are as following:

Hello @zhijun_zhong,

Welcome to Roon Community, this is the perfect place to visit when you have any questions or experience a snag while using Roon. :wave:

I see that you’ve gotten some input from @xxx and @Carl already on this. :+1:

I’ve reached out to our Roon Hardware Expert for advice on this issue, we’ll be back in touch with you with next steps soon. In the meantime would you mind rebooting your Roon Core and check if this has any affect on what you’re seeing? :crossed_fingers:

We know you’re eager to enjoy your new Bricasti with Roon, we apologize for the delay you’ve experienced and appreciate your patience. :v:

1 Like

Hello @jamie,

Thanks very much for your quick response!

I rebooted Roon Core, restarted server and router, and replaced network cable. The display keeps as “uncertified” and can not enable.

I do hope the problem could be solved with your support and enjoy my Bricasti with Roon soon.

Your further advice and support is really appreciated!

1 Like

As a long shot, can you try a different Ethernet cable?

1 Like

Hi @zhijun_zhong, we took a look on our end and everything appears to be correct for this device, so it appears that there might be something happening in your setup preventing it from showing as uncertified.

To start, try rebooting everything: Your router, the Core, and the Bricasti.

If that doesn’t help, we’ll want to try clearing the cache on your Core. Instructions below:

1 Like

Hello @dylan ,
Thanks very much for your advice and support!
The problem was solved by deleting the Roon cache folder as you suggested.

Many thanks for your effort! @Carl @jamie @xxx
Constant support from Bricasti Design is really appreciated!