Bridging Meridian 818v3 and Roon Rock stopped working

I’ve been using Roon Rock server connected to both the main network (on one ethernet port) and directly to my Meridian 818v3 (on another).

In the past I’ve had issues making this work unless Roon Rock is booted with both ethernet ports connected to a switch and then moving the second connection over to the 818v3. As of rebooting today, I’ve discovered I can’t get this configuration to work at all.

Is this a side effect/issue with the release of 1.5 (or an update to Rock)? Is it fixable? Right now, I’ve inserted a switch as a stop-gap, but this isn’t ideal.

Interestingly, up until now, the ethernet’s port had to be connected to a switch while Roon booted and I’ve discovered that this is no longer the case. Also, an ethernet crossover cable now allows communication between Roon and the Meridian 818v3, where this wasn’t necessary before.

This suggests that the automatic MDI/MDI-X configuration in the Intel driver has stopped working. So, one issue fixed within the driver, and potentially a new one created.

Nothing changed with ROCK at all. Only the software changed with Roon 1.5.

Anyway, MDI/MDI-X is something done at the hardware level, not by the driver.

Are you seeing link status and/or traffic?

Thanks, Danny. Further testing seems to indicate that I have an intermittent connection issue with one of my new cables, which unfortunately invalidates all the testing I’ve done over the weekend :frowning: The issue about directly connecting Roon and the Meridian, however, existed before the new cables arrived, so I’ll do some more testing next week and report back.

Hi Danny

A little more testing today shows that Roon won’t talk directly to my 818v3 any more (certainly not with any consistency). I’ve tried replacing the i350 network card with another card and also tried replacing this with an Anker USB ethernet dongle (intended for the Roon Nucleus I’m planning to order), but without luck. I’m assuming I’ll have the same issue with the Roon Nucleus?

It seems happy via an ethernet switch, but this does have an impact on sound quality. Is the only option to buy a fibre-optic decoupler to deal with noise from the switch or could this inject its own noise into the path?

PS I am seeing the link status and data lights flashing, so the link thinks it is up!

I just read through this again and realized you don’t actually describe your setup. Can you do so?

Sure, I’m running Roon ROCK with one ethernet port connected to the main network and another directly connected to the Meridian 818v3. The 818v3 connects via the proprietary Meridian connections to each DSP7200SE.

The 818v3 is set to use the IP address and the second Roon ethernet port is using, both with a subnet of, and no routing or DNS address supplied.

For the second ethernet port, I have used both an Intel i350 network card, and (now) am using an Anker USB to ethernet dongle.

The other port is using the address with a subnet of, routing address and DNS of

I am missing anything out?

@support Any thoughts on this? I was planning to buy a Roon Nucleus when I return from holiday, but have been waiting until I know whether I might run into this issue on that box too (using the USB ethernet dongle to the main network) and the internal ethernet direct to the 818).

This aspect of Nucleus and ROCK will be identical in behavior.

Your setup looks right to me. I’m stumped.

If all you do is insert a switch with 2 ports connected to ROCK box + Meridian, and with power (and no other ports), and no configuration changes, it works?

Hi Danny

The main network is always connected to the switch - along with Roon’s ethernet port used for remote control purposes.

If I move the two Sooloos (Roon+818) ports to the switch, Roon starts working. If I reboot Roon with this setup, then I can then usually switch back to a direct connection and all is fine - that is until I reboot!


ok, I have one idea… don’t use 5.x.x.x – I don’t know about the 818, but I know other Sooloos gear used that IP range for some funny internal stuff. Just try a different range that has no chance to conflict.

It should also be noted that as IPv4 space ran out, unallocated space like became allocated for real. For example, your 818 is conflicting with some server in Ukraine:

Hi Danny

Thanks for such fast response.

I hadn’t realised that the 5.x range had been reallocated, I’ll move it to a seperate 10.x ip range to avoid any conflict. Can I give you an update when I get back in about a week?


yes, I’m super curious…

Thanks, I’ll let you know how I get on when I get back home :slight_smile:

Hi Danny

Sorry about the delay, Fedex managed to lose my Triton power unit on its way back from Shunyata (Fedex actually insisted it wasn’t lost, but it was more that they couldn’t find it!), which has prevented me from plugging my HiFi back in until now.

The short answer is that you appear to be absolutely correct - the IP address range 5.x is now in use by someone on the internet and appears to be what was preventing the unit from working. This hadn’t crossed my mind as I had assumed it was in the private range.

Changing this to something in the 10. range seems to have resolved this. I might add that it could be worth adding this to a FAQ somewhere as there are a few instructions floating around on the web that suggest Roon is configured to use the 5. IP range when bridging (which made sense to me as it would completely distinguish the HiFi from the IP range in use by the rest of the network).

A huge thank you for figuring this out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.