Bryston BDP-2 Network issue [Solved, same network issue]

Just purchased a BDP-2 to use with Roon, which I’ve had running without a hiccup on my pc for months. It’s hardwired to my router and gives me an ip address I can connect to via either my phone or my tablet.

Issue I’m having is that Roon won’t find the device via the audio setup tab, and I can’t seem to connect to it from my pc’s browser. All I see when I type the IP address is “192… took too long to respond” whereas it fires up just fine over wifi.

I’m a rube when it comes to networks/routers so I hope this is just a simple fix. Appreciate any help…

Hi Jak

I just sent you an email.

Let the forum know if it works, as it is just a guess on my part.


Hello Jak,

Please ensure you have the latest “stable” Bryston BDP firmware release installed and select the Roon Ready box in the BDP Manic Moose Service Tab…this will also unselect the MPD mode…The BDP-2 should appear in the Roon Audio menu thereafter.

There’s a good deal of info on the Bryston BDP series & Manic Moose in the Bryston sponsored forum. Best regards, Robert

Thanks Robert, the BDP is in “Roon Ready” mode (as shown on its display). I’ve tried restoring the player to factory settings and setting up again, but I still have the same issue. Can easily access it via my phone/tablet by typing the given IP address (which did change after the reset) but cannot access it doing the same thing on my pc’s browser, and Roon (on my PC) won’t pick it up on the network. I’ll dig through Bryston’s boards to see if I can find a solution.

Here’s another method. Enable squeezebox support in Roon settings, and activate Squeezelite in the Bryston services tab. This is not Roon Ready, but squeezelite mode which is Roon capable. This is what Bryston users did prior to the Bryston Roon certification.

After hours of head scratching, I’ve figured it out. My pc(roon core) was on a different network than my wifi network.
I just had to switch my router to act as an access point.

Thanks to everyone who gave me suggestions!