Bug 1.8: iOS App crashes when trying to add more than one Genre Tag in Album Edit

When I edit an Album to add Genre Tags, I add the first Genre, which goes ok, then the second - and as soon as enter the second, the iOS App crashes.

on Edit menu, enter one Genre Tag → Press save → leave the Edit menu.
Get back inthe Edit menu → Add next Genere Tag → press Save → Leave edit menu
—and so forth…

I guess that should not be the way this is supposed to work.

Didnt get this crash yesterday. Seems this has sorted itself out.

Whoops, got to backtrack.

There is still a problem. Roon crashed just again on me on the problem described above.

Hi @bbrip

We’ve tried reproducing this in-house, but so far our QA team has not been able to. The next time this happens can you make a note of the time it occurs and we’ll enable diagnostics on your account?


Thanks, it worked just now, but on the next crash, I‘ll inform you.

@dylan it just bombed out again. Repetitively. 21.2.2021, 16:59 CET

Maybe enabling logging would help now tracing this issue.


@dylan, Same again today 23:22 trying to add multiple genres. And again a few minutes later entering recording location / dates to a newly added album.

Only App open at that time on iPad: Roon.



It doesn just crash on the iOS App, it also crashes in Mac OS, M1 Macbook Air.

Same behaviour as described above in post #1

Hi @bbrip

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

I spoke with the team about this, and here’s what we are hoping you can do next:

  • The next time this occurs, make a note of the time it happens and the album that you were editing
  • Reply here with the name and album
  • Send us logs from your install by using the directions found here and send us over a set of logs using a shared Dropbox link.

Thanks @dylan , this specific issue has not popped up again since about 2 weeks. If it does, I‘ll let you know.