Bug candidate: Artist view using tags makes Roon remote unusable

Roon Server Machine

Roonlabs Nucelus, 16BG Ram, build 1357

Networking Gear & Setup Details

Unifi Sec-Gateway connected to ISP router, several Unifi switches, all cat5 eth cabling, no Wi-Fi

Connected Audio Devices

  • Lyngdorf TDAI-3400 (eth)
  • Bluesound Powernode N330 (eth)
  • RME ADI-2 FS Pro (via USB)
  • Mytek Brooklyn Dac+ (via USB)

Number of Tracks in Library

9700 traks, 1400 albums

Description of Issue

By applying the following steps, Roon Remote running on a M1 Mac becomes imediately (almost) unusable: (1) select Artists view, (2) selecting a tag and now the browser freezes. However, I can scroll the page, but pictures aren’t updated (3) select home, shows only the “spinning” roon logo and then nothing happens. The page won’t be loaded. From that point in time, the Roon remote keeps busy. Also a restart of the remote will not help.
What helps is: reboot the Nucelus

A fresh database didn’t solved the problem neither.

Sidenote: I’m using tags, e.g., every trak has one or more tags.

Any advice?
Regards
Stefan

PS: what I observed with the new 1357 release is: after several days of running the core, skiping a song in a playlist takes sometimes several seconds (5-10 sec. become the new normal). Doing the same on par directly in Qobuz app (running on the same M1 Mac) works like a charm. Also here: reboot the core solves the problem for a while.

Hi @Stefan_Mauron,

Thank you for your post. The QA team has requested a copy of your Roon database to reproduce the issue in-house. If you’re willing, can you please navigate to your Roon database location, copy and compress (zip) the entire RoonServer folder, and upload it here?

Thank you!

Thanks @connor upload is done. I’ve added two screenshots: one while browsing the artists section with a tag and another after I disabled the tag again (empty artist pictures).
Hope it helps

Hi @Stefan_Mauron,

Thank you for your patience. The team is investigating the case and will respond here once we know more.

Hi @Stefan_Mauron,

Thank you for your patience - we’re still in the investigation phase, but we have noticed that the log package in the uploaded database frequently mentions failures to reach Qobuz’ servers, as well as other upstream servers.

It’s not likely the source of your issue but possibly exacerbating things. I recommend, if you haven’t already, verifying that a reliable DNS server is assigned in your router settings.

We’ll reach back out more promptly once we know more - thank you!

Thanks! Did it a few days ago. However, it did not solved the problem.

Hi @Stefan_Mauron,

The most recent release fixed a vulnerability that could create symptoms similar to those reported on this thread.

I wanted to check in to see if the current build offered any relief for the issue you’ve reported here. Otherwise, we’ll pull an additional diagnostic report to inform ongoing efforts to improve performance.

Thank you!

Problem remains the same. No improvement.

Hi @Stefan_Mauron,

We’ve been reviewing this case with QA - our reproduction efforts haven’t been successful and Roon recovers, but the symptoms here are consistent with a potential memory leak. We’d like to investigate more deeply to find the vulnerability here.

Hopefully, you haven’t encountered this frequently, but if this behavior continues to plague our setup, are you willing to provide us with an approximate timestamp the next time it occurs?

We’re additionally curious about what pages you were viewing in Roon before the freezing occurred - this includes the page just before you navigated to the Artists view to apply the tag.

Thank you again for your patience. I know this has been an arduous process so far, but we’re dedicating additional resources to the case.

Thanks Conor.

Here’s a quick video. I’ve added also ping times towards the Nucelus, the Security-Gateway, the bridged ISP-router and finally towards google.com. No latency issues observed.

Test was done Sat., 10:35 CET (see timestamp in filename)

Downloadlink valid for 7 days.

If you like, I can offer direct access to the Nucleus via a Teams-Call.

Hope it helps.

Regards
Stefan

Here the Nuceus settings

Hi @Stefan_Mauron,

We have some performance improvements we’re testing in #earlyaccess. Including among the improvements is better handling for libraries with a single tag applied across a large volume of tracks - this is the vulnerability you’ve been suffering in this thread.

I’d be curious to hear if things improve once we release the next build of Roon in the coming weeks. If you’re eager to try the fix, you can join Early Access by switching your Nucleus and Remotes to the beta branch. Here are the instructions:

1 Like

Thanks for the update. I want to stay within the official release channel and will wait until the update is available. Will report back asap.

Regards
Stefan

1 Like

Hi @Stefan_Mauron,

I’d keep an eye on Software Release Notes in that case. We’re on a regular release cadence now and there should be a production build shipping in the next few weeks.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.