BUG: MQA 44.1k TIDAL tracks not playing properly in Roon

Roon Core Machine

This:
macOSMonterey12-3-1
Roon 1.8 (Build 933), but issue has existed for several 1.8 builds.

Networking Gear & Setup Details

eero mesh network. CAT 5 ethernet connection to cable modem. CAT5 ethernet connection to Roon core.

Connected Audio Devices

iFi xDSD Gryphon connected to core by USB-C to Thunderbolt 3.

Number of Tracks in Library

~13,000 tracks

Description of Issue


Tagging @support

  • TIDAL MQA 44.1 tracks that are not in my Roon library or favorited in TIDAL will switch from an Enhanced signal path to a Lossless signal path and back again several times during playback of that track in Roon.

  • These tracks always begin playback with an Enhanced signal path.

  • My DAC’s display will change from MQA to PCM when these switches occur.

  • The name of the DAC and its decoding status that show during Enhanced playback disappear when it switches to Lossless playback.

  • The switches occur so rapidly that I don’t get a decent chance to grab a screenshot of the Lossless signal path.

  • It only occurs with MQA 44.1 tracks; MQA 96k and MQA 192k tracks are immune. Not found or tested MQA 48k tracks.

  • It only occurs in Roon; playback of these same tracks from the Mac TIDAL app are normal and give the proper MQA light show on the DAC for the duration of the track.

  • Enabling or disabling the MQA Core Decoder in Roon for this device makes no difference.

  • EDIT: All DSP is disabled for this device.

Have you done basic troubleshooting like rebooting everything?

Of course. :slight_smile: Several times.

List two tracks that you have problem with. I’ll test Roon playback to Lumin MQA hardware.

You have Tidal HiFi Plus subscription right?

1 Like

Hi Peter,

Yes, I have a HiFi Plus subscription with TIDAL.

I will get a list of more tracks later, but any track on Tracy Chapman’s eponymous debut album should show the issue.

Cheers.

1 Like

A few more tracks that have/had the problem:
Kanye West: No Church In The Wild
Motley Crue: Hell On High Heels
Chris Thile/Edgar Meyer: Monkey Actually
Daft Punk: Beyond

TL;DR: It may be down to an ISP issue or Thunderbolt bus problem or Roon’s connection to TIDAL.

  • When I went to bed last night I left my Mac on to preserve the state it was in while I was having this MQA problem. I shut off my DAC, however (more accurately, it shuts itself off after being idle for a while).
  • When I tested the issue this morning, my DAC wouldn’t trigger Enhanced mode in Roon; everything(!) MQA was Lossless.
  • I restarted Roon and rebooted my DAC. Enhanced mode returned.
  • I have not been able to reproduce the issue this morning except for one brief moment. Outside of that one hiccup, Roon and the DAC behaved as expected with all TIDAL MQA tracks.
  • I don’t normally listen to Roon in the morning; I’m usually listening mid to late evening, after a day’s worth of computing.
  • So what’s different about this morning compared to my usual listening time? My neighbors are at work or otherwise not using ISP bandwidth. The computer hasn’t been subjected to a full day of reading/writing data to peripherals.
  • I’m streaming 4K TV shows right now just like we do at night, so bandwidth on my local network is likely not the problem.
  • The messed up communication between Roon and my DAC this morning may point to Thunderbolt bus issues.
  • The time of day may indicate network problems. The fact that the problem hasn’t vanished completely but only appeared once, briefly, supports that theory. Plus, Roon seems to have been fragile in this area in the past.
  • It’s still a mystery why only 44.1k MQA tracks are affected.

EDIT: Here’s what I consider “normal” or “expected” playback of TIDAL MQA files in Roon on my DAC:

With a HiFi Plus subscription and quality set to Master, I expect 24-bit delivery, not 16-bit, for most Tidal Masters, but I can be wrong.

In your configuration Roon isn’t doing any MQA processing at all, its just passing the stream directly to your DAC. The signal path information relating to MQA decoding and rendering is actually provided to Roon by the DAC in this case. For some reason your DAC is getting confused and losing its MQA authentication lock on the datastream. Given that this only appears to happen with 44.1kHz tracks I’m willing to bet that there’s some sort of intermittent glitch in your DAC’s firmware or it’s having some kind of issue with the USB-C connection to your computer.

You might want to try changing the “MQA Capabilities” of your DAC in Roon’s audio device settings to “Renderer only”. This will force Roon to perform the authentication and initial decoding of the stream. If that works without issue then the problem is likely in your DAC’s firmware.

1 Like

Hi Andrew,

Thank you for that info. I’ll experiment. Given my experience this morning, the USB-C connection is a definite suspect.

Question: If the DAC’s firmware is the issue, would you expect the firmware to have the same problem when it is the audio output device for the TIDAL app using this configuration?:


There haven’t been any similar issues playing the same tracks through the same DAC connected to the same Thunderbolt 3 port using the TIDAL Mac app. My understanding is that the TIDAL MQA Passthrough functions essentially the same way as telling Roon that the DAC is an MQA decoder.

In theory they should be the same… In practice I’ve seen issues time and time again where Tidal’s content delivery network behaves differently for their own app than 3rd-party interfaces (like Roon). In essence their app connects to one node to get files and Roon is directed to a different one. In some cases the data on that node isn’t complete and they’ll make substitutions. It’s nothing nefarious, just the luck of the draw.

1 Like

Thanks. I’ll post back after I try the “Renderer only” thing.

I’ve not experienced any of these issues playing Tidal “Chris Thile/Edgar Meyer: Monkey Actually” and “Daft Punk: Beyond” using Roon Build 935 on Windows 10 21H1 passthrough MQA (via RAAT) to Lumin T2 internal MQA Full Decoder.

@Jeff_Bellune Experiment with turning off integer mode. Some DAC do not like it.

Thanks! I’ll add that to my testing routine to see if it makes any difference.

I always wondered what that option was for. What does it do exactly as it’s only on Mac’s.

The help files say that it’s required for bit perfect 32-bit playback on Mac’s CoreAudio. It has no effect on 24-bit or less playback. It’s supposed to be benign, so unless there’s a problem it can be safely turned on.

All my TIDAL MQA tracks are 16- or 24-bit so should not be an issue. But I’m going to turn it off to see if it makes a difference.

So I guess of use only is using Roons DSP engine then and the DAC supports 32 bit.

I think we’re discussing a problem.

Known problems of integer mode:

This is what your DAC manufacturer says:

1 Like

Given that, I think I’ll leave it off on my Mac running Monterey.

@AMP Maybe the new default for this setting should be “Off”?