BUG: Private audio on PC not accessible after IP address change

Roon Core Machine

Windows 11

Networking Gear & Setup Details

TP Link Deco 5300

Connected Audio Devices

Desktop PC USB Audio

Number of Tracks in Library

Description of Issue

Replaced whole house router with new TPlink Deco 5300. Roon client on PC does not see PC audio devices. Cannot play audio on PC now. I may have set my PC Zone to private. Now because my ip address is reset, Roon won't let me see my PC audio devices? Just a guess. Need way to override private zone? Rebooted Roon Core on NUC. Rebooted PC. No luck.

Just tried uninstalling PC Roon client and selecting db info to delete. Rebooted. Reinstalled. Still no luck in seeing PC audio in Audio settings list.

There needs to be a Uber User Admin mode to override things like this?

You need to be on the device that you made private to change that setting. If the device isn’t showing when you’re using the PC, then it’s likely something else. Have you gone into Settings > Audio to check everything you require is enabled?

The devices running on the Roon client are created by the Core, not the client. So, if something interferes with that interaction the client’s endpoint will not appear. You might try the basic, turn off the Firewalls on the client and the core and see if the devices return.

Okay, making some progress. When I turn off Windows 11 firewall, the PC System Audio returns in Roon client. But, when I then re-enable the Firewall it disappears from Roon Client.

So, what is the fix for this situation? I’m not going to disable Firewall permanently.

Thanks for the help so far.

Create the needed firewall exceptions and Roon will work again with the firewall enabled:

Checked the exception list. Roon and RAAT already there for Private. I added Public and saved and did another hard boot of Roon Core on NUC.

It is now working on my PC again. A bit messy but glad to be back in business.

Thanks to all for pointing me in the right direction.

1 Like

Then check your Windows network settings - somehow your PC thinks that your new internet connection is a public network instead of a private one after you swapped your router. I think you should fix this misconception or you may have to do more firewall changes like the one you just did and security gets reduced too.

Thanks for the tip but I just checked and my wired Ethernet is showing as “private network” in Network control panel. So, I am good to go. With all the network changes, Roon Core just got a bit cranky, but it is now running well again. Thanks.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.