Bug Report: Add to library while playing the track

Escalating this to the support team, as I confirmed that I’m not alone in this. Hope the developer team will address this issue in the future release.


This is a minor annoyance that I hoped to be addressed through the upgrade but it’s still lingering on. I wonder if anyone noticed this bug (?).

When I add the album to my library (by clicking + button) while playing a track in the same album, then two parallel worlds open up: The newly added album does not show the play action of the track in play, and when I click the track in play, the album shows that it is still not added to my library. To set everything properly synchronized, I have to stop the play, go to the newly added album and play the same track.

Why does it have to be this way? Is there any way Roon can address this in the next release? As I said it’s a minor annoyance, but it is clumsy nevertheless.


I can confirm this. It’s really annoying and makes the whole process of discovering new tracks and albums via Roon Radio really clumsy. It could be a such a comfortable user experience: you like what you hear, you add it to your library and you may instantly favourite the track.

Right now the way I do it is I click “Add Album to Library” (because I prefer having the whole album added to my library even if I – so far – only like a single track on it) on the now playing screen, then I click on the album name in the now playing screen to navigate to the album, then I click “Add to Library” again next to “Play now” because it wasn’t properly added and then I try to find the name of the track that’s currently playing and which is the reason I wanted to add this album to my library in the first place. When I’ve found it, I click the heart button to add it to my favourites.

This could be made a ton more user friendly, if the “Add Album to Library” action on the now playing screen would actually work and then, when the album was added, would show a heart next to the track title for me to click on (like it shows with all the other albums that are already in my library).

I’m using Tidal, just for reference. Does this behave the same way with Quobuz?


The problem Andrew and you are having I had before, but not anymore. I was using an Asus media computer with Windows 10 as my core. I had my nephew, who’s a computer engineer and audiophile turn that computer into a Rock Roon core. I realize this is not recommended, but it’s a decent computer that was no longer being used. NUC’s are great, but not the most reliable of computers. I’m using a Moon 680D streaming DAC, so that becomes my Roon endpoint. Now when I add albums, it does it in a couple seconds. Before it took several minutes and sometimes just wouldn’t. I am no computer expert by any means, but perhaps the problems you guys are having are not a Roon problem, but a Windows or gear problem? No offense intended at all. I’m here to learn, but if I can help in any way, I will. Perhaps telling us how you’re running Roon would be a good start. Between me and the plethora of even more knowledgeable people on this service, we can help you solve that problem.

I’m using a ROCK core made with a 7i5 NUC, so I confirm that it’s not a Windows problem. Also the same problem with Qobuz. And all my remote machines are Mac on OSX.


You got me? I hope someone more experienced than me with this kind of problem will write something here.

In my case, it is exactly as @hgim82 described it and I think @Kevin_Malcolm misunderstood the issue.

When I add an album while playing a track of that album, I neither can add tags to the newly added album nor favor certain tracks directly. I have to go through “My Library → Albums” to find the newly added album. As soon as I go through the queue or now playing, it seems like another version of this album shows up that does not reference to the album I have just added to my librabry (no favorite symbols showing up etc.).

The funny thing is that the play counter goes up in both albums (the one in my library and the one that is still in the queue. So to some extent they are the same album, it just seems like the album pages are not updated appropriatly after adding an album to the library while playing tracks of that album.

1 Like

Thanks for the additional thoughts. I believe this is just a simple logical bug in the code that can be easily fixed. I assumed that this would be resolved over the updates but surprisingly it lingers on for years of updates. I hope the Roon team reads this and takes an action.


I not so much misunderstood the problem, as I had that problem and several others. Since switching to a ROCK core computer most of the problems I had are gone. The only problem I still have is I find it still a bit slow to load. I am learning, but still not really well versed at computers. I’m more here to learn from you guys. I hope you get it sorted out.

@Kevin_Malcolm To give a clear message to the Roon developer team, I suspect that you still have the same issue as it is just a code bug nothing to do with hardware. I was not complaining about slowness of the process, but the logical bug that adding an album to the library while a track is playing does not properly refresh the display - both the library addition and the play action on the same page. Read the description above and try for yourself.

1 Like

Yes I understand the problem you’re having. I had the same problem, but not now. What solved if for me isn’t applicable to you. I only mentioned load speed because that’s my only remaining problem with Roon. Not related to your problem. Sorry for causing any confusion.

@Kevin_Malcolm I still don’t think you understood the problem I’m talking about. This is Roon’s inherent code logic issue and you couldn’t possibly have solved it by going to ROCK (which I also have). Read the description in the original posting about “two parallel worlds.”

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.