Bug: Roon 610 on OSX prevents Mac from entering sleep mode (costs me as much € for energy Roon license per year!)

Core Machine (Operating system/System info/Roon build number)

OS X Catalina 10.15.6 (latest at time of writing)
Roon 1.7 Build 610 (latest at time of writing)
iMac (Retina 5K, 27-inch, Late 2014)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router Fritzbox 7580
2x WIFI mesh repeaters

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lumin T2 connected to via cable to one of the mesh repeaters.

Description Of Issue

When the Roon app is initially started, it correctly does not prevent the MacOS from entering sleep mode. Just add the column “Preventing Sleep” to the CPU tab in Activity Monitor to see this.

As soon as playback starts, Roon does correctly flag MacOS, that a sleep shall not happen. Again, you can see this in Activity Monitor or run the command:
pmset -g |grep -w sleep
which will print
sleep prevented by Roon

Once playback to any device stops, it takes around 5 minutes for Roon to let MacOS know it can fall asleep, clearing of the flag preventing sleep.

  • Minor bug: why does it take around 5 minutes to clear the flag? It should immediately do so as soon as no streaming is happening to any device

Now, while music is playing to any device, open the DSP screen and change some settings multiple times. Either switch Sample Rate Conversion on and off a few times, or add/remove/enable/disable filters.

Now, again run the command
pmset -g |grep -w sleep
it will print something like
sleep prevented by Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon, Roon

  • Major bug: doing the steps above, seems to keep adding more and more flags to the MacOS that Roon prevents sleep and those flags are never cleared, effectively preventing the Mac from ever entering sleep mode again.

UPDATE:
I now realised that Roon will also keep adding (and never reset) “Prevent Sleep” flags every time you skip to a next track while listening. So you do not need to go to DSP and change settings. This bug thus actually affects every MacOS user

  • Major bug: changing track while playing will also keep growing “Prevent Sleep” flags that are not cleared, preventing any Mac from entering sleep mode

Why I consider these major bugs:
Since the Roon app (even in the simple usage scenario outlined above) will prevent my Mac from ever entering sleep mode, the Roon software is increasing my energy bill by approximately 100 EUR per year. This is costing real money to users so it needs to be fixed fast. Not speaking of the excessive wearing to equipment due to keeping it on. So please take this seriously.

And just because I cannot keep it for myself:
Roon, don’t you have solution architects outlining how to implement things? Or code reviews?
I mean, the algorithm is so crazy simple:

Every X seconds check

  • if Roon core is streaming to any device and flag to prevent sleep has not been set yet, set it
  • if Roon core is not streaming to any device and flag to prevent sleep has been set, unset it

What seems to have been implemented, on a track level, clearing only sometimes after 5 minutes, is just so wrong…

Hi @Moli,

Thanks for the report here!

I recently spoke to QA regarding this issue, we have a ticket in the development queue regarding this behavior and an investigation into this issue has been already completed.

Our developers are planning to look at this issue, but we don’t yet have a timeframe for when that’s going to happen.

Once the ticket has been scheduled and work begins, I’ll have a better sense of timing here. Thanks in advance for your patience!

1 Like

I waited so long for a fix @noris

Roon 1.8 is here but the bug seems to be there.

Just use activity monitor, energy tab.

After initial open of Roon, „prevents sleep“ reads false. Now start playing to any device and stop. Then „prevents sleep“ will stay forever at true.

So, Roon costs me 250 EUR per year.

Really - i like the new UI. But I still miss iOS Lockscreen controls, portrait mode on iPad. And yes, over 1GB ram usage even after closing the screen. The whole underlying OS integration is where Roon is far behind and the years pass and it seems this is not the focus.

Very sad.

Hello @Moli ,

I just checked the status of the development ticket and I see that it is still in the development team’s queue.

As per policy, we can’t comment on when the ticket will reach the front of the development queue, but we are aware of this report and and the ticket is in progress.

Thanks in advance for your patience here!

Hi,

I observed the same issue with Roon 1.8 (build 884) on a Mac Mini with macOS Monterey 12.1. As I see this bug is more than a year old one and did not resolved yet, which is strange. Note however that, the power consumption of a Mac Mini is small 3-5Wh in awake mode instead of 1.4Wh in sleep mode.