BUG - Roon crashes while adding an album to the library while playing [Fixed with Roon update]

Roon Core Machine

iMac retina 5k 2017
CPU 3.4GHz intel Core i5
MAC OS Mojave

Networking Gear & Setup Details

Happening on the core, machine is connected via ethernet to a Unifi Dream Machine

Connected Audio Devices

None during the crash

Number of Tracks in Library

21671 tracks

Description of Issue

Roon crashed while playing from Tidal on the core machine and I added a new album from Tidal to the library.
Once restarted the new album was showing up in the library, I started playing again and added a new Album, again Roon crashed
Not a big deal but annoying

The programmers are certainly interested in such a bug. Please keep LOG data. I’ve been reading along for almost a year now. The first time I hear about it.

Interim solution, via Tidal or Qobuz directly hear. If it is to be played immediately trigger synchronization of the services manually or perform a restart, which performs this automatically.

It just did it again and I saved the log.

This started happening with the latest version

1 Like

I have many crashes too, software is very unstable, old versions (1.7/6…) stable like a rock, 1.8 very buggy for me. Tidal not connecting (every day), searching problems, some audio devices crashes, when I added new albums sometimes nothing happened (Tidal integration problem? Roon per se problem?), no crashes like you have when add/play, but very annoying.

Also iMac, old one, not Mojave but Catalina. WAN/LAN works 24/7, speed 750mbits, Tidal soute without problems (tv app, handhelds apps and so on).

Roon Dev?

Hello @Marcor ,

Can you please upload the log file here?



thanks done. I think the log contains 2 of the crashes. the last one being the last entry in the log


Hello @Marcor ,

Thanks for sending the log file and for the report here. Can you please confirm that this was the track that was causing this behavior? Symphony No. 41 in C major ("Jupiter"), K. 551 / Wolfgang Amadeus Mozart ? Do you recall which of the compositions it was (who performed it)? If you try to log out and back into TIDAL, are you still able to reproduce the issue? Let us know when possible, thanks!

it happened twice, one time after the other, the last time was when I added the album Symphony No. 41 in C major ("Jupiter"), K. 551 / Wolfgang Amadeus Mozart Previously was in another log that I haven’t uploaded when I added another album, it was Herbert von Karajan - Albinoni: Adagio in G minor / Pachelbel: Canon I can upload the log if you need it
I just tried now playing a track and at the same time adding a new album to the library and Roon didn’t crash.

1 Like

Hi @Marcor ,

Thanks for those details. I spoke to the team and we have an existing ticket regarding this behavior, and I’ve added your report to the ticket. As per policy, I can’t comment on a timeline of when the ticket will make it into a Roon update, but we are aware and working on this issue, thanks!

Hi All,

This issue has been resolved in a recent Roon release, marking this thread as solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.