Build 102 HQP issues

Created just in case. Hopefully this thread may not be needed !

3 Likes

Unfortunately, HQP still crashes when changing tracks, albums, unpausing, etc. within Roon. This is with the latest and greatest beta 7.

Can you email me your HQPlayer settings file? You can export it through the File-menu.

Just to be clear, this is not universal. I’m using HQPlayer with two different machines, two different DACs, with / without NAA, etc., all without issues at all.

When ‘Auto sample rates’ on, whether ‘Auto Family Rate’ is checked or unchecked, adding music with different sample rates will freeze HQP. The Radio function will also have same issue. I will have to click the disconnect button to start a new song every time. I’m doing PCM only and is converting all DSD files to PCM. Thus, the ‘Auto’ function is very valuable to me as the DSD to PCM conversion is much better with no shuttering issues. Without putting it to ‘Auto’ and set on 176.4k, some of my DSD files will continue playing with no sound. I will have to click on the disconnect button again to resume playing. Will this issue be resolved soon or am I missing something to get this worked properly?

What do you mean by “freeze”? Depending on your settings and speed of your computer, it may take up to about minute to initialize processing for different sampling rate…

It’s means that the next song doesn’t start. I using an i7 Windows 10 machine.

When this happens, is the play-button in HQPlayer down or up?

The play button is down.

Then it is most likely initializing, so wait for at least for a minute before giving up… You can check the CPU load while this is going. If any/all of the CPU cores are at 100% load, then things are going fine. If the CPU load is below 5% then something is wrong…

I think I may have solve some of my issues. Today I leave the network button in HQP up instead of down and playback continues with different sampling rates songs. Though there are crackling noise in between the songs, but at least it played.

The conversion of DSD to PCM however still have issues. Midway of the album it will go no sound. CPU load is at less than 5% but the timer continues to run both in Roon and HQP. I still have to disconnect and reconnect before any sound came back. I have tried a few different DSD album. The issue is consistent.

Is anyone still having issues with HQP 3.13 and Roon, or am I the only one?

I still cannot manually move from one song to another without HQP crashing on me each and every time. It plays fine when playing a whole album or playlist, but any manual intervention from me causes HQP to crash.

I am running both HQP and Roon on a bootable OS X SD card on very clean and basic installs of both Yosemite and El Capitan. Running a Macbook Pro with an i7 2.3Ghz processor, 16Gb ram, ExaSound drivers (5.1.3 for Yosemite, and 5.1.6 for El Capitan).

I usually run PCM to DSD: poly-sinc-shrt-mp, ASDM7, Auto.

I sent in the HQPlayer settings file a while ago when asked for, but haven’t heard back. I’d be happy to submit again, along with logs if necessary.

Hi Mark,

It’s not clear what is on the SD card: OS X, Roon, HQP or all three.

In any event I would suggest installing OS X, Roon and HQP on either a Solid State Drive or a spinning Hard Disk in the usual way and booting from that. I am surprised that you can get Roon and HQP working at all off an SD card as described. SD card read/writes are enormously slower than SSD or HD and, so far as I am aware, are not recommended hardware for either Roon or HQP.

Yes Andy, all three are running on the SD card.

I did try running off my main SSD drive with the same HQP crash results.

I think it is an issue with HQP working properly with the exaSound drivers. An observation tonight… When stopping a track in HQP, my exaSound driver icon on the menu bar still had the green “play” icon, even though HQP was stopped. Same thing when running Roon and HQP. When I stopped a track in Roon, it stopped in HQP as well, but the exaSound icon still showed the green “play” icon vs. being “stopped”, which is red square icon. Selecting another track to play crashed HQP, which may be due to the state of the exaSound driver.

I’m still having drop out issues in 102/3.13beta8 for Mac. HQP plays fine at all setting by itself, but with no setting when linked to Roon. I’m just using Roon/HQP on one 2015 iMac 5K, no NAA. I’ve tried all the different setting suggested, all the -2 strings to offset any heavy load that may be causing the drop pouts and I can’t get it to work. The auto settings don’t help either. At this point I’m not even sure what to ask for in the way of help. I’ve put significant time into trying to get this tork for me but I’m still missing something. I just don’t know what.

Hi Jeff – apart from the filters, which output setting/bitrate do you use – and what is the DAC you’re using?

I could help to set a little buffer in HQP settings – 100ms or 250ms.

And not that it should matter, but the non-beta HQP 3.13 has been out for a couple of days now.

Thanks @RBM. Here’s a screen shot.

Just another data point - I have the same DAC, and have no problem with dropouts at all. Using almost exactly the same settings, but I have poly-sinc (not the -2s variant) and DS7 as the modulator. MacBook Pro 2.5 i7, 16GB RAM.

I’ll say when I use my Mac Mini instead (output to NAA on my MacBook Pro), I have to switch to the -2s variants to keep the CPU utilization down.

@Jeff, Have you tried un-checking Pipeline SDM and restarting HQP? Does PCM play fine through Roon?

Thanks John. Good to know it isn’t the DAC.