Build 1128 all audio devices disappeared

Roon Core Machine

Mac mini M1 Monterey 12.6 Ram 8go

Networking Gear & Setup Details

Wifi ok + ethernet for 3d lab Nanoplayer

Connected Audio Devices

3d lab Nanoplayer ethernet switch Silent angel

Number of Tracks in Library

Description of Issue

After loading new Roon server version yesterday (+ new version Mac OSX 12.6) ther’s no way to manage my audio device Nanoplayer 3D lab. I can’t go back to older version because new version Mac required.
Si nothing to do else waiting you fix it.
Thanks to help !

Hi @Jean-Paul_Le_Gal,

I went ahead and enabled diagnostics for your account. It looks like Roon is failing to connect to our account servers, Qobuz, and local devices. I hate to ask this but have you tried restarting your core?

Also, is the device listed in Settings>Audio, and is it enabled?


Hi Wes
Yes I restarted the core 2 times, also for wifi and nanoplayer.
Audio midi setup and sound parameters are ok with nanoplayer (AirPlay) enabled.
I needed to re-connect with Qobuz because was lost (ok now) but all devices connected of my home are lost (iPhone, tv…) and above all the one I need to play is Nanoplayer 3dlab. For the moment I’m playing with Audirvana and it works…
Thanks for help!

Hi @Jean-Paul_Le_Gal,

This may be a long shot but is your Wi-Fi on your Mac turned on? If the mini is connected to both Wi-Fi and LAN this could cause some odd networking issues with Roon. Try turning off Wi-Fi and test again if so. In the meantime, I’m looking over other possibilities.


Hi Wes
I deleted Wifi on Mac but nothing changes. One thing to note (may be ?) when Roon update it forced me to update the Mac Osx version otherwise the procedure was blocked. I also updated the remote…

Via diagnostics, I can definitely see that your core and remote are both on the same network and both are on the appropriate version. I will take another look at diagnostics when your core comes back online.

Can you try disconnecting ethernet and trying Wi-Fi alone? If no change, please switch back.

This is what I am seeing in the diagnostics:

09/21 12:37:33 Trace: [remoting/brokerserver] [initconn>] Connected
09/21 12:37:33 Trace: [remoting/brokerserver] [initconn>] Connected
09/21 12:37:33 Trace: [remoting/brokerserver] [initconn>] Resumed Session
09/21 12:37:33 Trace: [remoting/remotingprotocolv2] resume send 0 messages, 0KiB
09/21 12:37:33 Warn: [remoting/brokerserver] [initconn>] failed: System.Exception: incomplete receive

Your core isn’t able to communicate with it and that’s why it’s not an option as a zone. I’m not sure why this is relevant to the update but I would try connecting the Nano to a different ethernet port, using a different cable, and power cycling both the device and the core. In that order.

Without ethernet nothing changes.
Changing ethernet port no change.
I can’t change ethernet cable, I have the best with Atlas Mavros
Power cycling both device and core I did yersterday.
For me the only change was your build so Î’m sure its the problem origin and I hope you can correct it.
Last information my others players are working in the same environnement.

Hi Wes,
Between 1.11 and 1.13 is the switch so I did a test with and without the Silent Angel switch but without success.
Before that I had reinstalled everything.
Others remote as Amarra or Audirvana are still working…
Now I can’t do anything more, so thanks to tell me if you think that a future version could fix it. Hold me informed because next week I will cancel my subscription, I can’t pay without service.

It’s a shame the way you did 2.0 migration!
So I canceled my subscription, without regrets!
Thank you to close my account and suppress all my data, hold me informed about it.

Paging @accounts for you. They will close your account. I’ve unlisted this topic as we do for all accounts-related matters.

1 Like


Do you by chance use Time Machine or a similar solution for backups? I have a solution for you if so.


1 Like