Build 216: Update stuck in a connect and reconnect loop [resolved with bad DSD analysis identified]

Yes even if I use the Roon client on the CORE machine its continually connecting flashing up a page and disconnecting again in a constant loop

Ive done 3 database restores after renaming the old database folders .000 .001 etc and the problem keeps repeating even on a clean restore of a pre 216 build database

Can you give me a location to upload the LOG zips to please

Contacted you via PM.

Thanks @vova for the help to identify the issue - a bad analysis of a DSD512 track - need to see exactly how you found that as the cause but good to know it was an easy fix…now to get that file to you for some inhouse testing :stuck_out_tongue:


Hello, immediately after yesterday’s automatic update to Build 216, the connection is not working between my two remote Windows 10 Lenove laptop remotes and the QNAP TVS-882 i5 16GB server that hosts the core. Everything was working fine prior to the update. Now when I launch Roon on the laptop, the Roon screen with the daily quotation launches correctly but then the GUI goes into a continuous toggle between trying to connect and disconnecting. If I try to select a core, I get this message:

Linux 3.19.8/
Version 1.3 (build 216 stable
(green dot) Ready

If I wait on that screen, the green dot cycle repeated from failure to ready…

Windows firewall is disabled. I have rebooted the QNAP and remotes PCs several times to no avail.



Hi @David_Garretson ----- Thank you for the report and my apologies for the troubles here.

Can you verify if you have tried reinstalling the remote application on theWindows 10 Lenovo laptops yet since noticing this issue?


Hello Eric,

Yes, I eventually re-loaded remote software to one of the Windows 10 laptops. The problem remains.

Hi @David_Garretson — Thank you for verifying that information for me.

Just to make sure I am understanding this behavior you are experiencing correctly. Roon appears to be getting stuck in a “connecting” then “disconnecting” loop every few seconds and as a result you are seeing the following, correct?


Yes, that’s the problem.

Hi @David_Garretson ----- Thank you for the confirmation and the follow up! Moving forward I would like to grab a set of logs from you so we can try and determine what is causing this behavior to occur.

May I kindly ask you to please connect to your RoonServer share (like you connect to any other share on the QNAP) from windows explorer. Open the RoonServer folder (located on that share) and create a zip file of your logs folder. Once the package is ready can you please upload load them via dropbox and provide me a download link in a PM?


Thanks, I just sent you a PM. Dave

Hi @David_Garretson ---- I just checked my inbox and am not seeing a PM :sweat: Did the upload complete yet?


5 posts were split to a new topic: Build 216: Unable to access Roon

Eric, I just tried PM again. Maybe I’m not doing it right. I don’t have a drop box. Can you give me an email address to send the log file to as an attachment? Otherwise, email me and I’ll reply with an attachment.

Hi @David_Garretson ---- Here is a link to the first PM you had sent me and my response to going about getting the logs over to us.


Thanks, I just dropped you my folder of logs named Dgarretson Logs.

1 Like

Hi @David_Garretson ----- Confirming that I have received your logs and that they are in our queue to be evaluated. Once I have some feedback for you I will be sure to reach out immediately with our thoughts/findings. Your patience is greatly appreciated!


This was causing what appears to be a similar symptom to what I had…might be worth a look at the logs for any DFF file analysis errors

The file/s seem to be up sampled from JRiver MC from DSD256 to DSD512

Thanks. Good call! I deleted a Wechseldominante - Babel .dff DSD file (not DSD512) and Roon now behaves normally.