Build 334: AAC 24bit conversion - audio artefacts [Resolved B339]

Hi Eric,

I’m hearing the same crackling distortion on track #2 (Down to Rest) at about 1:30 mark, in Mark’s example above.

Using my ROCK NUC thought IQaudIO DAC to my speakers.

I also had Headroom management on (only) with -3 adjustment to avoid the clipping indicator.

Cheers, Greg

1 Like

@anon55914447 — This is perfect, thank you!


Thanks for the additional feedback @Greg, adding you to my report for our techs as well :+1::microscope:


Hi @Soeren_Schulze ---- Thank you for the follow up!

Being as you cited this thread in your follow up to me in the thread you had previously opened stating that you were experiencing this issue, I have went ahead and moved your recent posts here as this is where I am currently tracking this behavior.

As I have asked others, may I very kindly ask you to please provide screenshots highlighting all the playback/zone settings being used in Roon when you notice these audio artifacts.


Here are the artifacts very massive (listening with high quality headphones):

All — I touched base with our tech team today concerning the mentioned audio artifacts being heard during playback of AAC content from TIDAL via Roon. The team has asked if you could please use the instructions found here and update ffmpeg on your core machines. Once completed please verify what the experience is like.

Looking forward to hearing your feedback!

Ahem, i’m sorry but i cant find a suitable place to place the ffmpeg-UNIX executable on my QNAP Roon Server?

I did, however, start up my MOCK Roon Server and tried the same song (O’Death - Down To Rest) on that one, same pops and crackles all over the place. :frowning:
Then, i followed your suggestion, and i downloaded the latest FFMPEG from the referred site, this one:
Put in the Codecs library, replacing an older one, and voila!, no more knittering and disturbances! :slight_smile:

So, how do we update the ffmpeg libraries on our QNAP servers?

PS Playing O’Death directly from Tidal on my Vault does sound a LOT better than when playing the same song from Roon over RAAT on the Bluesound Vault, even if the distorsion and knittering sounds are gone.
Resolution increases, volume increases, everything is noticeably much better.
I’m not talking audiophile improvements here, my grandma could hear this, and she passed away in -84…

Hi Eric,

That seems to have solved the issue on my ROCK NUC.

@Rugby and @john, notice that the info below the album cover now shows 22kHz.

Cheers, Greg

1 Like

Hi @Mikael_Ollars ---- Thank you for the updates and sharing the observation you made with the your MOCK after updating FFMPEG. Very appreciated!

With regard to the QNAP, can you verify for me that the OS is completely up to date? According to the QNAP website the latest version is: build / 20180528


Mine’s on that build. The ffmpeg included is 2.8.5

I can’t find the path at the moment.

I was on but upgraded just now. When that was finished i noticed the QNAP package for Roon Server had been updated so i updated that QNAP App also.
When finished it reported RoonServer 1.5 Build 333 so from within the Roon ecosystem i updated to build 334 and relaunched.
Once again, back to playing the olde O’Death - Down To Rest…
Sorry, still frying bacon all over the place… :frowning:

Right, I have done some titting about (when I should be working :smiley: )

It turns out there is a symlink to the path of ffmpeg that QNAP uses (which RoonServer references) here:
/usr/bin/ffmpeg which points to /mnt/ext/opt/medialibrary/bin/ffmpeg

I think this is a protected area in the QNAP filesystem.

Now, if you install the third party QNAPClub repository in AppCenter, there is a a .qkpg of ffmpeg v4.0.0 which installs to /share/CACHEDEV1_DATA/.qpkg/ffmpeg/

By altering where the symlink in /usr/bin points with
ln -sfn /share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg ffmpeg

You can now force the QNAP machine to use v4.0.0 and confirm this with ffmpeg -version

Running my test tracks again this fixes the problem.

However, I do not know if this change is persistent after a reboot because QNAP does funny things in its startup and doesn’t have a traditional Linux etc. (getting beyond my basic knowledge here) so I’m not sure how viable it is.

I think if Roon are waiting for QNAP to update ffmpeg as part of the core firmware they’ll be waiting a long time. Current ffmpeg is v2.8.5 I installed v3.2.2 to try first and that didn’t work so even if they do update, I doubt it will be to the most recent version.

Maybe @crieke could chime in and see if it’s possible to do some wizardry with his Roon .qkpg installer.

Otherwise, Roon might have to look at making their recent .aac/mp3 24bit coversion changes work with the older codec.

It would also be interesting to know what version of ffmpeg is being used by Synology in their current builds.


I just did a test with the ffmpeg 4.0 package and copied it into its own “bin” folder in the RoonServer app directory. Then I added the app “bin” path to the PATH variable in the start script. This works and it should be possible to ship ffmpeg with the RoonServer app.

Did not check Synology yet.

1 Like

Chris, did you check for persistence after rebooting?

This would be persistent as it is in the start script of RoonServer.

I will ask the qnap development team, if there are plans to update the system’s ffmpeg binary and think about the best strategy to use a newer ffmpeg on qnap.
(ship it with the qpkg vs. checking, if ffmpeg 4 is installed as a qpkg).

1 Like

Should those of us with ROCK regularly update the ffmpeg file? What are the instructions to do that, and how often?

I just checked on my devices:

ffmpeg version 2.8.5 Copyright (c) 2000-2016 the FFmpeg developers

Synology DS1511+:
ffmpeg version 2.7.1 Copyright (c) 2000-2015 the FFmpeg developers

All — First, thank you for your feedback and sharing the observations you have made since taking the update to B334. The insight has been greatly appreciated!

Secondly, I have went ahead and opened up tickets for everyone in this thread who is experiencing this issue. Our tech team is currently investigating and once I have an update on their progress I will be sure to touch base again ASAP.

Again, thank you for your patience and understanding while we try to get to the bottom of this!

1 Like

@support I have the same clipping on AAC since 334 would you like a fresh ticket opened?