Build 416: Roon Radio does not start playing after album ends

After playing an album, roon radio does not automatically start playing. The queue looks like it has picked something and should be playing. But you have to open the queue and click skip next and then play to get it started playing. Works normally after that.

1 Like

Interesting. I tried some combinations.

I cleared everything out of the queue and played one track. Roon radio started as expected after the track ended.

Cleared everything, manually added a few tracks. After the last track, it stopped, although the queue looked like it was ready to start radio.

Tried a playlist. Same thing.

Tried an album. Same thing.

Tried a single track again (like first test) and this time it stopped after the track ended.

So, it does seem hit or miss, but mostly miss for me.

I’m seeing the same behavior here. Also, once Radio fails to start as described in this thread, I can’t play anything after that. I have to restart the Roon remote on my iPad to allow me to play anything.

I hardly ever use the Radio feature, so I don’t know when this started.

PS - as R Neal mentioned, this behavior is hit or miss.

Hi @SKBubba,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this happen regardless of which zone you’re playing to?

@dylan, Yes, it happens in more than one zone (endpoint).

Core: Roon 1.6 build 416 stable 64bit, Windows 10 64 bit, Lenovo, i5-8250U, 8GB RAM, 512GB SSD, System Output

File server: Windows 10 64 bit, Dell, i3-6100, 4GB RAM, 128GB HD (OS), 2TB HD (Data)

Endpoint: Roon 1.6 build 416 stable 32bit, Windows 10 64 bit, Lenovo, Celeron 1017U, 4GB RAM, 500GB HD, Topping D10 USB, WASAPI exclusive

Endpoint: Roon 1.6 build 416 stable 32bit, Windows 10 64 bit, Lenovo, i3-2370M, 8GB RAM, 256GB SSD, USB/Optical TOSLINK converter, WASAPI exclusive

Endpoint: Chromecast Audio

Network: Wired gigabit ethernet, Belden-M Cat 5, Netgear Nighthawk R7000 router, Cisco SG 300-10 switch, Netgear GS308 switch, Netgear R6400 router

Internet connection: Cable, 214mbps download, 11mbps upload, DNS,

Library: ~15,000 tracks, ~300GB (on file server)

Streaming service: Tidal HIFI

Thanks, @SKBubba.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time that you start playback, the content you’re playing, and the time that playback ends without starting radio. Then respond here with those times, and I’ll make sure we review the diagnostics related to that timestamp.

Maggie Mae by the Beatles, start 1:43 PM, stop 1:44 PM (Eastern Daylight Time US)

Thanks, @SKBubba,

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Did you get the logs?

Hi @SKBubba,

Initially, the diagnostics report didn’t come through but I just re-enabled diagnostics and they’ve now arrived at our servers. Apologies for the delay here. I’ll be sure to reach out ASAP once the team has finished their analysis.

Hi @SKBubba,

The team is currently analyzing the diagnostics report, and I wanted to follow up with another question in the meantime.

Does the radio pick show in the sidebar before the end of the queue is reached? Or does the pick show after all tracks in the queue have finished?


In testing, it worked once and in that case it showed the next track (first radio track) before the end of the last song in the queue.

Hi @SKBubba,

The team has been trying to reproduce the behavior you’re seeing here, but so far they have not been able to successfully. They’re hoping we can gather some additional information from you since you’re able to reliably reproduce this issue.

  1. Start Roon Radio from a single track. Note the track you try to start this from and the time you start radio. Does this work?
    • Select a track by right-clicking or long-pressing, select the arrow next to play, and choose Radio
  2. Start playback of a single track. Make sure that Radio is set to start after the track finishes. Does this work? Note the time you do start the track and the name of the track.

For the above, try to choose tracks that are more well known/popular.


Hey, @Dylan:

OK, first track was Blackbird by the Beatles, started at 8:22 AM EDT US. When started using your above method (right click, Roon Radio) it worked. It selected a related track as the next track and played it.

Next I stopped radio, cleared the queue, and just played a single track, Glass Onion by the Beatles, started at 8:24 EDT US. I just played it without using the Roon Radio option. The “Start music after radio ends” option is enabled on the queue screen. The track played, and it appeared to select a related Radio track at the end, but it just stopped. It did not play the track. It says “Nothing playing” on the bottom bar and “Go find something to play!” on the queue screen. Screenshots below:

Thanks, @SKBubba! I’ve enabled diagnostics and passed this info along to the team. I appreciate your patience and cooperation here, I’ll be sure to let you know what the team finds.

Thanks for looking in to it. It’s not a huge deal. What I like to do, though, is pick an album for whatever mood I/we are in that day, play it, then let radio play similar stuff all day.

Any udate?

Hi @SKBubba,

We recently met with the team to discuss this. The team is still actively investigating this behavior. The team has been able to get this to reproduce very rarely and aren’t seeing it as often as you are reporting, so there is likely something specific to your environment that is causing this behavior to occur more often. The ticket is still open with our team to continue investigating — I’ll be sure to update you as soon as we have more information here.


Hi @SKBubba,

I checked in on the your ticket in our internal tracker. This is still under investigation by the technical team and I’ve asked them for an update.

Most aren’t experiencing this same issue with Radio not starting, so there are likely some local factors involved here.

I’ll be sure to reach out as soon as I’ve received more info on the status of the investigation from the tech team.

This appears to be fixed in 1.7.