Build 416: Roon Radio does not start playing after album ends

Did you get the logs?

Hi @SKBubba,

Initially, the diagnostics report didn’t come through but I just re-enabled diagnostics and they’ve now arrived at our servers. Apologies for the delay here. I’ll be sure to reach out ASAP once the team has finished their analysis.

Hi @SKBubba,

The team is currently analyzing the diagnostics report, and I wanted to follow up with another question in the meantime.

Does the radio pick show in the sidebar before the end of the queue is reached? Or does the pick show after all tracks in the queue have finished?

After.

In testing, it worked once and in that case it showed the next track (first radio track) before the end of the last song in the queue.

Hi @SKBubba,

The team has been trying to reproduce the behavior you’re seeing here, but so far they have not been able to successfully. They’re hoping we can gather some additional information from you since you’re able to reliably reproduce this issue.

  1. Start Roon Radio from a single track. Note the track you try to start this from and the time you start radio. Does this work?
    • Select a track by right-clicking or long-pressing, select the arrow next to play, and choose Radio
      image
  2. Start playback of a single track. Make sure that Radio is set to start after the track finishes. Does this work? Note the time you do start the track and the name of the track.

For the above, try to choose tracks that are more well known/popular.

Thanks,
Dylan

Hey, @Dylan:

OK, first track was Blackbird by the Beatles, started at 8:22 AM EDT US. When started using your above method (right click, Roon Radio) it worked. It selected a related track as the next track and played it.

Next I stopped radio, cleared the queue, and just played a single track, Glass Onion by the Beatles, started at 8:24 EDT US. I just played it without using the Roon Radio option. The “Start music after radio ends” option is enabled on the queue screen. The track played, and it appeared to select a related Radio track at the end, but it just stopped. It did not play the track. It says “Nothing playing” on the bottom bar and “Go find something to play!” on the queue screen. Screenshots below:

Thanks, @SKBubba! I’ve enabled diagnostics and passed this info along to the team. I appreciate your patience and cooperation here, I’ll be sure to let you know what the team finds.

Thanks for looking in to it. It’s not a huge deal. What I like to do, though, is pick an album for whatever mood I/we are in that day, play it, then let radio play similar stuff all day.

Any udate?

Hi @SKBubba,

We recently met with the team to discuss this. The team is still actively investigating this behavior. The team has been able to get this to reproduce very rarely and aren’t seeing it as often as you are reporting, so there is likely something specific to your environment that is causing this behavior to occur more often. The ticket is still open with our team to continue investigating — I’ll be sure to update you as soon as we have more information here.

Thanks,
Dylan

Hi @SKBubba,

I checked in on the your ticket in our internal tracker. This is still under investigation by the technical team and I’ve asked them for an update.

Most aren’t experiencing this same issue with Radio not starting, so there are likely some local factors involved here.

I’ll be sure to reach out as soon as I’ve received more info on the status of the investigation from the tech team.

This appears to be fixed in 1.7.

This issue is still occurring. First time I noticed it was just before Christmas, after the 1.7 upgrade. I intended to open a ticket the next time it happens but now I see this ticket is already open.

NUC/Rock - Roon version 1.7 (build 511). Sounds like the exact same issue with the Radio feature showing the track intended to play but not starting it. And it is an intermittent. I’ll add more information on the next occurrence.

I am having a similar experience. Don’t think it is user setup issue. Hit or miss on my end if roon continues after an album ends. It would say it works properly most of the time.

It’s happening all the time this past week. For some reason it appears to be worse now than it was. The followup radio selection is displayed but does not start. If you give the selection a thumbs up it will start and the radio continues but its no longer automatic. Or at least it has not been automatic this past week.

Hi @Mike_LC and @Brian_Runge,

Please see my post here:

It has happened several times today on different remotes, PC and Ipad. As mentioned above the radio feature has a selection showing but does not start it. Should I open a separate ticket for this issue? It is current.

Hi @Mike_LC,

Yes, it sounds like your report is a bit different than the general outage that was experienced today. Please open a new Topic with details on your setup and we’ll be able to help out!

A post was split to a new topic: Roon Radio does not start playing

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.