Build 511 - All Sonos players gone

Core Machine (Operating system/System info/Roon build number)
Roon Optimized Core Kit - Version 1.0 (build 183) stable
Roon server Version 1.7 (build 511) stable
Intel NUC i8

Description Of Issue
Today after upgrading to 511, all Sonos players (endpoints) are gone from Roon.
I tried rebooting and a cold reboot.
But none of my Sonos players are coming back.
How do I troubleshoot?

SoNos updates required I believe from another post

Hi @Baard_Ole_Grotta,

Can you please provide some more information regarding your network setup? What is the model/manufacturer of your networking gear and how are the SONOS/Core connected in this setup?

I have Ubiquiti switches and EdgeRouter ER4. The NUC-ROCK is connected to the first switch. (MAIN)

All the SONOS players have latest update 10.6, and all sonos players are also connected to the MAIN switch.
And of course I have restarted everything.
All players are in the same ip-range:

Only the AirPlay SONOS devices show up.

Is it possible to manually add SONOS-players by IP, or downgrade to 505?

Hi @Baard_Ole_Grotta,

Thanks for sharing that network setup info!

No, the players are discovered via multicast automatically, there is no way to manually add them. Downgrading is also not supported for the reasons listed in the article as the two database versions are not compatible any longer.

Just to confirm, you rebooted the Core, Switch and Sonos endpoints, correct? It sounds like you did but just double checking.

If the behavior is still the same after rebooting, can I please request that you perform a Backup of your database (for safe-keeping) and then try using another PC as the Roon Core and connect it to the main switch?

This test should help identify if this is a general networking issue or a ROCK-specific one and we can proceed from there based on the results.

Installed a new Roon-server on my MacBook Pro, still cannot see any of my SONOS-endpoints.
So my problem is not ROCK-specific.
And as you can see from my screenshot, my AirPlay compatible SONOS-endpoints show up, but I cannot play through them. Play does not start.

Reboot the router and modem too

I rebooted all of my network-gear, including switches, router and modem. No difference after that. So I rebooted one of the SONOS-endpoints, and it came back! I then rebooted the next player and then suddenly everything came back.
After a final reboot of the roon-server, everything was gone again. Very strange as everything have worked flawlessly for a long time up to build 511.
I guess something is broken in 511.
BTW: Why does some of the SONOS-players show up under “Roon tested” and some under “Other Network Devices”

Is it possible to download build 505, so I can install on another computer and get things up and running again.

Hi @Baard_Ole_Grotta,

Downgrading is not supported as I mentioned in my previous message.

Just to confirm, you used the Macbook pro in “Core” mode and not “Remote” mode correct? As in when the “Choose your Core” screen appeared, you selected “Use this PC” and not selected the previous existing ROCK setup?

If this is the case, I would next take a look at the network. We have often seen managed switches such as yours need more advanced settings to work properly. Would you by any chance have an un-managed switch which you can try connecting your ROCK and a few Sonos endpoints to and verify if that is stable?

We only show the Sonos devices we have tested in the lab under “Roon Tested”. As of the time of writing this message, the Sonos devices which are Roon tested are:

  • Connect
  • Connect:Amp
  • Play:1
  • Play:3
  • Play:5
  • Playbar
  • Sub
  • Zoneplayer 80/100

What’s strange is that the Kontor speaker has what appears to be the artwork for the Play:5 but is showing up in Other Network Devices. If you remove the Kontor from the network, does that change any behavior for the other zones?

Yes, I did install in Core-mode. Use this computer. And moved the license.

The hardwired SONOS-endpoints are already connected to a unmanged switch (zyxel gs-1100) that hangs on the USW-MAIN switch.

The Kontor-Endpoint is two Play:5 second gen, and one SUB.

I don’t want to downgrade, I only want build 505 to test with a new setup. To see if build 511 broke someting. As everything has worked great up to and including build 505. Never had any problem before.

Hi @Baard_Ole_Grotta,

Thanks for confirming this.

Just to confirm, was the ROCK/Macbook connected to the unmanaged switch or to the USW-Main?

Sometimes switches go bad, so it would be good to confirm the behavior with all endpoints + Core on the unmanaged one and then all endpoints + Core through the main one.

Unless you have the old installer executable downloaded, I won’t be able to provide previous versions. Do keep in mind that even if you do have the old, the two databases are incompatible with each other and installing it on top of an existing install might cause unstable behavior.

I tried both, no difference. Even tried only connecting one of the SONOS-players with an ethernet cable. Still a no go.

Hi @Baard_Ole_Grotta,

Is it the same Sonos player which triggers this behavior each time? Which of them did you reboot to get the system up and running again?

When restarting the earlier mentioned “Kontor” - Office, the system gets up and running again, until the next time i reboot the ROCK.

Hi @Baard_Ole_Grotta,

Happy New Year!

Is there anything different with regard to Kontor when compared to your other zones? You mentioned these are a grouped zone consisting of two Play:5s and a SUB, how are they grouped in the Sonos App? If you un-group them in the Sonos app and only group them via Roon, does the system remain stable?

The only difference is that it is a stereo zone with sub. They are one zone, in Sonos. So the players are not grouped, they are set up as one zone in Sonos.

Is it possible to get some logs file from the system to see why suddenly all non-airplay SONOS players are gone?

Hello @Baard_Ole_Grotta,

Yes, this is possible.

Can I please ask that you let me know the exact local time + date when this issue occurs again and then the exact local time + date of when you reboot your Kontor zone to get Roon working again?

E.g. at 11:37AM on 1/13/20 all the devices disappeared, at 1:41AM on 1/13/20 rebooted Kontor zone and devices re-appeared.

Once I have this information I can go ahead and enable diagnostics mode for your account. Thanks!