Build 521 Update - Issues Nexus 5 running Android 6.0.1

Hi @William_Street,

I can’t give any specific timelines regarding the release that will address this at this time, but I can say for sure that the team is hard at work to resolve this and we are hoping to release something to address these issues as soon as possible. We will be sure to keep everyone updated when this issue is resolved.

5 days now and nothing but the team is working hard. Just hard to believe in this day and age.

I understand Roon doesn’t support downgrading. I can possibly see the logic in that for downgrading server or core since they can make changes to the database. But why not allow in this case to let users downgrade Roon Remote?

There’s no reason to not make that available after 5 days of a broken upgrade. Roon Remote build 511 works flawlessly on any Android system that hasn’t been upgraded to B521.

People have reported downgrading to 511 successfully using apk files from third party sources.

At this point it seems unreasonable to not make this option available to those that need or want it.

Do you not have an alternative way to control Roon, e.g. a PC or Mac or something? I know its not a solution, but it at least means you can be using the system whilst they figure this out.

Yes, I can start Roon playback from my core in the basement, then go upstairs and listen to my headphones and have no control or access until I remove my headphones and go back to the basement and access Roon on my main computer again. Not much fun.

Or, I could reinstall Roon Remote B511 on my phone which would “at least means you can be using the system whilst they figure this out.”

It’s not like this is a free app we’re using here.

Hi @William_Street,

I’ve posted the latest update from the team here:

Since we haven’t had any update on this since the original post, am I safe in assuming there is no new information in the last 2 days?

Any new thoughts on making build 511 of Roon Remote available for download to those that would like the functionality back?

This is beyond ridiculous now. Over a week, no updates, not even replies to messages anymore. Did your team quit/get fired over this and no one’s left working?
Roon should be embarrassed. Apparently not even a thought about the inconvenience to their paying customers.

Hi @William_Street,

You have our apologies for the ongoing trouble here. The last update that we posted is still current:

This issue is limited to a very small number of devices that impact a very small number of our customers — That’s not to say that this isn’t an important issue for us to resolve, but we needed to make sure to get this specific older hardware in-house in order to do further testing.

We now have this hardware so our team is working on resolving and testing the solution and, as soon as that’s complete, we’ll be releasing the fix ASAP. These things take time, but I can assure you that our team is working to get this released as soon as possible.

Apparently not everyone is interested in Roon (Ruin) goal of pushing the graphics capabilities forward, especially when it gets to the point of making devices unworkable. If we were so worried about having the latest greatest, I know, at least in my case, I wouldn’t be using a 5 or 6 year old device as remote control. I’m guessing all most want is basic functionality, that’s reliable and does what we want in a remote.
I’m sure there are others that do want the latest greatest devices and the graphics to go with it.

It appears that Ruin has come to the point where pushing the graphics capabilities further has reached a major crossroads; where further advances appear to have “broken” Roon Remote on some older devices. Again, as has been asked repeatedly, why not simply allow users that wish, to downgrade Roon Remote to build 5.11? This gives us back the same functionality we had with Roon Remote prior to the release of Build 5.21 while allowing Roon to continue trying finding a solution to this problem without upsetting and inconveniencing so many of their users. Then, in the future, we can choose whether or not to upgrade to the next builds as they’re released, while in the meantime we continue to have functioning Roon and devices.

After over 2 weeks, this unwillingness on Roon’s part to make this simple concession seems beyond unreasonable. We get that the main Core and Server software may not be downgradable (and even that I don’t see being an issue other than possibly having to rebuild the database just as in a clean install), but there’s no issues at all running Roon Remote build 5.11 with Core/Server build 5.21. It’s beyond me how a company in this situation could be so blind or ignorant to the issues they’ve caused their paying customers.

As an aside, I notice Build 5.21 remains available for download from Play Store with no kind of warning that there are currently major issues with the release. Pretty irresponsible I think when you know it’s broken.

Thanks for nothing Ruin. Finally have Roon Remote Build 5.11 running again on my Nexus 5 with Android 6.0.1. Running flawlessly with Build 5.21 on my core/server.

Again, thanks for nothing Ruin.

How’d you re-load B511?

Here’s the link I used (kindly shared to me by another user):

First times I tried I got an “Install Failed” message. After following the instructions exactly in sequence (“How To Install APKs Bundle?”) it worked no problems.

You have to download both those files: arm64_v8a-1.7 (build 511) stable and arm64_v7a-1.7 (build 511) stable, then download and install the Split APKs Installer.

If you have any problems, feel free to ask.

Good luck.

Also be sure to disable automatic updates in Roon Core or Server to prevent Ruin trying to update to latest build.

I wasn’t able to install 5.11 but 5.05 is working perfectly on the old Samsung with my 5.21 core. And that’s just fine…thanks Bill.

1 Like

Hi Bill
Got my nexus tablet working too.


1 Like

Hi @William_Street,

You have our apologies for the ongoing trouble here. As mentioned in our latest update on this issue, we hope to have a release to address this in the near future. Generally, these types of downgrades are not something we can officially support, but I’m glad that you’re able to use this device for the moment.

As we mention in our update, we’ve acquired several of these older devices with GPUs that are older and not functioning as they should, which is in turn causing the behavior you’re experiencing. The team has created a solution to work around the issues with the GPU’s functionality and we are working on finishing our testing for the solution. As soon as the tests have been performed we will be releasing the update.

Apologies again for the trouble!


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.