Build 521 Update - Issues Nexus 5 running Android 6.0.1

I wonder if alot of these updates are tested before the release. i guess everybodys set ups are different. Im not having this issue that you are seeing William my remote won’t connect to the core even though its seeing the core but just says failed which is annoying the life out of me lolol

I’m hoping this gets fixed as well. My Nvidia Shield hasn’t worked at all with Roon since 1.7 was released in November. I’ve been in touch with Roon and was so excited when 521 came out and said, “Fixed inability to open Roon Remote on Nvidia Shield tablet”. Guess what? It doesn’t work.

I’m hoping Roon solves this Android issue once and for all so I can get back to enjoying music the way I want to enjoy music.

I thought my remote issue was with my end. Like a router issue but ive done everything i can my end by going into router settings off the ROON troubleshooting page im starting to think its the issue ROON end my phone wont connect either which is android all on the same network. Trying to use the FireHD 10 tablet which i bought just to use with ROON remote. Im pleased i only got a year sub up to now i like ROON but i cannot justify laying out for another sub with issue after issue with updates

Hi @William_Street,

You have our apologies again for the continued trouble here. Our support, QA, and development teams have been hard at work on this issue and, as soon as we have more information, we will be sure to update everyone. We’ve also pinned a general announcement about this issue here in #support and we will continue to keep everyone updated there.

Unfortunately, downgrading is not something that is supported due to incompatibilities between versions.

Once again we apologize for the issue here, William, and we will be sure to update you soon.

Thanks again Dylan. I appreciate your response. I did read your link about downgrading. I’m sure you and your team would have to agree there was a major breakdown with respect to this part during the upgrade to build 5.21:
“Our team does extensive testing to ensure these changes are safe and stable, so that each new version of Roon installs smoothly across our entire customer base, whether they started using Roon last week, or years ago.”
Also, maybe in the future, it may not be the best idea to roll out an update just before the weekend. It does appear that the resources weren’t in place to deal with major issues over a weekend. For a product like this, involving music playback, I would believe majority of your user base would be most heavily using Roon on weekends, causing the greatest potential for upset users if there are serious issues such as in this case.
In closing, I didn’t understand this part of your link:
“it’s worth remembering that Roon is a service, and our users don’t pay for any specific upgrade or version.”
Unless I’m mistaken, I thought that’s exactly what we’re paying for as part of our annual or lifetime fee.
Anyways, thanks again. From my end it appears you were about the only one working over the weekend so I’m sure you’ll be as happy to see these issues resolved as those of us that have been affected.

Would it be asking too much to get an estimate on when this issue might be resolved? Is it imminent? Days? Weeks?

Hi @William_Street,

I can’t give any specific timelines regarding the release that will address this at this time, but I can say for sure that the team is hard at work to resolve this and we are hoping to release something to address these issues as soon as possible. We will be sure to keep everyone updated when this issue is resolved.

5 days now and nothing but the team is working hard. Just hard to believe in this day and age.

I understand Roon doesn’t support downgrading. I can possibly see the logic in that for downgrading server or core since they can make changes to the database. But why not allow in this case to let users downgrade Roon Remote?

There’s no reason to not make that available after 5 days of a broken upgrade. Roon Remote build 511 works flawlessly on any Android system that hasn’t been upgraded to B521.

People have reported downgrading to 511 successfully using apk files from third party sources.

At this point it seems unreasonable to not make this option available to those that need or want it.

Do you not have an alternative way to control Roon, e.g. a PC or Mac or something? I know its not a solution, but it at least means you can be using the system whilst they figure this out.

Yes, I can start Roon playback from my core in the basement, then go upstairs and listen to my headphones and have no control or access until I remove my headphones and go back to the basement and access Roon on my main computer again. Not much fun.

Or, I could reinstall Roon Remote B511 on my phone which would “at least means you can be using the system whilst they figure this out.”

It’s not like this is a free app we’re using here.

Hi @William_Street,

I’ve posted the latest update from the team here:

Since we haven’t had any update on this since the original post, am I safe in assuming there is no new information in the last 2 days?

Any new thoughts on making build 511 of Roon Remote available for download to those that would like the functionality back?

This is beyond ridiculous now. Over a week, no updates, not even replies to messages anymore. Did your team quit/get fired over this and no one’s left working?
Roon should be embarrassed. Apparently not even a thought about the inconvenience to their paying customers.

Hi @William_Street,

You have our apologies for the ongoing trouble here. The last update that we posted is still current:

This issue is limited to a very small number of devices that impact a very small number of our customers — That’s not to say that this isn’t an important issue for us to resolve, but we needed to make sure to get this specific older hardware in-house in order to do further testing.

We now have this hardware so our team is working on resolving and testing the solution and, as soon as that’s complete, we’ll be releasing the fix ASAP. These things take time, but I can assure you that our team is working to get this released as soon as possible.

Apparently not everyone is interested in Roon (Ruin) goal of pushing the graphics capabilities forward, especially when it gets to the point of making devices unworkable. If we were so worried about having the latest greatest, I know, at least in my case, I wouldn’t be using a 5 or 6 year old device as remote control. I’m guessing all most want is basic functionality, that’s reliable and does what we want in a remote.
I’m sure there are others that do want the latest greatest devices and the graphics to go with it.

It appears that Ruin has come to the point where pushing the graphics capabilities further has reached a major crossroads; where further advances appear to have “broken” Roon Remote on some older devices. Again, as has been asked repeatedly, why not simply allow users that wish, to downgrade Roon Remote to build 5.11? This gives us back the same functionality we had with Roon Remote prior to the release of Build 5.21 while allowing Roon to continue trying finding a solution to this problem without upsetting and inconveniencing so many of their users. Then, in the future, we can choose whether or not to upgrade to the next builds as they’re released, while in the meantime we continue to have functioning Roon and devices.

After over 2 weeks, this unwillingness on Roon’s part to make this simple concession seems beyond unreasonable. We get that the main Core and Server software may not be downgradable (and even that I don’t see being an issue other than possibly having to rebuild the database just as in a clean install), but there’s no issues at all running Roon Remote build 5.11 with Core/Server build 5.21. It’s beyond me how a company in this situation could be so blind or ignorant to the issues they’ve caused their paying customers.

As an aside, I notice Build 5.21 remains available for download from Play Store with no kind of warning that there are currently major issues with the release. Pretty irresponsible I think when you know it’s broken.

Thanks for nothing Ruin. Finally have Roon Remote Build 5.11 running again on my Nexus 5 with Android 6.0.1. Running flawlessly with Build 5.21 on my core/server.

Again, thanks for nothing Ruin.

How’d you re-load B511?

Here’s the link I used (kindly shared to me by another user):

First times I tried I got an “Install Failed” message. After following the instructions exactly in sequence (“How To Install APKs Bundle?”) it worked no problems.

You have to download both those files: arm64_v8a-1.7 (build 511) stable and arm64_v7a-1.7 (build 511) stable, then download and install the Split APKs Installer.

If you have any problems, feel free to ask.

Good luck.

Also be sure to disable automatic updates in Roon Core or Server to prevent Ruin trying to update to latest build.