Build 69 Crashes - Roon quit unexpectedly

I am having a problem after updating Roon to latest build.

  • Roon version: Roon for MacOS 1.1 Build 69
  • Serial # 95280E6F-A12A-4186-9526-95B7B3311AAB
  • Mac Version: OSX 10.10.5
  • Hardware: Mac Mini (Mid 2011)
  • 16GB RAM
  • 500GB Flash Drive startup drive
  • Library: 4TB External Thunderbolt hard drive
  • Playback Device: Devialet D200 using USB
  • Library size quite big with several TB of music, with CD and - hires 24 bit files and DSF files.

Description of Symptoms:

After updating to the latest version tonight, Roon reloaded the library successfully and started played fine for about 15 minutes before it crashed in the middle of playback.

After that Roon would crash on start with error message “Roon quit unexpectedly, click reopen …”

I tried restarting the computer a few times with same problem.

Please advise ways to diagnose the problem or reset everything to fix the problem.


Hello @agentsmith, sorry for inconvenience. I’ll contact you over PM. Stand by.


I am over in Hong Kong, so may not be able to reply until late your time.

I have a similar problem. In my case Roon doesn’t finish the database conversion and it crashes 1 or 2 minutes after starting.

I backed up the Roon directory (under Library) and renamed it so Roon would create a new database but it gets stuck after reading a couple of hundred albums.

Please advice.


Hey @Pacomo – sorry for the trouble here. I’ll send you a PM and we’ll figure out what’s going on.

Hi Folks,
I am having the very same problem with Roon (build 69) crashing after trying to load for a few minutes. I’ve retried to load it several times with exactly the same crash resulting (“Roon quit unexpectedly…”).
Does anybody have an answer yet for this? Currently my Roon setup is dead, dead, dead…
petridish (Geoff Cole)

Hello @petridish, we are still analyzing logs of other users. But from the first sight the have two unrelated problems. We are going to contact you over PM with further instructions. Stay tuned.

I upgraded to the latest build on my Windows 8.1 (Basic Edition) machine.
My library contains some 140,000 tracks. Roon displayed ‘database is being updated’ or so for some 30 minutes.
After that the interface became active and, by clicking the spinner symbol, I could see progress with rescanning files on my Network share.

However, after some 10 minutes, I got a Windows notification “Roon has stopped working”.
Rebooting and restarting Roon gives the same result.

Let me know if I need to provide additional information …

Hey @GeorgeSmiley – I’m going to follow up via PM and we’ll figure out what’s going on here.

Stand by!

We solved @agentsmith issue. It appeared that his watched folder contained a corrupted file which was crashing Roon.

Yeah!!! I am next!
You guys rock.
One day without Roon and I am already depressed! :smile:

@petridish also had an issue with the file. He provided us with this file, so we will try to fix the issue from our end.

Yes, fast response and resolution. Excellent service attitude and performance as always.

YEP…Can’t be a happy situation haven’t used Roon for a few days, opened it up on my Windows 10 computer to play through stereo. Started the latest upgrade on all devices , watched the circle for a few seconds and put on some music , Tidal tracks I believe. Switched on my Surface Pro 3 to use as remote as I enjoyed dinner, 45 minutes later… music stopped. " A problem has caused Room to stop working"… windows will look for a solution …on both machines. On the remote machine option offered to choose another library, with warning I would then lose myth existing one… which has all my favourites and playlists… this is not so cool. What should I do…Roon has previously been faultless and seamless… who screwed up my evening ???

What should I do having opened Roon tonight …it started to do latest update, I chose update all devices. The circle spun I started playing music on Windows 10 computer plugged into my DAC attached to stereo, went into other room opened up my Pro 3 as remote, it started updating. 45 minutes or maybe 30 later music stopped , pop up on both machines, Roon has stopped working. Closed that window, an offer to choose another library with warning that will no longer be able to use old library…first error in a year with Roon, what shall I do?? I don’t want to lose my playlists and favourites…help …:frowning:


Hi Keith,

It sounds like your main Roon install has stopped for some reason, if that’s not running then the Remote Roon will not be able to connect to it hence the message.

I would ignore the warning on the RoonRemote install for now, I suggest you restart your main Roon and then report back on how it progresses or not.

Can you also provide information on the hardware you are running Roon (computer, NAS, LAN, WiFi, etc.)

@Mike, I think the warning on RoonRemote library selection change should be reviewed.

Hey @kjwho – sorry for the trouble here. I’m going to follow up via PM and we’ll figure out what happened here. Stand by!

MacBook Pro 2010, i7 2.66GHz, 8 GB RAM, 2 TB SSD, OS X 10.8.5, QNAP NAS, 25k Tracks in Library, iPad Retina Remote
Roon was very stable. I was a very happy camper.
Since upgrading to the latest build 1.1 (Build 69) I had several crashs immediately after starting roon app:

Reinstalling roon from download didn’t help. Replacing the roon directory in /library from backup solved the problem – until roon crashed again…
What to do to regain confidence?

Jip same problem, after update it crashes.