Build 933: Back button and header unresponsive on some pages [SOLVED: Build 935 with fix is now live]

Roon Remote UI issue

iPadOS 15.4.1
If I choose “Genres” in the main menu:

I can’t go back. The arrow is inactive (unclickable):

To resolve this I have to delete Roon Remote and insatll it again.

The same on Windows 10, but here I can push Ctrl+Left Arrow on a keyboard to go back to Home screen.

Actually, I noticed this issuue on a previous build.

This isn’t a Build problem. As usual, the Remote app had to be updated, which happened when you reinstalled it, to be in sync with Core update.

Not sure I follow?

I updated Core and Remote first and then tried to experiment.

The OP is implying that there is a problem with Build that was only solved by deleting and reinstalling Roon Remote.

In almost all Builds, that I can remember, the Remote app must always be updated. This happened when the OP deleted/reinstalled Remote app, thereby initiating an action that could have been accomplished (per the Build notification in Settings==>About), by a simple app update.

All of my 3 remotes are up to date and the back arrow does not work for me either.

1 Like

Well, ok. Now I delete Remote again, installed it
Core and Remote both have version 1.8 build 933
Went Menu → Genres and got the issue I described :smile:
Navigation arrows on Genre tab are unclickable.
So now I have to delete Remote again, because I don’t want Roon to open on the Genres tab or any other tab except Home screen
And now I avoid Genres tab

OK, it seemed like you were saying that the problem was resolved by a delete/reinstall, but I guess it wasn’t if you have to do it again.

Seems like you and @rbo have a problem with updating the Roon Remote. Sorry I got in the way.


@Serge_Tse , I have the same issue on my iPhone 12 mini. Try to slide back using the native iOS / iPadOS functionality. Works for me.


Trying to help is not getting in the way :slight_smile:

I do not have a problem with updating and updates were successful. As far as I am concerned, this is a bug.

1 Like

I’m having the same issue. Also, the Menu button doesn’t work at that point. **

I noticed that if I go one step further and click on a Genre, the back button and Menu button starts to work again.

As UliR mentioned, swiping does work.

**EDIT: Actually, none of the buttons at the top of the screen work when you go into the Genre screen.

iPad 7th gen, iPhone 12 Pro, everything running latest firmware.


I can replicate the issue with the back button on the Genre main page as well on my iOS devices (iPhone, iPad) and macOS. When I click on a Genre and go back to the Genre main page the button starts to work again (even when I then go back to the homepage and from there to the Genre main page again).


I have exactly the same behaviour (Mac client and core on the same Mac mini M1).

Hey @Serge_Tse, @RBO, @Saturn94, @UliR, @DaveN

Thank you for your report. Can you try restarting the affected devices? That resolved the issue on my iPhone but the issue persisted on my iPad and Mac. We’ve replicated it internally and can confirm that the bug affects the entire header on several pages.

The menu button appears to be working for us when in this state, can you gents kindly confirm if that’s the case for you.

We’ve moved your posts to this new issue thread so we can respond with updates here. This report has triggered an all-hands response and we’re currently investigating in order to get a fix patched as quickly as we can. We apologize for the trouble and inconvenience. Thank you again for bringing this to our attention :pray:t2:


Rebooting everything made no difference for me. :frowning:

1 Like

The menu button works for me but sometimes only after multiple taps. However, I just realised that the bookmark, search and profile buttons on the top right are unresponsive as well.


Same on my 10.5” iPad Pro running iOS 15.4.1. On most screens the buttons at the top don’t work (apart, thankfully, for the menu button, although that sometimes needs a few taps, as @Toscana says above).
The buttons work fine on the ‘tracks’, Live Radio, Qobuz, Compositions, Playlists and settings screens, but no others.
My iPhone 13 Pro seems unaffected.


1 Like

Hey @Toscana, and @Michael_Curtis

Thank you for following up, we appreciate the help. I can confirm your observations, the back and other header buttons appear to have issues on the Genre, Album, Artist, Composers, My Live Radio, and Tags pages. We’ve categorized this bug as an emergency and we’re aggressively working on a solution.

I’ll be back in touch with updates


I wasn’t able to replicate on my iPad Pro 12.9 2020 but i did on my iPad 9.7" 2018 (both on iPad OS 15.4.1)
However, after visiting one of the Genre-views the issue was gone.
It seems i can replicate if i restart the app, and visit Genres immediately, then the top bar (except the menu) becomes unresponsive.


@jamie - Rebooting iPhone 12 mini made no difference for me. No ipad currently available.

1 Like