Build 943 crashes when accessing the settings menu [Solved: Update to Build 970]

I upgraded ROCK today and the client on my old MacBook Pro (2013 I think) running Big Sur. Trying to access Settings just closed the app with no error message. Tried it a few times then rebooted the Mac, but this made no difference.
Tried it again a few hours later and the problem seems to have disappeared.

I needed to access Setting because updating one of my RoPieee endpoints caused it to disappear from Roon. It needed reenabling to be visible. Not looking forward to doing the other five tomorrow.

That’s exactly my experience. Except that in my case the 2013 MacBook Pro running Big Sur didn’t show the problem, but the 2012 iMac running Catalina. And yes, if Roon app keeps running for 10-15 minutes, the problem goes away. I experienced the same problem for a second time yesterday, after a power outage which took both my Roon Core server and the iMac off the grid without proper shutdown. When recovering from the outage and turning back on the apps, Roon on the iMac crashed once again on trying to access the ‘Settings’ menu. And once again the problem went away after 10-15 minutes…

But if I simply close Roon app on the running iMac and then open the app again, the problem doesn’t manifest itself. Weird…

Edit: If closing Roon app on the affected Mac for a long period (over night), the problem returns when opening the app again next morning. But, as before, after some time it goes away.

BTW, I am looking forward not only to a fix for this problem, but rather an explanation of what was at fault… out of sheer curiosity…

For a solution approach, one more observation:

Under Manjaro, my Wine GUI also crashes under certain conditions.

  1. i use a large database
  2. the Linux server is in autostart.
  3. the Wine GUI is started before the server has read and completed everything.

After 10 or 15 minutes, the problem no longer occurs.

During the startup phase, something seems to overlap and interfere with each other. Of course, this is only noticed by every customer who also always restarts.

If I start the Wine GUI before the server, the crash problem does not occur either.

1 Like

It crashes when clicking on settings here also after the update? :frowning: .My controller is a Microsoft Surface running Windows 11.
It was all fine before this update.

I have the same issue. Clicking settings on the core machine (via remote desktop as that machine is tucked away with just a power cord and ethernet cable) crashes Roon.

If i click settings on my iPad the app crashes but not the core server.

It doesn’t crash on my iPhone or using the client app on my Windows 10 workstation.

A bit busy with work at the moment but if the problem persists I can dig into logs later on.

I’m lucky enough to have plenty of hardware to acess Roon but if I’d been limited to just the core and my iPad it would have been a huge issue.

I see others have mentioned Ropieee in this thread and I just added two of those having none before. No idea if it’s related just thought I’d add it as a data point for the devs looking into this,

1 Like

Hi everyone,

Thank you for your patience so far on this issue. While we don’t have a comprehensive resolution, I’m writing to update that we’re working diligently with QA to isolate the problem and we will provide more information in this thread as it becomes available.

If you are continuing to experience a fatal crash on accessing Settings, a troubleshooting step you can try in the meantime is to clear your GMS files. The crash appears to be related to graphical elements, so this will reset the interface portion of Roon. Please follow the steps below:

  • Exit out of Roon\RoonServer on the affected device
  • Navigate to your Database Location\Database\Registry\Client folder path
  • Locate and delete any file that starts with GMS
  • Start Roon again and let us know if the issue is resolved

Clearing GMS has resolved the issue for many users. If it doesn’t change the behavior on your device, please stay tuned for now, and we will provide another update shortly.

1 Like

Deleting the files starting with GMS doesn’t fix the issue on my iPad Pro.

Same here on WIN10 server with parallel full app install, no matter if deleting GMS*.* in Roon and/or RoonServer folders.

Does not help… this issue has gone on too long. Either resolve it or rollback. I had no issues prior to this update.

Roon doesn’t crash for me when entering settings. I just checked. Qnap code I pad pro remote.

Mine also works without issues :thinking:

1 Like

Hi Connor.
I have the same problem on my MacBook Pro running the latest macOS and Roon releases.
I’ve deleted the GMS files as per your instructions, but the Roon app still crash if I try to reach the settings tab.
Please help.

Thanks you, Pino.

So glad for you, but it does for many of us. It is a huge issue that needs to be resolved. I also think that Roon needs to include a rollback option for future updates.

1 Like

Yes, I appreciate your frustration, but I posted so people don’t think this is an issue for everyone. There must be a particular issue in your set up, which needs to be discovered.

Evidently not for everyone, but for enough users to not simply assume it’s a particular issue of a particular setup. Many affected users seem to be running on MacOS, but there have been reports of the problem on other OS, too.

I appreciate that Roon is aware, taking this seriously and investigating to crush the bug.

1 Like

I have a Windows setup, and I have been running Roon for many years now (pretty much since the very beginning). I am also a professional software developer, database administrator, and system administrator. This is the absolute first time that an update caused an issue for me. Assuming it is in my particular setup is very much a mistake.

I am running a Falcon Northwest PC which was customized to my specs as my server machine. I also completely minimize Windows footprint to the absolute minimal for top performance. I run two pieces of software on this machine. Roon and HQPlayer.

I use a Microsoft Surface as my controller. I did the suggested check, which did not work. The issue is most probably in the controller software, not the server/core. When Settings closes Roon whatever is playing continues. Also, the suggestion was to delete a file which is actually located on the controller machine.

I also believe that moving forward Roon needs to include a rollback option so that users are not affected when issues arise and while they work to resolve them. This is usually considered an absolute minimal when programming updates for virtually any software applicaiton.

1 Like

It is in your set up if roon have made an error in how the client works on a Microsoft Surface. Their issue being relevant to your set up as opposed to a Lenovo user.
I believe Chris was alluding to an individual’s infrastructure setup not how they have set their infrastructure up.
BTW due to the nature of the hobby professionals in IT are strewn across the forum.

A surface is a standard PC in tablet format from the company that builds the OS. It runs Windows 11 and I guarantee you there no difference in how it runs the controller software than other PC machines, such as Lenovo.

Yes i know but it has a different graphics card and drivers and roon build their interface using their own custom graphics engine which screws up all the time on graphics changes. So…
I had various surfaces when i worked at Microsoft. Where we were all alpha testers for OS variants on Surfaces.

I get where you are coming from, but it does not have a unique graphics card. It uses the Intel graphics built into the CPU. It is a new enough CPU that it can run Windows 11 (which really only runs correctly on CPUs that are under three years old). But most importantly it has run flawless and unless I missed it, I do not believe Roon made any changes to the GUI which could be affected by graphics.

Also, the screen and interface work perfect, the only issue is when the Settings button (or link) is clicked. At this point Roon literally closes. Therefore, no settings, audio, about (to verify both core and controller version for example), storage, etc. are unavailable. I can use Roon and listen to music, but I can change nothing… surprising how much I use this function now that I can’t.

I do not know, but I am guessing that the settings screen runs on a different screen, and the main Roon interface screen closes when it opens. However, the Settings screen simply does not open, therefore it appears as if Roon has crashed… this is only my speculation of course…