Build 943 crashes when accessing the settings menu [Solved: Update to Build 970]

Deleting the GMS files did not solve the problem

That is very helpful, thank you!

You are welcome Bert… I was actually a tad surprised that no one from Roon suggested this after I discovered it. I never tried manage profiles ever before, but it does seem to access all (or most?) of the settings functions.

Strange enough is that after I used your workaround I can access the settings again without a crash.

Cool… my “Settings” still crashes, but so long as I have an easy way to get to those controls, I am fine. I still think Roon Should be adding a roll back option in case a user has an issue.

It works :+1:t2:

Hello everybody,

The team appreciates your continued patience on this persistent issue. While we were unfortunately unable to pinpoint the exact cause of the crash prior to the weekend, tech support and QA have escalated this and it’s a top-priority investigation. We will keep you posted in this thread as soon as we have developments to report.

To summarize, it’s a fatal graphics-related crash upon accessing Settings. Some users have reported resolution after a Core/Remote reboot and by clearing GMS files (see above post here for instructions). Other users have seen no effect with troubleshooting steps so far.

As a workaround (thank you @Randy_Myers for pointing this out), you can access the Roon settings interface by clicking “Manage Profiles” on your user icon on either mobile and desktop clients.

Stay tuned, and I will report back shortly.


I run Roon Build 943 on my M1 MacBook Air and began having the persistent ‘crash upon clicking Settings’ issue several days ago. This morning, it came to mind to try the universal (on macOS) keystroke shortcut [⌘ + ,] to access Roon’s settings… and it worked! No crash. What’s more, I now no longer have an issue accessing settings via the click method either. So far, all seems back to normal and has held thru a couple of intended Roon reboots as well.



I have a Macbook Pro with the same problem. It’s unfortunate this is happening, for sure; but, I’m glad I’m not alone in this and I’m sincerely grateful to others who have identified some workarounds.

Both, clicking on, “Manage Profiles,” or using the universal keystroke shortcut identified by @Randy_Myers and @jonathan respectively work for me.

I anxiously await the fix.

Thank you,


1 Like


In case this information could be useful to the Roon staff working on the issue, I am also experiencing a crash when trying to access settings from a remote w10 desktop. The problem seems highly random, sometimes the app crashes, sometimes it doesn’t. I noticed that if a wait a couple of minutes and try again (or reinstall the app) the settings would be accessible again.

Hope this will be resolved soon.


1 Like

Thanks! Very useful and can confirm it solved the issue for me too (on Mojave OS, Roon 1.8 943).

Unfortunately, it appears that the issue has not been rectified in today’s release of Build 952. At least not for me. Just installed 952 on to my sonicTransporter and M1 MacBook Air. First click on Settings in the sidebar initiated an instantaneous quit of Roon on the MacBook. Re-opened and repeated the attempt…same result. Re-opened again and used workaround [Cmd + ,] which successfully opened the Settings pane. And, like before, using the keystroke command that one time has successfully ‘unlocked’ the ability to use click in the sidebar again.

Since workarounds exist, this is certainly not the most significant issue in the world. Just pointing out that the nuisance is still there. Perhaps in the next build. :slight_smile:

1 Like

Hi everyone,

As @jonathan pointed out, we have not implemented a direct fix for this issue with the most recent build (Build 952). I recognize it’s frustrating to see another weekend pass with a “non-update,” but we do have a ticket in on this issue and it remains a priority. I’ve included some workarounds and a solution that has resolved the issue for some users below.

Temporary Workarounds:

Option 1. Click on your Roon profile (circle with initials or your uploaded photo). Then select “Manage Profiles” → Settings to access and change your settings.

Option 2 (Mac Only). Use the universal keystroke shortcut for application settings: Command-comma [⌘ ,].

Another Troubleshooting Step to Try:

Clear your GMS cache (resolved issue for some users). To clear:

  • Exit out of Roon\RoonServer on the affected device
  • Navigate to your Database Location \Database\Registry\Client folder path
  • Locate and delete any file that starts with GMS
  • Start Roon again and let us know if the issue is resolved

Connor… thank you for keeping us appraised. :+1:

I’d like to clarify the Mac keystroke shortcut for application settings, however.
It’s actually Command-comma [⌘ ,] and not Command-plus sign. I probably did an awkward job of conveying what the keystrokes were in my initial post and may have created a bit of confusion. :upside_down_face:


Adding some data point here. I have been using Roon on Mac >1yr and it had been very stable. The setting crash only set in very recently after I’ve been playing with extensions. It happens the most when the extension manager has been running a long time and Roon got restarted with the extensions still active. If I shutdown the machine that hosts the extension and then restart Roon and go into Settings, it works very well. Then going to Extensions to watch the extensions come back as the ext-host machine comes back up. Everything works till the next restarting of Roon. Rinse, repeat.

I have same problem.

I’m running Roon server on a NUC PC (not running ROCK) , and I’m running the Roon remote on a Microsoft surface pro (windows 10) + an iPhone. When I click on the settings menu, Roon crashes.

any progress to fix the issue?

Hi @Jean-Claude_Gallard, @leafy

Our QA team has been diligently working on a permanent fix that we hope to roll out shortly. I appreciate your patience in the meantime.

As a workaround, you can access settings on your Remote devices by selecting “Manage Profiles” after clicking on your Roon avatar.

We’re aware of how irritating this problem can be and it’s a high priority. I should have an additional update soon to provide to the channel.


Hi everyone,

The team has a fix in the pipeline for this issue, so we should have a firm timeline to resolution shortly.

We’d like to thank everyone for reporting this issue and for helping us to gather relevant details and logs. I’ll post another update as soon as I have the precise date for when the fix will be released.

1 Like

Hi everyone,

We have implemented a direct fix for this issue in the most recent release, Build 970. You can read the full release notes here.

Please update to Build 970 on your Core and all Remotes to implement the change on your devices.

Thank you again for your help and reports as we worked to pin down this issue.