Build 943 crashes when accessing the settings menu [Solved: Update to Build 970]

It fixed itself

Yes, this was me… I deleted the topic because the problem went away all by itself…

I tried this several times… start the MacOS client and access the Settings menu… crash. I restarted the Core, but same. No evidence in Core logs. Just when I was looking at the Roon log on the iMac the problem went suddenly away…

Interesting. This seems to have gone away for me, too, after waiting. No idea what’s going on here, but I’ll leave this for the Roon folks, in case they can track something down.

Mine started crashing now. Was completely fine after the update… until now.

Latest version of Monterey.

@support please give us a hand here :slight_smile:

That’s weird. On the feedback thread another user reported the same problem on a MS Surface running Windows 11. I just updated an older MacBook Pro (Big Sur) and after the update it didn’t crash when selecting the Settings menu… Roon App on the iMac which yesterday crashed (Catalina) after recovering from this problem all by itself continues working fine.

No idea what is going on. I updated to the latest build the other day and all worked fine until now.

Restarting ROCK and all remotes does not change this behaviour.

Same. Latest Monterey on remote computer. Crashes as soon as I click on “Settings” in Roon.

I can access settings on the older MBP running Core on Big Sur.

Hi @Chris_Gelatt, thank you for bringing this issue to our attention, and we’re glad to hear it’s resolved for now.

@RBO, I appreciate you reporting that the problem is persistent. Looking through the logs, the crash consistently occurs while Roon loads graphical elements. We can try to clear the GMS files to reset the GUI component of the app as a first step.

Be sure to first create a Backup of your Roon database. Next, exit out of Roon and navigate to your Database Location\Roon\Database\Registry\Client and delete any file that starts with GMS.

@John_Steinberg, I’m sorry to hear this Core is now having a problem. Please also try clearing GMS files using the above instructions, and we’ll work from there.

Let me know if it helps, and we’ll be standing by.

1 Like

Cheers @connor.

Will follow your instructions when I get back home. Unless the issue cleared itself like others reported.

1 Like

After a blackout today at my place, during which both Roon Core and the Remote on the iMac were shut off, now after restarting Core and Remote the Roon App again crashes when trying to access the Settings menu.

Will give it half an hour (it plays music…), and if the problem doesn’t go away as it did yesterday, I’ll follow @connor’s recommendation.

Edit: Just tried again and the problem once more went away by itself. It is as if some client-side library’s instantiation was delayed… Anyway, this is new after yesterday’s update.

1 Like

Last night and still this morning, when I click “Settings” the Controller crashes and closes. The Core on my server continues to run and play music.

Any thoughts on what is going on here?

No idea really. This happened to me and others when updating Roon app on MacOS. But after waiting for some 10-15 minutes the problem went away. No more crashes since then.

Mine still closes… impossible to do anything without settings available. My controller is a Surface running Windows 11.

1 Like

So it’s not only MacOS which is affected. I’d say let Roon App on the Surface running for some time and try again. If this doesn’t go away from itself as was the case for me and at least another user who reported the same issue, then I’d recommend you open a support thread.

Thank you… I will let it run for a while and try again. I do not ever recall having a major issue like this with an update, and I have used Roon for many years.

There is something weird going on. I just now updated the Roon App on an old MacBook Pro I sometimes use as Remote. Updated fine and didn’t crash when selecting the Settings menu… The problem doesn’t seem to be widespread. Otherwise we’d have seen a deluge of messages on the board.

I have installed the app on various apple devices on hand, laptops, iPads and iPhones and have not experienced any issues across 6 devices.

You’re not alone :slight_smile:

So, this seems to be an issue with the latest update. It is time for Roon Support to jump in here and address this.

It is not just the iOS version, but also the Windows version that exhibits this problem. And honestly, this is a huge issue… it either needs to be fixed or the update rolled back now.


Hi @Randy_Myers,

Thank you for reporting this issue, and I’m sorry you’re experiencing a crash as well. The tech support team is investigating, and I’ll report back with next steps as soon as we have more information. I appreciate your patience in the meantime.