Build 943 crashes when accessing the settings menu [Solved: Update to Build 970]

Roon doesn’t crash for me when entering settings. I just checked. Qnap code I pad pro remote.

Mine also works without issues :thinking:

1 Like

Hi Connor.
I have the same problem on my MacBook Pro running the latest macOS and Roon releases.
I’ve deleted the GMS files as per your instructions, but the Roon app still crash if I try to reach the settings tab.
Please help.

Thanks you, Pino.

So glad for you, but it does for many of us. It is a huge issue that needs to be resolved. I also think that Roon needs to include a rollback option for future updates.

1 Like

Yes, I appreciate your frustration, but I posted so people don’t think this is an issue for everyone. There must be a particular issue in your set up, which needs to be discovered.

Evidently not for everyone, but for enough users to not simply assume it’s a particular issue of a particular setup. Many affected users seem to be running on MacOS, but there have been reports of the problem on other OS, too.

I appreciate that Roon is aware, taking this seriously and investigating to crush the bug.

1 Like

I have a Windows setup, and I have been running Roon for many years now (pretty much since the very beginning). I am also a professional software developer, database administrator, and system administrator. This is the absolute first time that an update caused an issue for me. Assuming it is in my particular setup is very much a mistake.

I am running a Falcon Northwest PC which was customized to my specs as my server machine. I also completely minimize Windows footprint to the absolute minimal for top performance. I run two pieces of software on this machine. Roon and HQPlayer.

I use a Microsoft Surface as my controller. I did the suggested check, which did not work. The issue is most probably in the controller software, not the server/core. When Settings closes Roon whatever is playing continues. Also, the suggestion was to delete a file which is actually located on the controller machine.

I also believe that moving forward Roon needs to include a rollback option so that users are not affected when issues arise and while they work to resolve them. This is usually considered an absolute minimal when programming updates for virtually any software applicaiton.

1 Like

It is in your set up if roon have made an error in how the client works on a Microsoft Surface. Their issue being relevant to your set up as opposed to a Lenovo user.
I believe Chris was alluding to an individual’s infrastructure setup not how they have set their infrastructure up.
BTW due to the nature of the hobby professionals in IT are strewn across the forum.

A surface is a standard PC in tablet format from the company that builds the OS. It runs Windows 11 and I guarantee you there no difference in how it runs the controller software than other PC machines, such as Lenovo.

Yes i know but it has a different graphics card and drivers and roon build their interface using their own custom graphics engine which screws up all the time on graphics changes. So…
I had various surfaces when i worked at Microsoft. Where we were all alpha testers for OS variants on Surfaces.

I get where you are coming from, but it does not have a unique graphics card. It uses the Intel graphics built into the CPU. It is a new enough CPU that it can run Windows 11 (which really only runs correctly on CPUs that are under three years old). But most importantly it has run flawless and unless I missed it, I do not believe Roon made any changes to the GUI which could be affected by graphics.

Also, the screen and interface work perfect, the only issue is when the Settings button (or link) is clicked. At this point Roon literally closes. Therefore, no settings, audio, about (to verify both core and controller version for example), storage, etc. are unavailable. I can use Roon and listen to music, but I can change nothing… surprising how much I use this function now that I can’t.

I do not know, but I am guessing that the settings screen runs on a different screen, and the main Roon interface screen closes when it opens. However, the Settings screen simply does not open, therefore it appears as if Roon has crashed… this is only my speculation of course…

To actually verify that Roon is crashing, one can simply use task manager and see Roon vanishing from Processes tab, but RoonAppliance remaining, which keeps music playing…

But then again in a separate server/core setup the appliance or core is on another machine, and it indeed does continue playing music.

Separating the core from the GUI is far and away better performance than having both on single machine.

There may, of course, be a more widespread problem with Roon. The symptoms you describe are similar to reports about crashing on IOS devices but not necessarily when accessing the settings screen…:thinking:

Clicking Settings still crashes Roon controller, however I have figured out a work around. I click manage profiles in the top right-hand corner of the screen. Under profile I gain access to the functions that I would get from the Settings button/link. Hopefully this can help others.


Getting crashes again after the remote’s been playing ball for a few days.

Deleting the GMS files did not solve the problem

That is very helpful, thank you!

You are welcome Bert… I was actually a tad surprised that no one from Roon suggested this after I discovered it. I never tried manage profiles ever before, but it does seem to access all (or most?) of the settings functions.

Strange enough is that after I used your workaround I can access the settings again without a crash.