Build 952 Feedback

Simple; until the most recent software upgrade, this had never happened before. Now all three client devices have flickering connections.

I am also trying to look at my cellular incoming service.

Spoke to soon. First issue observed.
Both my desktop and phone software lose volume control ability (Roon volume DSP) when coming out of an unused state (for sometime) to an active state.

I.e. I use Roon App, lock phone for 5 mins, reopen phone into Roon app = No Volume or control.

Solution is to close the app and reopen. Doesn’t happen every time.
Phone is running build 952.

It will always be a mixture of both. Of course, I’m too stupid to understand or get everything right, but the developers haven’t found everything that makes the system secure, fast and stable again either. Small example:

Of course I found the button where the gameplay works, but Roon/Qobuz could give me a little more information.

Of course I found the way back to the playlist, clicked on the artist and got this nice picture.

Of course I then found the album and was happy to get something new from this artist on my ears again.

Thanks Roon, but there is still work to do, because Qobuz sends you with the current program code in an interface that does not always work.

A deep look into the logs shows quite a lot. The Restart solution should be considered temporarily.

Interestingly my iPad running the older app which seems to refresh the connection on use has no issue.

1 Like

Yeah, the need for a reboot on a Windows machine is there. I reboot mine (manually) each 15 days… making it daily and automated would interfere with some e-mail backups I have active but since my server just crashed this night due to memory I think I will have to consider your suggestion with better care. Thanks for sharing your experience and giving me something to think!

Now here I go uninstalling and reinstalling the core and restoring from backups… maybe that helps.

(But I still hope Roon solves it sooner than later).


huge memory leak issues on this build, needs a reboot roughly every 4 hours. Those reporting issues with the remote ios etc, volume not working, if you reboot the server it will solve it. Update fixes need urgently


KEF LSX connected via Ethernet will no longer maintain a connection to my ROCK. Was unable to maintain a link via Google Mesh, but Ethernet was fine under previous builds.

Just got back from a week in Virginia.
Updated my win10 remote and Antipodes Core and…holy smoke!!

I have never seen such a fast start up.
Everything is lightning fast and all artwork is just there instantly.
Not sure what they did exactly to affect my simple system so much but I like it.

Sorry that others are not experiencing the same results though.

Can confirm I’m also seeing a massive memory leak.

[ 9441.112703] oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/system.slice/roonserver.service,task=RoonAppliance,pid=984,uid=0
[ 9441.112828] Out of memory: Killed process 984 (RoonAppliance) total-vm:35070392kB, anon-rss:12722048kB, file-rss:0kB, shmem-rss:0kB, UID:0 pgtables:43192kB oom_score_adj:0
1 Like

edit: could be a network issue at my side, investigating.


The button still doesn’t work on ios. Not sure if it ever worked…

As a software developer I’m very surprised that such simple issues are still not fixed… I can only imagine how many errors are under the hood…

Once again, as with every Roon update so far this year, the audio takes yet another quantum leap in sound quality. Pretty soon I will need a bigger house to fit all the musicians in the room with me. :grin:

Great work by Team Roon!


I’m also having issues with sporadic unresponsive Pause/Play and Previous/Next buttons. Rebooting Roon controller resolves it sometimes. Rebooting Roon Server on Core has been necessary a few times – streaming from files from drive attached to Core.
Something is amiss in 952.

1 Like

After 8 hours testing, these actions seems to help with memory leak:

  • disconnected Qobuz and Tidal
  • stopped Roon core
  • deleted Roon core cache files
  • restarted Roon core, waited scanning all my local files
  • connected Qobuz
  • connected tidal

Hope I do not jinx it. Been ok with memory usage so far.

1 Like

Are you running Rock? Win? Linux?
I’m on Rock

I can share the observation that temporarily logged off services (Qobuz / Tidal) lift the performance of the Roon - database. I’m still evaluating log data, what exactly happens there, but Qobuz seems to consistently make problems when, for example, for a fresh playlist a few hundred albums and thousands of tracks are to be built up at the same time. Whether that still applies when local is already read in. I must check further.

The iOS remote app repeatedly ‘crashes’ but actually it seems the app isn’t crashing, it’s going into the background as if I have pressed the home button.
A double tap reveals Roon is still open, but with a blank screen as the image, and selecting it opens the last screen from a blank screen.
iOS 15.5 iPhone 8plus


I’ve just tried enabling Reset Roon remote on next start-up (Setting within IOS settings). I guess this or reinstalling the app could be tried.

1 Like

Well, that did not work. Using around 9gb of RAM after staying overnight. And growing. It was stable the whole day, being used a lot through different remotes. However while idle, during the night, the memory leak appeared. Not even a backup was scheduled for this night. Strange.

Updating: one of my macs was on sleep mode overnight with Roon Remote open and “active” (a song was paused on an endpoint and I forgot about it) - maybe the new architecture for connecting quickly with remotes for the core is keeping it working and leaking the memory? Even if the remote was on a sleeping mac?

1 Like

I just had a song stuck again after playing through 12 titles… instead of rebooting roon, I just turned the DAC off and on again.

Instantly fixed the issue.

So I wonder if the issue has to do with how roon communicates with the DAC through USB?

1 Like