Build 952 Feedback

These remote problems seem to be getting worse. Today I had two Win remotes freeze simultaneously. I was fumbling around like an idiot trying to press pause so I could answer a call. I ended up hurriedly turning off my Pre.

My faithful Roon companion seems to have caught COVID. I hope after a week of isolation, Team Roon is going to release a vaccine.



952 results in a crash after another. Roon is mostly unusable here. Roon Server runs on a Win 10 system. Problems started 2 or 3 updates ago and are getting worse. Use beta testers and slow these buggy releases. They are really no fun.


@support, any statement on the current issues a lot of users have with 952 would be greatly appreciated. My Nucleus runs fine, at least up to now, but a lot of people here are annoyed and a few are getting impatient.
I think it is not a good idea to not comment on anything?

1 Like

The memory leak seems to appear particularly when I leave a ropieee XL endpoint connected to a khadas tone 2 pro upscaling to dsd 512 paused after playing a bit.

When it happens the leak is so aggressive it crashes my whole windows 10 pro server overnight.

Considering deactivating Roon core altogether until Roon team chimes in.


@Marcelo_Bulgueroni thanks for the observation. We need a lot of cool heads in the community right now to soberly analyze and tell the team what background might be playing a role. Together, a complete picture and improved code or interface coordination with service providers will then emerge.

Find this:

Maybe not observed everywhere, but further tracking could be worthwhile for several people:

Memory compression (QNAP/Synology) and the use of SWAP technology (Ubuntu-Linux) fills the memory barrel to overflowing?

I do not use it and do not have these problems, however, is also no proof against.


Unfortunately I am also having issues with this build.
These are the most serious I have experienced. After a period of indeterminate length my end-points seem to hang, music will continue playing, but the player controls stop working or take an incredibly long time to function. Moving to any other screen (Home, Genres, etc.) will fail to load anything. When I reload the end point, all is well again… until the next time.
My end points are on iOS and Mac-OS, and the problem occurs with both.
I have the 64bit server running on a dedicated NUC with Windows 11.
Not sure whether any of that makes sense or is helpful, but thought I’d share.


Having the exact same experience as Martin above. Only I am using a Nucleus Plus as core and an Android Amazon Fire as the player.

1 Like

Have exactly the same problems. iPad remote/NUC-Rock.
Hope Roon will fix this as soon as possible.

I hate to sound like a mee too, but updated this morning when I got back form my holiday.

No issues with Roon Core (on Rock) so far, but multiple Windows failures on the client already today.

First time it did not update any albums that were added to the library, and was just spinning like t was about to do something, a client restart and all good.
Second and third times the music stopped tracking what was playing, and seemed to just lock up, closing and restarting it fixed it again.
At least restarting the client fixes it.

1 Like

This is in fact exactly what I am experiencing now with 952 release.

This is what i have been experiencing since before 952. I did not update as i did not want more problems. Mine freezes and a forced shutdown restart gets it working again … until it doesnt.


Ok so this has never really happened to me before today. I will monitor over the next few days, but I am guessing it’s like this until at least the next build

I’ve had Windows 10 lockups since build 952.

EDIT: Upgrading to the latest video drivers on Intel and NVIDIA seemed to help a little.

Well with the new faster development cycle we will hopefully get an improved build within a couple of weeks


So I have just had my first core restart in several years
While playing music this evening :scream_cat:

My same problem (previously reported here) resolved itself it seems.

And me who used to love roon :unamused:

Update Error message when clicking on “About” I rebooted core, but stil the same error message. Backup to Dropbox executed this morning, but was excruciatingly slow, took 3 hours. Could be related. This was after the backup completed.

also seeing the “error checking for an update” message on all roon devices. @support ?

Screwed the pooch big time with this update. A better way is needed, an ability to go back to a stable build or simply opt into the push updates? Don’t know but these incremental and often meaningless “feature upgrades” are not worth the headache for me.

I’d rather upgrade to a known stable build every few months and when meaningful features are introduced if give the option to do so.